XBoot 3.21

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

Post Reply
User avatar
Gaiyan
Hardware Guru
Hardware Guru
Posts: 542
Joined: Tue Jun 29, 2004 3:39 pm
Contact:

XBoot 3.21

Post by Gaiyan »

This deserves it's own thread to consolidate the latest info. Earlier I discovered that XBoot 3.10 was the latest official version despite there being a 3.20 release which I had patched. This 3.20 version turned out to be ELiTE's own versioning based on Vectronix's XBoot 3.10 crack.

At one point, after adding MagiC 6.20 ROMs to my MonSTer STacy, I realized that XBoot no longer worked, as TOS was never booted. This is when I discovered that the 3.20 patch also had included a patch to prevent it from working in MagiC to prevent XBoot from appearing twice during boot. This didn't work for me so I created and announced my version that ran under MagiC and called it 3.21.

Realizing that this will create confusion as my MagiC use case is quite niche and uses a later version number. I have therefore combined both of my XBoot 3.x patches into one release with two different binaries. From my part there is only XBoot 3.21; one that runs in MagiC, and one that doesn't. The two versions are packaged in their own folders and the in-app info clearly distinguishes the two:
Xboot 321.png
Xboot Magic.png
Another major change is the total re-creation of the manual. The current one is an enhancement done by myself from a very poor-quality source but it wasn't good enough. I painstakingly OCRd what I could and manually created the whole documents with new graphics.

Please enjoy, what I consider to be one of the best utilities for the Atari ST ever!

P.S. The manual is also included in the archive.
You do not have the required permissions to view the files attached to this post.
Image
nagual
Captain Atari
Captain Atari
Posts: 492
Joined: Mon Sep 11, 2006 10:15 am
Location: Frankfurt am Main, Germany

Re: XBoot 3.21

Post by nagual »

Thank you very much for this:-)
Manual is excellent:-)

Cheers!
:cheers:
User avatar
Gaiyan
Hardware Guru
Hardware Guru
Posts: 542
Joined: Tue Jun 29, 2004 3:39 pm
Contact:

Re: XBoot 3.21

Post by Gaiyan »

nagual wrote: Thu Oct 08, 2020 9:50 am Thank you very much for this:-)
Manual is excellent:-)

Cheers!
:cheers:
Glad you like it, thanks!

Josh.
Image
bj
Atari Super Hero
Atari Super Hero
Posts: 511
Joined: Sun Sep 21, 2003 10:30 am
Location: London

Re: XBoot 3.21

Post by bj »

Great! Thanks
regards
BJ
marss
Captain Atari
Captain Atari
Posts: 240
Joined: Thu Nov 07, 2002 12:29 pm

Re: XBoot 3.21

Post by marss »

Thanks
mikro
Hardware Guru
Hardware Guru
Posts: 2839
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: XBoot 3.21

Post by mikro »

Wow, that's what I call dedication. :) Great job!
User avatar
dhedberg
Atari God
Atari God
Posts: 1353
Joined: Mon Aug 30, 2010 8:36 am
Contact:

Re: XBoot 3.21

Post by dhedberg »

Wow! Thanks!
Does it work on the CT60 as well?
Daniel, New Beat - http://newbeat.atari.org.
Like demos? Have a look at our new Falcon030 demo It's that time of the year again, or click here to feel the JOY.
User avatar
Gaiyan
Hardware Guru
Hardware Guru
Posts: 542
Joined: Tue Jun 29, 2004 3:39 pm
Contact:

Re: XBoot 3.21

Post by Gaiyan »

Thanks guys!

I don't have a CT60 to test it with.

A reminder, that my website has a review roundup of XBoot
Image
User avatar
leech
Atari God
Atari God
Posts: 1386
Joined: Tue Dec 01, 2015 3:26 pm

Re: XBoot 3.21

Post by leech »

Nice, I will test in the morning on ct60/SV.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 596
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: XBoot 3.21

Post by Bikerbob »

Thank you for the quality manual.

Loving it!

James
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
User avatar
mpattonm
Hardware Guru
Hardware Guru
Posts: 708
Joined: Mon Oct 21, 2002 8:52 am
Location: Czech republic
Contact:

Re: XBoot 3.21

Post by mpattonm »

leech wrote: Sat Nov 28, 2020 7:53 am Nice, I will test in the morning on ct60/SV.
Hi, did you succeed? Because it does not appear to work for me.
Rustynutt
Atari God
Atari God
Posts: 1658
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: XBoot 3.21

Post by Rustynutt »

After reading (the very nicely scanned manual :)), with the SV think i would try and place it after the SV driver. At least boot without the driver first to try.
Haven't had the chance to try this yet.
Also maybe try booting both SV and TOS at 640*480 16 or 256 color, at least as a starting point, and monitor the Falcon video out the same time as being connected to the DVI (if setup to do this).
User avatar
calimero
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2563
Joined: Thu Sep 15, 2005 10:01 am
Location: Serbia
Contact:

Re: XBoot 3.21

Post by calimero »

So what is alternative for CT60 and SuperVidel?
using Atari since 1986.http://wet.atari.orghttp://milan.kovac.cc/atari/software/ ・ Atari Falcon030/CT63/SV ・ Atari STe ・ Atari Mega4/MegaFile30/SM124 ・ Amiga 1200/PPC ・ Amiga 500 ・ C64 ・ ZX Spectrum ・ RPi ・ MagiC! ・ MiNT 1.18 ・ OS X
User avatar
mpattonm
Hardware Guru
Hardware Guru
Posts: 708
Joined: Mon Oct 21, 2002 8:52 am
Location: Czech republic
Contact:

Re: XBoot 3.21

Post by mpattonm »

Rustynutt wrote: Mon Feb 08, 2021 8:07 am After reading (the very nicely scanned manual :)), with the SV think i would try and place it after the SV driver. At least boot without the driver first to try.
Haven't had the chance to try this yet.
Also maybe try booting both SV and TOS at 640*480 16 or 256 color, at least as a starting point, and monitor the Falcon video out the same time as being connected to the DVI (if setup to do this).
I did only try on CT60 alone - XBoot did not launch.
Rustynutt
Atari God
Atari God
Posts: 1658
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: XBoot 3.21

Post by Rustynutt »

Noticed on a CT63 "essential" floppy disk there are a couple of cache on cache off programs.
I've always ran it with cache on, the CPX only allows a 5 second delay, but not to disable it. But that's far to late to aid any programs run before that point.
With the 040 Afterburner, those were handy tools.
Wondering if cache off placed before XBoot in the auto folder, then cache on in the list directory of programs chose to boot with might get it going.
Apologies for not trying it yet myself. Im monkeying around yet with file check for exf2 and F32 partitions....
User avatar
alienkidmj12
Captain Atari
Captain Atari
Posts: 294
Joined: Sat Mar 10, 2012 6:45 pm

Re: XBoot 3.21

Post by alienkidmj12 »

would be nice to obtain sourcecode for this, any ideas who might have it ?
Post Reply

Return to “Applications”