Current situation with Cosmos?

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

Post Reply
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Current situation with Cosmos?

Post by Bikerbob »

Hey all, those that are reading.

I am having issues with my microcosmosEX.
20220220_214210.jpg
I have been using 4-5 different usb sticks over the last few years for file transfers, different sets of drives that I like to use etc.. depending on machine I have the cosmos connected to.

It was working last month.. this month.. I cannot see any Translated drives. Either RAW or Translated (FAT-16/32) I did not change anything.

I run HDDRIVER 11.09 I have tested on 4 different machines. I was getting some under voltage messages when powering from the cosmos miniusb - none if I power from the pi3b microusb. Hd driver is seeing messed up IDE sometimes as well. Of course I could turn them off.
20220222_145229.jpg
What is the current situation? I have tried here, and Facebook, looking at the GITHUB - nothing has been updated or answered in a long while. I see here there are some others like nanard and Mikro who have helped with development. I know Jookie has not been around here in a bit.

IS what I am doing now in posting still the best way to try and get this issue fixed?

James
You do not have the required permissions to view the files attached to this post.
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Current situation with Cosmos?

Post by Bikerbob »

attached are my logs from the CE device and the PI3b... I have no idea why the cosmos is not seeing things.. but the PI3b seems to be working fine.

I decided to put a new burn of the Stretch image on.. its on.. same deal.. did the update.. same deal.
You do not have the required permissions to view the files attached to this post.
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
mikro
Hardware Guru
Hardware Guru
Posts: 2746
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Current situation with Cosmos?

Post by mikro »

AFAIK, Jookie is partly burnt-out, partly working on some new CE iterations but doesn't have time (or energy) to spend on fixing bugs. Expi (the main person) is busy with non-Atari things and generally we all know that his reply rate wasn't great even in the past.

And I can only state my regret that I'd agreed to put my name on that website because all I did was to participate in some discussions, tested the device in my Falcon before Expi started with shipping and fixed 3-4 bugs. And now "everyone" think that I'm somehow connected to the project and even worse, responsible for it.
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Current situation with Cosmos?

Post by Bikerbob »

mikro wrote: Fri Feb 25, 2022 11:55 am AFAIK, Jookie is partly burnt-out, partly working on some new CE iterations but doesn't have time (or energy) to spend on fixing bugs. Expi (the main person) is busy with non-Atari things and generally we all know that his reply rate wasn't great even in the past.

And I can only state my regret that I'd agreed to put my name on that website because all I did was to participate in some discussions, tested the device in my Falcon before Expi started with shipping and fixed 3-4 bugs. And now "everyone" think that I'm somehow connected to the project and even worse, responsible for it.
OH... sorry Mikro.. :( Well in general I love my CosmosEX.. update - I did find out why I had the under voltage issue.. a small particle of metal I guess from my bench get into the device on the cosmos end - not the pi3b and landed across 2 pins of the Xylix chip.. Last night I took it all apart and put it under a magnifing glass and saw it.. I sprayed the boards with alcohol and blew it clean with compressed air.. everything they way is good again. no under voltage issue.

LITERALLY everything works EXCEPT SHARED drives will not display on the atari and no translated drives will mount.. but USB mouse works.. WIFI dongle works. ASCI is working fine.

So.. what about the idea that I need to reflash chips? is that something I can do?

James
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
simonsunnyboy
Moderator
Moderator
Posts: 5455
Joined: Wed Oct 23, 2002 4:36 pm
Location: Friedrichshafen, Germany
Contact:

Re: Current situation with Cosmos?

Post by simonsunnyboy »

mikro wrote: Fri Feb 25, 2022 11:55 am AFAIK, Jookie is partly burnt-out, partly working on some new CE iterations but doesn't have time (or energy) to spend on fixing bugs. Expi (the main person) is busy with non-Atari things and generally we all know that his reply rate wasn't great even in the past.

And I can only state my regret that I'd agreed to put my name on that website because all I did was to participate in some discussions, tested the device in my Falcon before Expi started with shipping and fixed 3-4 bugs. And now "everyone" think that I'm somehow connected to the project and even worse, responsible for it.
That's sad to hear :(

I don't want to press you either but is there anywhere interface documentation available?
What to do on the RPi side and what to do on the Atari ACSI side to create new "devices"?

I was short of asking jookie on FB but now reading your comment, I feel hesitant to do so.
Simon Sunnyboy/Paradize - http://paradize.atari.org/

Stay cool, stay Atari!

1x2600jr, 1x1040STFm, 1x1040STE 4MB+TOS2.06+SatanDisk, 1xF030 14MB+FPU+NetUS-Bee
mikro
Hardware Guru
Hardware Guru
Posts: 2746
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Current situation with Cosmos?

Post by mikro »

I think you can ask Jookie, no problem there. He's just fed up with bug reports/development but I think he is always open to discuss new ways of using his hardware. :)
stormy
Atari God
Atari God
Posts: 1244
Joined: Tue Jan 26, 2016 12:39 pm

Re: Current situation with Cosmos?

Post by stormy »

I almost decided to make my own device to sell to the atari community, but the thought of having to support it and answer questions put me off and I decided to just not make it at all. It's a shame because it was a device that would revolutionise ataris and I would have been famous. I can live in my medrocity quite happily though.
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Current situation with Cosmos?

Post by Bikerbob »

OK, SO.. Jessie distro has helped - weird.. but I now get translated drives to show up.. but just like the share when it does not connect I get the mount.err

So this further says to me this is a firmware/software issue not hardware.
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Current situation with Cosmos?

Post by Bikerbob »

stormy wrote: Fri Feb 25, 2022 5:32 pm I almost decided to make my own device to sell to the atari community, but the thought of having to support it and answer questions put me off and I decided to just not make it at all. It's a shame because it was a device that would revolutionise ataris and I would have been famous. I can live in my medrocity quite happily though.
thats a shame. :(
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 595
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Current situation with Cosmos?

Post by Bikerbob »

Jookie did get back. I also examined the board under a very strong set of magnifying glasses and discovered a flake of metal that had bridged two pins of the Xilinx chip.. cleared that up.. had to downgrade and then re-upgrade the Raspbian install, and things started working again.. SO back in business.
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
simonsunnyboy
Moderator
Moderator
Posts: 5455
Joined: Wed Oct 23, 2002 4:36 pm
Location: Friedrichshafen, Germany
Contact:

Re: Current situation with Cosmos?

Post by simonsunnyboy »

I'm glad to hear you got your device working again.
Simon Sunnyboy/Paradize - http://paradize.atari.org/

Stay cool, stay Atari!

1x2600jr, 1x1040STFm, 1x1040STE 4MB+TOS2.06+SatanDisk, 1xF030 14MB+FPU+NetUS-Bee
dlsa
Atarian
Atarian
Posts: 1
Joined: Tue May 10, 2022 5:04 pm

Re: Current situation with Cosmos?

Post by dlsa »

Hello,
Did you get the shared drive working ? Mine does not appear in TOS.
Thanks,
Regards
Post Reply

Return to “CosmosEx”