68060 CLKEN CLK pins

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, [ProToS], moondog/.tSCc., lp, Moderator Team

Post Reply
Rustynutt
Atari God
Atari God
Posts: 1359
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

68060 CLKEN CLK pins

Post by Rustynutt »

For some time been using a couple different 68060 to 68040 adapters on an Afterburner.
So far no luck.
One I have now is from the Amiga world.

Got to looking at Rodolphe schematics. He drives the CT60 at full bus speed, feeding the CLK what would be the PCLK on the 68040, and pulls the CLKEN high via a resistor.

The Amiga versions tie the 68040 BCLK to CLKEN to operate the bus at half speed of the CPU. But it leaves the CLK pin floating.

Shouldn't the CLK pin get the 040 PCLK and CKLEN the BCLK?

Or as on the CT60, be pulled low or high ?
The 68060 user manual doesn't go that deep, other than a frequency chart which I'm not to sure what it's telling me.
czietz
Hardware Guru
Hardware Guru
Posts: 1614
Joined: Tue May 24, 2016 6:47 pm

Re: 68060 CLKEN CLK pins

Post by czietz »

Are you sure the 060's CLK is really floating on your adapter? This cannot work! I would guess the 040's PCLK is still connected to the 060's CLK. Check with a multimeter.
Rustynutt
Atari God
Atari God
Posts: 1359
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: 68060 CLKEN CLK pins

Post by Rustynutt »

czietz wrote: Tue Jul 27, 2021 12:42 pm Are you sure the 060's CLK is really floating on your adapter? This cannot work! I would guess the 040's PCLK is still connected to the 060's CLK. Check with a multimeter.
Yes, you are correct :)

Testing two separate PCB, PCLK and CLK do meet at the same place.
With the adapter slightly pressed together, the connection is not good at the pins.

Am moving the regulator to bottom side out of the way, then will reassemble tightly and test again!
User avatar
shoggoth
Nature
Nature
Posts: 1099
Joined: Tue Aug 01, 2006 9:21 am
Location: Halmstad, Sweden
Contact:

Re: 68060 CLKEN CLK pins

Post by shoggoth »

I'm using an Amiga on in my Milan, and it worked out of the box.

I suspect the AB040 isn't quite that straight forward though because the TOS + patches aren't 060-ready.
Ain't no space like PeP-space.
Rustynutt
Atari God
Atari God
Posts: 1359
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: 68060 CLKEN CLK pins

Post by Rustynutt »

Yes, something there for sure.
MOVEP for one.
I tried EmuTOS from ROM and it would not boot the AB.

Have found an older took kit which allows independently setting the PMMU tree up, thinking that might get EmuTOS pass the hump.

Don't think the same issues Amiga has with the math library are of concern with TOS.
Rustynutt
Atari God
Atari God
Posts: 1359
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: 68060 CLKEN CLK pins

Post by Rustynutt »

shoggoth wrote: Tue Jul 27, 2021 7:25 pm I'm using an Amiga on in my Milan, and it worked out of the box.

I suspect the AB040 isn't quite that straight forward though because the TOS + patches aren't 060-ready.
BTW, did you modify the Milan 74AS version IC's to allow bus speed over 16MHz? Mine is an early Milan, 16/32 with the 040 is as fast as it can run.
Rustynutt
Atari God
Atari God
Posts: 1359
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: 68060 CLKEN CLK pins

Post by Rustynutt »

Looks like there are two basic AB Tool Kits, one released at the time if the board, and another Doug Little developed after manufacturing was sold to another company.

On the English side, Doug Little, haven't had luck making contact myself.
I guess for my own work, if I could ever understand the code enough to make changes, that's fine for me. But what of the other 5 to 6 Afterburner users remaining in the world, what of them ? :)
Post Reply

Return to “CT60 / CT63 Area”