Obsession ball launch issue

A forum for anything about the STEem Engine STE emulator, comments, problems, bug reports etc. The current version is v4.0.2. All support queries should be posted on the SourceForge site.

Moderators: Mug UK, Steem Authors, Moderator Team

Post Reply
EdSalisbury
Atarian
Atarian
Posts: 2
Joined: Thu Apr 22, 2021 2:29 am

Obsession ball launch issue

Post by EdSalisbury »

Hey guys, using Steam SSE v4.1.0 and trying to play Obsession -- I know that the down arrow is supposed to launch the ball, but all it does it make a "snap" noise and the ball only moves slightly (like the key isn't being able to be held down) - I know that the joystick can interfere with this, and have disabled the joystick completely as far as I can tell, but still no dice. Anyone else have an ideas on what to try? I've tried different TOS versions (1.62 UK and US), without avail, and I've also tried the PP HD version. It definitely *seems* like some sort of key repeat issue or something, as it's registering the keydown, but not holding it.

Thanks for any help you can provide!
User avatar
dma
Atari God
Atari God
Posts: 1181
Joined: Wed Nov 20, 2002 11:22 pm
Location: France
Contact:

Re: Obsession ball launch issue

Post by dma »

Maybe you got some accessibility functionality activated on your OS?
Have you tried it on Hatari, just to compare?
seedy1812
Atari freak
Atari freak
Posts: 68
Joined: Tue May 18, 2010 2:04 pm

Re: Obsession ball launch issue

Post by seedy1812 »

Cursor down to pull back the spring and space to shake the table ( tilt ) In here ( https://web.archive.org/web/20170402053 ... /obsession ) its says the shift keys are for the flippers
EdSalisbury
Atarian
Atarian
Posts: 2
Joined: Thu Apr 22, 2021 2:29 am

Re: Obsession ball launch issue

Post by EdSalisbury »

So, just tried in Hatari, and it worked just fine. I can create a bug report I guess? I wanted to see if anyone else is tried it to confirm... Thanks!
User avatar
dma
Atari God
Atari God
Posts: 1181
Joined: Wed Nov 20, 2002 11:22 pm
Location: France
Contact:

Re: Obsession ball launch issue

Post by dma »

OK, i just tried the game :
- PPera's HD version, "OBSESS.ZIP",
- on a fresh download of "Steem.SSE.4.1.0.Win64.D3D.R6.zip",
- running it with "TOS v1.62 (1990)(Atari Corp)(STE)(UK)",
- and using GEMDOS hard drive emulation.

The game's working, and i can long press down arrow key to adjust the plunger's power, then the ball goes to the top, rolls on the table, and all. No problem on that then.

Only (really) weird thing is that, after the password screen, no more music in the game, not on menu, not in game, only sfx.
WTFF i'd say. And this also happens on Hatari.
I then tested a disk version "Obsession (1994)(Unique Development Sweden)(Disk 1 of 2)[cr Vectronix]" (+ second disk), and the music is fine on it.
Post Reply

Return to “Steem”