POV 44 & 45 - Good images?

This is where you post all your requests for demos, intros, pubtros etc...

Moderators: Mug UK, lotek_style, Moderator Team

jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

POV 44 & 45 - Good images?

Post by jamesrc »

Does anyone have a good image of POV 44 or POV 45?

For POV 44:

Every copy I can find, the Secret Seperation demo bombs before it finishes loading. 3 bombs and then 4 on the STe, and 3 bombs on the STFM.

Granted I've only tried on the MiST and under emulation, but it's consistent in both cases.

I suspect a bad disk image.

For POV 45:

The Land of the Giants demo simply reboots the ST instead of loading.
mlynn1974
Captain Atari
Captain Atari
Posts: 443
Joined: Mon Mar 03, 2008 10:33 pm
Contact:

Re: POV 44 & 45 - Good images?

Post by mlynn1974 »

For POV 45 atari_mark says:
"I checked out POV45 and it is the actual demo. I just never got round to fixing it."
https://www.atari-forum.com/viewtopic.php?f=2&t=6456
Still got, still working: Atari 4Mb STe, 520STFM (x2), 2.5Mb STF, Atari 2600JR, Flashback 8 Gold.
Hardware: Cumana CSA 354, Ultimate Ripper, Blitz Turbo, Synchro Express II (US and UK Versions).
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

mlynn1974 wrote: Wed Nov 04, 2020 12:14 am For POV 45 atari_mark says:
"I checked out POV45 and it is the actual demo. I just never got round to fixing it."
https://www.atari-forum.com/viewtopic.php?f=2&t=6456
Sounds like he's saying it didn't work on Steam or SainT in 2005...

Also doesn't work on my MiST board for me. Or the latest Hatari. I guess we need someone to test on real hardware.
User avatar
RealLarry
Captain Atari
Captain Atari
Posts: 195
Joined: Sat Jan 31, 2015 12:05 pm
Location: San Junipero

Re: POV 44 & 45 - Good images?

Post by RealLarry »

Just tested pov44 & 45 on my STE/4MB/TOS2.06 (stuck at 2.06 as something went weired with my homebrew DualTOS and/or it's switch):

- Secret Seperation bombs away with three. Found a demo of the same name at http://www.atarimania.com/demo-atari-st ... 26495.html which runs fine. Dunno if it's the same demo as in pov44
- Land of the Giants just resets the STE. No way to test it, yet.

All other demos are working...the ABC demo/pov45 is showing some grabled scrolling graphics, but same with hatari.
You do not have the required permissions to view the files attached to this post.
On the other side of the screen, it all looks so easy.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

Thank you! Yes -- I see that same corrupted scroller on the Jive Bunny demo, so it seems those are bad disks. I interpreted Mark/MSD's comment in the other thread to mean that these disks didn't work under emulation, but it seems the copies floating around on the Internet don't work on real hardware, either. Funny they'd be grouped together like this. (Consecutive disks, 44 and 45).

I tried several copies from different sources. Exxos. No Fragments. Demozoo. And whatever random copy I had lying around on a hard drive from 15-20 years ago. Same result on all of them.

Edit: I tried different configurations -- STe (TOS 1.62) and STFM (TOS 1.02 and 1.4). I also tried both 1mb and 2mb setups. I didn't bother with 512K as these demos are 1 meg only.
mlynn1974
Captain Atari
Captain Atari
Posts: 443
Joined: Mon Mar 03, 2008 10:33 pm
Contact:

Re: POV 44 & 45 - Good images?

Post by mlynn1974 »

On POV45 LOTG.CV is packed with Pack-Ice but Multi-Depack can't depack it. The first few hundred bytes look corrupt.
It is a STOS BASIC program compiled with the STOS Compiler so it may have been patched incorrectly for TOS 1.4.
I can't find the original Land Of The Giants demo anywhere so it would be hard to make a working version of POV45 without it :(
Still got, still working: Atari 4Mb STe, 520STFM (x2), 2.5Mb STF, Atari 2600JR, Flashback 8 Gold.
Hardware: Cumana CSA 354, Ultimate Ripper, Blitz Turbo, Synchro Express II (US and UK Versions).
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

mlynn1974 wrote: Thu Nov 05, 2020 12:48 am On POV45 LOTG.CV is packed with Pack-Ice but Multi-Depack can't depack it. The first few hundred bytes look corrupt.
It is a STOS BASIC program compiled with the STOS Compiler so it may have been patched incorrectly for TOS 1.4.
I can't find the original Land Of The Giants demo anywhere so it would be hard to make a working version of POV45 without it :(
Thanks for looking. I wonder if POV44 is salvageable.

I will try out a regular non-packed copy of Secret Seperation. I found this because I'm trawling through all 165 POV disks and watching every demo (reading all scroll text in most cases) and validating they work on the MiST's phenomenal MiSTery core.

I've reported a few bugs in that core, but it seems to make sense when I find a bad disk (and find no fixed version) to report that to the community at large, too. I'm sure some of this stuff nobody has looked at in many years!

It's a shame that Land of the Giants seems lost to time!
mlynn1974
Captain Atari
Captain Atari
Posts: 443
Joined: Mon Mar 03, 2008 10:33 pm
Contact:

Re: POV 44 & 45 - Good images?

Post by mlynn1974 »

Ahh! Land of the Giants is here:
https://ftp.untergrund.net/users/ltk_ts ... /ZONE_TRP/

On POV 45 there is something wrong with LOTG.CV. The original LOTG.PRG compresses down to about the same size but it seems 12k was chopped off the end of the LOTG.SPL to fit it on 82 tracks, 10 sectors, 2 sides. I made a disk image with 11 sectors but changing the disk contents causes AUTORUN3.PRG to complain. I might try to "fix" POV 45 at the weekend.
Still got, still working: Atari 4Mb STe, 520STFM (x2), 2.5Mb STF, Atari 2600JR, Flashback 8 Gold.
Hardware: Cumana CSA 354, Ultimate Ripper, Blitz Turbo, Synchro Express II (US and UK Versions).
mOa
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 147
Joined: Sun May 12, 2002 11:53 pm

Re: POV 44 & 45 - Good images?

Post by mOa »

Hello

here's POV44 fixed using another source demo

I have a bunch of others POV menus fixed for STe (mostly STOS demos patched)

Nice found: I was looking for this Land of Giants for a while

The remaining POV with non fixed issues are POV 106,150,162 (and 105 partly fixed)

Thank you
You do not have the required permissions to view the files attached to this post.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

Oh, my!

Thank both of you! I'll grab this fixed 44 later today and also the LOTG demo. Although, mlynn1974, if you do manage to fix up 45 at the weekend then I might just wait for that disk.

Fantastic work!
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

mOa,

Are your other fixed POV disks out there in people's collections, or are they posted somewhere?
mOa
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 147
Joined: Sun May 12, 2002 11:53 pm

Re: POV 44 & 45 - Good images?

Post by mOa »

These are my own collection. Roughly 40 disks / 30 Mb. I can upload them if people are interested
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

mOa wrote: Thu Nov 05, 2020 5:13 pm These are my own collection. Roughly 40 disks / 30 Mb. I can upload them if people are interested
I'm definitely interested.
User avatar
atari_mark
Captain Atari
Captain Atari
Posts: 198
Joined: Thu Oct 10, 2002 12:30 pm
Location: Wigan, England
Contact:

Re: POV 44 & 45 - Good images?

Post by atari_mark »

here's POV44 fixed using another source demo
This crashes on Steem v4, TOS 1.62 and 2.06. Tried STFM and STE emulation with both 1MB and 2MB but I still get 3 bombs. Strange how my original worked back in 1990. I will find my original floppy and try in on real hardware.

MSD/POV
Mac Sys Data/Persistence Of Vision

Instructions said to install Windows 2000 or better so I installed Fedora.
User avatar
atari_mark
Captain Atari
Captain Atari
Posts: 198
Joined: Thu Oct 10, 2002 12:30 pm
Location: Wigan, England
Contact:

Re: POV 44 & 45 - Good images?

Post by atari_mark »

Real Atari STe hardware, original floppy and it works!
Mac Sys Data/Persistence Of Vision

Instructions said to install Windows 2000 or better so I installed Fedora.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

atari_mark wrote: Thu Nov 05, 2020 6:38 pm Real Atari STe hardware, original floppy and it works!
I'm sure it's the image itself that's bad. Been plenty of those floating around over the years.

Any chance you could re-image it and try? :)
mOa
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 147
Joined: Sun May 12, 2002 11:53 pm

Re: POV 44 & 45 - Good images?

Post by mOa »

atari_mark wrote: Thu Nov 05, 2020 6:19 pm
here's POV44 fixed using another source demo
This crashes on Steem v4, TOS 1.62 and 2.06. Tried STFM and STE emulation with both 1MB and 2MB but I still get 3 bombs. Strange how my original worked back in 1990. I will find my original floppy and try in on real hardware.

MSD/POV
Hello MSD
I'm using STEem v4 too with 2mb + french TOS 1.62 and it works perfectly. Can someone confirm this please?
Maybe my TOS is wrong. Sorry
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

mOa wrote: Thu Nov 05, 2020 8:24 pm Hello MSD
I'm using STEem v4 too with 2mb + french TOS 1.62 and it works perfectly. Can someone confirm this please?
Maybe my TOS is wrong. Sorry
I'll give it a whirl with Steem tonight.
Last edited by jamesrc on Thu Nov 05, 2020 9:14 pm, edited 1 time in total.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

Can confirm that MoA's fixed version works for me on Steem SSE 4 in STe mode with 2mb and TOS 1.62.
IMG_3949.jpg
Also works on the MiSTery FPGA core on an STe with 1mb RAM with either TOS 1.62 or TOS 2.06.
IMG_3950.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
atari_mark
Captain Atari
Captain Atari
Posts: 198
Joined: Thu Oct 10, 2002 12:30 pm
Location: Wigan, England
Contact:

Re: POV 44 & 45 - Good images?

Post by atari_mark »

Removed STEEM, downloaded a new copy, sorted my TOS, downloaded the fixed POV44 and..... it works! Thanks MoA for fixing it.

I tried STEEM on a different PC and it threw an error about a missing d3dx9_43.dll. To top it all, my actual STe is now crapping out using pputnik's hard disk driver :(. I appear to be having brain issues from not using an ST for a long time.

Mark
Mac Sys Data/Persistence Of Vision

Instructions said to install Windows 2000 or better so I installed Fedora.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

atari_mark wrote: Thu Nov 05, 2020 9:43 pm I tried STEEM on a different PC and it threw an error about a missing d3dx9_43.dll. To top it all, my actual STe is now crapping out using pputnik's hard disk driver :(. I appear to be having brain issues from not using an ST for a long time.
It happens to all of us. Thanks for 165 POV disks!

And thanks again, MoA. I'd very much like to get your other fixes, if you've got the time, as I plan to go through every disk in this collection over the next weeks and months.
User avatar
atari_mark
Captain Atari
Captain Atari
Posts: 198
Joined: Thu Oct 10, 2002 12:30 pm
Location: Wigan, England
Contact:

Re: POV 44 & 45 - Good images?

Post by atari_mark »

It happens to all of us. Thanks for 165 POV disks!
Thanks for the comment.

I have had POV166 on my hard disk for the past 20 years waiting to be completed. The menu works but I figured there was no point in completing more compilations in a world where we have the internet.
Mac Sys Data/Persistence Of Vision

Instructions said to install Windows 2000 or better so I installed Fedora.
jamesrc
Captain Atari
Captain Atari
Posts: 175
Joined: Fri Aug 12, 2005 11:33 pm
Location: Austin, TX, USA
Contact:

Re: POV 44 & 45 - Good images?

Post by jamesrc »

atari_mark wrote: Thu Nov 05, 2020 10:00 pm I have had POV166 on my hard disk for the past 20 years waiting to be completed. The menu works but I figured there was no point in completing more compilations in a world where we have the internet.
I get the argument about ultra fast Internet and cheap storage just allowing us to have everything.

But on the other hand, I've got a 4mb Atari STe (or at least an incredibly accurate hardware recreation of one) that I chose to spend time playing Stunt Car Racer and Obsession Pinball on when I've got a modern gaming PC with 16,384 times the RAM sitting just five feet away. My point is that if we cut out things that have no point to them then none of us would be sitting around here playing with old computers at all.

There's a certain authenticity that comes from compilations. Personally I love them; so, if you're soliciting opinions, I'd say finish POV 166.

Of course, it's your time, and time is a precious commodity. :)
User avatar
RealLarry
Captain Atari
Captain Atari
Posts: 195
Joined: Sat Jan 31, 2015 12:05 pm
Location: San Junipero

Re: POV 44 & 45 - Good images?

Post by RealLarry »

jamesrc wrote: Thu Nov 05, 2020 5:25 pm
mOa wrote: Thu Nov 05, 2020 5:13 pm These are my own collection. Roughly 40 disks / 30 Mb. I can upload them if people are interested
I'm definitely interested.
+1
On the other side of the screen, it all looks so easy.
mOa
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 147
Joined: Sun May 12, 2002 11:53 pm

Re: POV 44 & 45 - Good images?

Post by mOa »

Here is POV 45 100% fixed at last!

Land of The Giants was STOS so fixed for STe too

Enjoy!
You do not have the required permissions to view the files attached to this post.
Post Reply

Return to “Demos - Requests”