Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

I always had to use an acsi drive image to run magic under emulation. Gemdos didn't work. At least under Steem.
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

calimero wrote: Thu Mar 04, 2021 7:37 pm MagiC change names over time... I can not say for sure but it was Mag!X before ver. 3... so possible that MagiCDesk also was “newer” name for Magxdesk....
Yes, that's true. But the application is named MagXdesk, so i changed that in the about dialog, for consistency.
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 13070
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by wongck »

calimero wrote: Thu Mar 04, 2021 7:37 pm Btw
MagiC change names over time... I can not say for sure but it was Mag!X before ver. 3... so possible that MagiCDesk also was “newer” name for Magxdesk....
Yeah I noticed that back in the days as well.
I thought that it was just translation from German to English. :P
I have no idea if "magic" is spelled as "magix" in German or not, but I just assumed it to be back then.
( no Internet/Google to check at that time... probably had to go to the library so I didn't.... just being lazy)

Edit... just did a Google translate and nope, magix did not translate to magic
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff that are no longer for sale due to them over 30 years old - click here for list
User avatar
Fujiyama
Atari Super Hero
Atari Super Hero
Posts: 833
Joined: Thu Jul 12, 2007 8:21 am
Location: Norway

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Fujiyama »

ThorstenOtto wrote: Thu Mar 04, 2021 6:07 pm Yes, uploading happens automatically after building so they should already be available ;)

For Hatari, you should maybe file a bug report, either here in a different thread, or on the mailing list. But GEMDOS emulation is maybe restricted there to single-tos versions. In aranym, i use an harddisk image and betados, because of similar problems (the hostfs driver is only available for mint)
I need to look closer into Hatari as there's probably stuff in the manual I've missed. I just set it all up quick and easy so I can test out downloaded Atari stuff and setups before transferring it over to my STe (using a CF card).
I haven't looked into disk images yet, but maybe I should.


MagiC 6 looks great now.
N_AH0000.png
A couple of comments/questions:
- should the version number and date be changed to reflect the changes (however small)? This would avoid some confusion
- to be really nitpicky, there's an "x" in "MagxDesk Vx5.02" :wink: Maybe even the "V" can be omited, just leaving the version number (i.e. "MagxDesk 5.02) -I can't remember what it said before (when it was commercial). But again, I'm being very nitpicky here :D
- should there be a little notice in the same "About MagiC" window about the software status (free, license type etc. website URL for further updates etc)? You should also put your name in there of course!
- Using "LEDpanel" in the AUTO folder (so the time/date can be displayed in the menu bar) I noticed that the date is shown in the US way (month-day-year) but I want to have it shown the European way (day-month-year). If I recall correctly the time is displayed in the US/UK way as well (am/pm instead of the 24 hour format).
Is there an option for this somewhere, or do two different English-language versions need to be compiled for this?
On the same STe, the date is displayed correctly (TOS 2.06), but I believe I used a UK TOS version.
You do not have the required permissions to view the files attached to this post.
Last edited by Fujiyama on Sat Mar 06, 2021 8:16 pm, edited 1 time in total.
STe | MonSTer with dual IDE-CF adapter | NEC Multisync 1990SXi | ST_ESCC | RSVE | WB Systemtechnik Link '97 | Sony HD floppy drive w/AJAX | Exxos HD floppy module | Ricoh battery-backed realtime clock module | Discovery cartridge | C-Lab Unitor-2 | C-Lab Export | C-Lab Combiner | C-Lab Steady Eye | C-Lab Human Touch | Unicorn USB

Are you a good person?
User avatar
calimero
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2484
Joined: Thu Sep 15, 2005 10:01 am
Location: Serbia
Contact:

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by calimero »

@Fujiyama
Decade ago, I also did not understand difference betwen “gemdos” drives and ide or asci images in Hatari (I do believe that Steem have same).

Gemdos drive in emulator is when you map host OS folder to emulator. This gemdos drive have limitations from Atari/TOS side!

To be sure that stuff in emulators are 100% same as on real hardware, you should use ide/asci image in emulator.
using Atari since 1986.http://wet.atari.orghttp://milan.kovac.cc/atari/software/ ・ Atari Falcon030/CT63/SV ・ Atari STe ・ Atari Mega4/MegaFile30/SM124 ・ Amiga 1200/PPC ・ Amiga 500 ・ C64 ・ ZX Spectrum ・ RPi ・ MagiC! ・ MiNT 1.18 ・ OS X
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

Fujiyama wrote: Sat Mar 06, 2021 12:08 pm MagiC 6 looks great now.
Good!
- to be really nitpicky, there's an "x" in "MagxDesk Vx5.02" :wink:


Should also be fixed now. It was a bit more serious than just the "x", because of the change in the text, the number was copied to the wrong place...
Is there an option for this somewhere, or do two different English-language versions need to be compiled for this?
On the same STe, the date is displayed correctly (TOS 2.06), but I believe I used a UK TOS version.
That would require compiling a version for COUNTRY=UK. But the only place were that makes a difference is when setting the IDT cookie (the keyboard table can already be replaced by copying the keytable to \gemsys\magic\xtension\keytabls.sys). On machines that have NVRAM, that setting can be changed there. Do you have a tool maybe that can change the value of the _IDT cookie?
User avatar
Fujiyama
Atari Super Hero
Atari Super Hero
Posts: 833
Joined: Thu Jul 12, 2007 8:21 am
Location: Norway

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Fujiyama »

I don't know of any tool which allows for doing this, although I have a couple of CPX modules which can display which cookies are in use and their values.
I just found DTCOOKIE12.lzh (Date/Time cookie) which looked promising but wasn't self-explanatory in a way to create cookies, so I need to look into the German documentation (alas my school-German is lacking).

Does anyone reading know of other ways to create/change this date/time "_IDT" cookie?
STe | MonSTer with dual IDE-CF adapter | NEC Multisync 1990SXi | ST_ESCC | RSVE | WB Systemtechnik Link '97 | Sony HD floppy drive w/AJAX | Exxos HD floppy module | Ricoh battery-backed realtime clock module | Discovery cartridge | C-Lab Unitor-2 | C-Lab Export | C-Lab Combiner | C-Lab Steady Eye | C-Lab Human Touch | Unicorn USB

Are you a good person?
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

Fujiyama wrote: Sun Mar 07, 2021 8:28 pm I just found DTCOOKIE12.lzh (Date/Time cookie) which looked promising
I dont think it would had helped in this case, since it only install an _IDT if none exists already, and there is no way to specify its value (it just uses default values based on the setting from the ROM header).
Does anyone reading know of other ways to create/change this date/time "_IDT" cookie?
I've added some code now to make it possible to set the value of the IDT cookie in the magx.inf. The new line looks like

Code: Select all

idt=$112f
and must be placed in the #[boot] section. The default values for the different languages are explained at https://github.com/th-otto/MagicMac/blo ... gx.inf#L79

BTW, i just realized that MagiC does not even use the values from NVRAM. That would be the next task, i guess.
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

Thanks, downloaded the new version.

I noticed In the English "EXTRAS" folder, you have a magx.inf example file.

But, It is the German version and it is for V6 and missing the V6.20 updates.

Can you add the English version to the distribution and maybe update the German one with the v6.20 changes?

Here are the parts missing in the V6 .inf file:

Code: Select all

; new from MagiC 6.20
;	biosdev
;	con
;	aux
;	prn

Code: Select all

; Determination of the BIOS devices.
; As without changes to MAGX.INF a few filenames would be missing
; in u:/dev from MagiC 6.20 onwards, here are a few examples for
; various computer types that have to be supplemented:

;Atari ST:
;biosdev=3,u:\dev\midi
;biosdev=6,u:\dev\modem1

;Atari Mega-STE:
;biosdev=3,u:\dev\midi
;biosdev=6,u:\dev\modem1
;biosdev=7,u:\dev\modem2
;biosdev=8,u:\dev\serial2

;Atari TT:
;biosdev=3,u:\dev\midi
;biosdev=6,u:\dev\modem1
;biosdev=7,u:\dev\modem2
;biosdev=8,u:\dev\serial1
;biosdev=9,u:\dev\serial2

;Atari Falcon:
;biosdev=3,u:\dev\midi
;biosdev=6,u:\dev\modem1
;biosdev=7,u:\dev\lan

;Mac:
;(none)

;The GEMDOS standard files can now also be redirected to BIOS
;devices that are present in u:\dev:
;con=u:\dev\console
;aux=u:\dev\modem
;prn=u:\dev\prn

Here is a v6.21 English magx.inf file that could be used (of course remove forum-dictated .pdf extension):

magx.inf.pdf
You do not have the required permissions to view the files attached to this post.
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

TheNameOfTheGame wrote: Mon Mar 08, 2021 3:37 pm I noticed In the English "EXTRAS" folder, you have a magx.inf example file.

But, It is the German version and it is for V6 and missing the V6.20 updates.
Unless i missed something, that was the only file with explanations in Andreas' sources.
Here is a v6.21 English magx.inf file that could be used (of course remove forum-dictated .pdf extension):
Yes, thanks, i will update it.
User avatar
Fujiyama
Atari Super Hero
Atari Super Hero
Posts: 833
Joined: Thu Jul 12, 2007 8:21 am
Location: Norway

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Fujiyama »

Cool!
And would you mind adding new version numbers/dates to the "About MagiC" window, reflecting the update, to avoid any confusion since they all look the same now?

Regarding MAGX.INF -back in the day I used a utility called MAGICCFG.APP (MagiC-configurator) which allowed for a point & click user interface for changing all those parameters. The docs say "knows every flag and segment up to MagiC version 6.01" so obviously it won't allow changing of those new parameters in 6.20, but does anyone know if it just leaves them alone when changing more "general" parameters (common for all MagiC versions), or does it remove any parameter it doesn't recognize when you save MAGX.INF from it?
Last edited by Fujiyama on Mon Mar 08, 2021 4:29 pm, edited 1 time in total.
STe | MonSTer with dual IDE-CF adapter | NEC Multisync 1990SXi | ST_ESCC | RSVE | WB Systemtechnik Link '97 | Sony HD floppy drive w/AJAX | Exxos HD floppy module | Ricoh battery-backed realtime clock module | Discovery cartridge | C-Lab Unitor-2 | C-Lab Export | C-Lab Combiner | C-Lab Steady Eye | C-Lab Human Touch | Unicorn USB

Are you a good person?
User avatar
Fujiyama
Atari Super Hero
Atari Super Hero
Posts: 833
Joined: Thu Jul 12, 2007 8:21 am
Location: Norway

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Fujiyama »

ThorstenOtto wrote: Mon Mar 08, 2021 2:55 pm
Fujiyama wrote: Sun Mar 07, 2021 8:28 pm I just found DTCOOKIE12.lzh (Date/Time cookie) which looked promising
I dont think it would had helped in this case, since it only install an _IDT if none exists already, and there is no way to specify its value (it just uses default values based on the setting from the ROM header).
Does anyone reading know of other ways to create/change this date/time "_IDT" cookie?
I've added some code now to make it possible to set the value of the IDT cookie in the magx.inf. The new line looks like

Code: Select all

idt=$112f
and must be placed in the #[boot] section. The default values for the different languages are explained at https://github.com/th-otto/MagicMac/blo ... gx.inf#L79

BTW, i just realized that MagiC does not even use the values from NVRAM. That would be the next task, i guess.
Excellent! I will give it a go when the new MAGX.INF file has been included.
A little off-topic, but is something similar possible with TOS 2.06 as well? Maybe someone reading might know.
STe | MonSTer with dual IDE-CF adapter | NEC Multisync 1990SXi | ST_ESCC | RSVE | WB Systemtechnik Link '97 | Sony HD floppy drive w/AJAX | Exxos HD floppy module | Ricoh battery-backed realtime clock module | Discovery cartridge | C-Lab Unitor-2 | C-Lab Export | C-Lab Combiner | C-Lab Steady Eye | C-Lab Human Touch | Unicorn USB

Are you a good person?
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

Only took a quick look (most of the processing is done in https://github.com/th-otto/MagicMac/blo ... rce/file.c), and from what i understand, it should copy all unknown entries from the original to the destination. But has to be checked.
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

Fujiyama wrote: Mon Mar 08, 2021 4:29 pm A little off-topic, but is something similar possible with TOS 2.06 as well? Maybe someone reading might know.
For TOS that should not be neccessary (provided you use the UK version). For magic this was only needed, because there is only one english version, and that is compiled for COUNTRY=us
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

ThorstenOtto wrote: Mon Mar 08, 2021 3:59 pm
TheNameOfTheGame wrote: Mon Mar 08, 2021 3:37 pm I noticed In the English "EXTRAS" folder, you have a magx.inf example file.

But, It is the German version and it is for V6 and missing the V6.20 updates.
Unless i missed something, that was the only file with explanations in Andreas' sources.
Here is the German 6.20 magx.inf file if it can be helpful.

MAGX.INF.pdf
You do not have the required permissions to view the files attached to this post.
User avatar
Fujiyama
Atari Super Hero
Atari Super Hero
Posts: 833
Joined: Thu Jul 12, 2007 8:21 am
Location: Norway

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Fujiyama »

ThorstenOtto wrote: Mon Mar 08, 2021 4:43 pm
Fujiyama wrote: Mon Mar 08, 2021 4:29 pm A little off-topic, but is something similar possible with TOS 2.06 as well? Maybe someone reading might know.
For TOS that should not be neccessary (provided you use the UK version). For magic this was only needed, because there is only one english version, and that is compiled for COUNTRY=us
Yes, you're right. Using the UK TOS 2.06 would provide English language and the European date/time standard.
STe | MonSTer with dual IDE-CF adapter | NEC Multisync 1990SXi | ST_ESCC | RSVE | WB Systemtechnik Link '97 | Sony HD floppy drive w/AJAX | Exxos HD floppy module | Ricoh battery-backed realtime clock module | Discovery cartridge | C-Lab Unitor-2 | C-Lab Export | C-Lab Combiner | C-Lab Steady Eye | C-Lab Human Touch | Unicorn USB

Are you a good person?
User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 565
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Mark_G »

Here is the German 6.20 magx.inf file if it can be helpful.
MAGX.INF.pdf
The file seems to be corrupt ?
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

Mark_G wrote: Mon Mar 08, 2021 5:16 pm
Here is the German 6.20 magx.inf file if it can be helpful.
MAGX.INF.pdf
The file seems to be corrupt ?
Simply remove the .pdf extension. The forum software requires certain extensions to be able to upload files.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 2229
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Cyprian »

I've just checked that .inf and Magic boots to the fileselector.
When I try to run any application I see a dialogbox: "Insufficient memory (Error #-39"
Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.atari.org
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

Oh, it is just an example .inf to show all the available options (from the distribution EXTRAS folder).

It should be tailored to individual needs before using it as the working copy.
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1738
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by TheNameOfTheGame »

What about integrating the XaMagiC code that Gerhard Stoll wrote?

If it was integrated in the MagiC source, then it would eliminate the need for trapper to be running.

Code: Select all

XaMagiC
-------

XaMagiC is add some AES functions from other AESs.

At the moment ist support:
- all know appl_getinfo() modes.
- appl_control with the mode APC_HIDE, APC_SHOW, APC_TOP and APC_HIDENOT.


Install
-------
XaMagiC needs Trapper (from Manfred Lippert). You can start it from the desktop
or copy it to your APPS folder. Which ist defined in the magx.inf with #_APP.


History
-------

Version 0.03 (2008-12-26)
- Disaple the extended mode from appl_getinfo (96).
- In appl_getinfo some infos are only present if the correct MagiC version runs.
- appl_control with the mode APC_HIDE, APC_SHOW, APC_TOP and APC_HIDENOT

Vesion 0.02
- Extended mode from appl_getinfo (96)

Version 0.01
- New appl_getinfo modes

For developer
-------------
XaMagiC use the TOS and GEM library form Martin Els„sser (http://acspro.atari.org/)


Gerhard Stoll
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 2229
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Cyprian »

TheNameOfTheGame wrote: Mon Mar 08, 2021 6:08 pm Oh, it is just an example .inf to show all the available options (from the distribution EXTRAS folder).

It should be tailored to individual needs before using it as the working copy.
ok, I've commented most lines and now I see the desktop.
Now I've faced another issue - I'm not able to save a new configuration into MAGIC.INF. I tried also with empty file. Could it be AHDI issue?
grab0002.png

---EDIT---
MagxDesk's "Save Options" works fine.
It's seems Magic-Conf has an issue.
You do not have the required permissions to view the files attached to this post.
Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.atari.org
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 2229
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Cyprian »

BTW, would be possible to add a support for Hatari/Steem GEMDOS drives?
Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.atari.org
ThorstenOtto
Atari God
Atari God
Posts: 1521
Joined: Sun Aug 03, 2014 5:54 pm

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by ThorstenOtto »

What do you mean with support? That's not a matter of the kernel. And in AtariX you already have an emulated GEMDOS drive (although currently hardcoded to only use drive M:)
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 2229
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Bildschirm-treiber nicht gefunden" (MagiC/NVDI) error

Post by Cyprian »

I mean that currently Magic can't boot from Hatari/Steem GEMDOS drive (I see only "Offscreen-treiber nicht gefunden"). Also, when it is booted from ACSI drive it can't see Hatari/Steem GEMDOS drive.
Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.atari.org
Post Reply

Return to “Applications”