Warzone / Core Design / 1991

Game requests go here.

Moderators: simonsunnyboy, Mug UK, ICS, Doctor Bob Gordon, Moderator Team

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Warzone / Core Design / 1991

Postby dlfrsilver » Thu Apr 26, 2018 8:15 pm

Hello guys, i have a problem with this game. I dump the original i bought to an ST guy on facebook.

The disk was dirty, i cleaned it, made a kryoflux dump, a CTR, an IPF and an STX file.

The game use a copylock ST on track 0.0, and the remaining are ST tracks with 10 sectors each.

Problem : Steem 3.9.3 is unable to make the game work on every config i tried. The game was done by John Kirkland, and in 1991, so the game should run on ST and STE.

Second part of the problem, i have no errors on disk, and the copylock encodes correctly. Problem : The loading stops with a HALT.

Steven or any ST cracker/coder can take a look ? thanks :)

Files below :)
You do not have the required permissions to view the files attached to this post.
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Sun Apr 29, 2018 2:12 pm

Anyone can help ? Nick Pomaredes, if you come around, can you have a look at why Warzone doesn't work (on Steem) and Hatari please ?
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Sun Apr 29, 2018 8:34 pm

Hi,

Strange, didn't decrypt the loader yet, but it seems to fail when looking for something at track 1. It never attempts to read the copy protected sector at track 0.

It might be a bad Pasti conversion. Please provide or email the RAW files.

It is known if the disk actually works?

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Sun Apr 29, 2018 8:49 pm

ijor wrote:Hi,

Strange, didn't decrypt the loader yet, but it seems to fail when looking for something at track 1. It never attempts to read the copy protected sector at track 0.

It might be a bad Pasti conversion. Please provide or email the RAW files.

It is known if the disk actually works?


Hi Ijor, I need to know if anything has been tampered. the CTR file fails, the IPF fails, and the STX file fails. Problem : no track has been modified. that's why i'm pulling my hair out.

About the protection track, it goes on it directly at the start. it tries to read sector 253 / track 0 / side 0
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Sun Apr 29, 2018 9:12 pm

dlfrsilver wrote:Hi Ijor, I need to know if anything has been tampered. the CTR file fails, the IPF fails, and the STX file fails. Problem : no track has been modified. that's why i'm pulling my hair out.


I have a possible idea what's going on. Please PM me a link to the RAW images.

About the protection track, it goes on it directly at the start. it tries to read sector 253 / track 0 / side 0


It tries to read sector 253 on track 10, not on track 0. There is no such a sector 253 on any track anyway. But it fails much later, and it doesn't ever attempt to read the actual protection that is, as usual, on sector 6.

Again, please let me see the low level dump.

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Mon Apr 30, 2018 9:21 pm

Check your PM :)
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Sun May 06, 2018 2:20 am

any news about this dump gentlemen ?
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Mon May 07, 2018 1:47 pm

Hi, I didn't have much time to check, but at first glance I don't see any obvious issue.

Do you know if the original disk actually works? Did you try to write back the image?

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Mon May 07, 2018 4:01 pm

... ah ... I think I know what happens, I'll confirm later, please stand by :)

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Mon May 07, 2018 6:27 pm

Ok, yes, it was as I suspected ...

The problem is that the index pulse position is wrong. It is not correctly aligned with the data and then the copy protection fails when looking for the first header when performing a read track. This is a common check on most CopyLock protections.

Conceivable it is a duplication defect or the disk is a copy, but much more likely the problem is the drive that was used to produce the image. Every drive has a slightly different index pulse alignment. But on some PC drives the different alignment is quite significant. The original duplication alignment was probably a bit too tight as well or otherwise this shouldn't happen.

I can probably "rotate" the dump and fix this, but if you can, try to dump the disk with a different drive.

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Tue May 08, 2018 1:54 am

Thank you ijor for the look :)
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

User avatar
Brume
Red eyes
Red eyes
Posts: 4166
Joined: Mon Apr 22, 2002 10:16 am
Location: France
Contact:

Re: Warzone / Core Design / 1991

Postby Brume » Tue May 08, 2018 9:14 am

Very interesting, thanks for the reply, ijor.

I don't have original disk of Warzone, but I've taken a look at all Core design games I've dumped. They all use the same CopyLock / Rob Northen protection (some have a different year of release). All work very well with Steem so i was surprised to see Warzone didn't.

Does it mean the original disk of dlfrsilver works or is it faulty?
@dlfrsilver: can you try the game you bought on FB on a real hardware? Thanks :)

Zippy
Captain Atari
Captain Atari
Posts: 166
Joined: Sun Feb 01, 2004 1:58 am

Re: Warzone / Core Design / 1991

Postby Zippy » Tue May 08, 2018 1:00 pm

If it's a normal Rob Northen Copylock protected disk and you want to make a working protected copy from a non-working image you could try using the attached util to copy it over any other working copylock keydisk. It just copies the part required for calculating the "magic number" and leaves the rest of the protected sector alone.
You do not have the required permissions to view the files attached to this post.

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Tue May 08, 2018 1:22 pm

Brume wrote:Very interesting, thanks for the reply, ijor.

I don't have original disk of Warzone, but I've taken a look at all Core design games I've dumped. They all use the same CopyLock / Rob Northen protection (some have a different year of release). All work very well with Steem so i was surprised to see Warzone didn't.

Does it mean the original disk of dlfrsilver works or is it faulty?


The original disk will work or not on real hardware, again, depending on how the drive will align the index and the data. If using the same drive that was used to dump these images, it will probably not work. I assume, but can't be sure without testing on a different drive, that the problem is that the drive used by dlfrsilver has the index alignment displaced significantly.

If so, then the original disk on real hardware will probably work using a different drive, at least with an original Atari branded drive. And an image produced with that drive should also work. The problem is not related to Steem or emulation in general. It is either a problem of the original disk, or the drive used, or both.

Btw, this is a real problem when doing "preservation" with this kind of hardware. The original index position is not really preserved. In most cases it is not very significant because the protections have some tolerance to variations, and because most drives have a rather similar index alignment. But there is no way to know if a given image wasn't produced with such a drive that has the index alignment displaced significantly. So again, the original index position is not preserved unless the drive is somehow calibrated with a disk with the known index position. And I've already seen some Sony drives with the index alignment way off.

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Tue May 08, 2018 2:52 pm

Zippy wrote:If it's a normal Rob Northen Copylock protected disk and you want to make a working protected copy from a non-working image you could try using the attached util to copy it over any other working copylock keydisk. It just copies the part required for calculating the "magic number" and leaves the rest of the protected sector alone.


Very nice. But note that in this case the problem is not the copy protected sector. The protection fails earlier and then it doesn't even attempt to read that sector.

Zippy
Captain Atari
Captain Atari
Posts: 166
Joined: Sun Feb 01, 2004 1:58 am

Re: Warzone / Core Design / 1991

Postby Zippy » Tue May 08, 2018 3:31 pm

Ah OK, I thought it was worth a mention in case the problem was just with the reproduction of the protected sector. :)

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Wed May 09, 2018 12:23 pm

Just to say that i tried the game disk on my 520 STE/4mb. It fails the same as in IPF, STX and CTR. so it's not tied to disk drive, but the disk itself is faulty :/

The duplication went wrong on this disk :(

The disk drive i use works with no problem, i did many Copylock games on both Amiga and ST lately with it.
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Wed May 09, 2018 4:17 pm

Yes, it's possible that it is a duplication defect. But conceivable the original disk might be failing for a different reason.

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Wed May 09, 2018 9:45 pm

ijor wrote:Yes, it's possible that it is a duplication defect. But conceivable the original disk might be failing for a different reason.


Well shame it will not work. This means find another warzone, and since this game is not that easy to find in original for ST, well, finger crossed...
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Thu May 10, 2018 2:46 am

Attached a working Pasti image. It was produced from the RAW images provided by dlfrsilver but shifting the index to the correct position.

Edit: Updated the image to a more complete one.
You do not have the required permissions to view the files attached to this post.

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Thu May 10, 2018 2:12 pm

Thank you !

I use Steem 3.9.3 and there is still a problem. Pasti tell me that : Drive A: Side : 0 Track 10 Read Track attempted without track info !

And then the game loading halts.
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

User avatar
Brume
Red eyes
Red eyes
Posts: 4166
Joined: Mon Apr 22, 2002 10:16 am
Location: France
Contact:

Re: Warzone / Core Design / 1991

Postby Brume » Thu May 10, 2018 3:14 pm

Thanks for the job, ijor. Works fine!
May I ask you how you shifted the index?

@dlfrsilver: it works with TOS 1.0, TOS 1.04 or TOS 1.62 (I use Steem 3.9.4).
Got the same issue as yours with TOS 1.02 only.

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Thu May 10, 2018 4:15 pm

I was lazy with the conversion. I edited the post and uploaded a new version of the image. The track warning should not appear anymore, but for some reason that I didn't check, it's still doesn't work under TOS 1.02. As Brume is saying it works with most, if not all, other TOS versions.

Brume, I made the rotation more or less manually with a custom tool running under a debugger.

User avatar
dlfrsilver
Atari God
Atari God
Posts: 1458
Joined: Mon Jan 31, 2005 1:41 am
Contact:

Re: Warzone / Core Design / 1991

Postby dlfrsilver » Fri May 11, 2018 10:22 pm

Brume wrote:Thanks for the job, ijor. Works fine!
May I ask you how you shifted the index?

@dlfrsilver: it works with TOS 1.0, TOS 1.04 or TOS 1.62 (I use Steem 3.9.4).
Got the same issue as yours with TOS 1.02 only.


It fails under Steem 3.9.3 even under STE/TOS 1.62. I upgrade to steem 3.9.4.

Under Steem 3.9.4. it loads, but i'm stuck on level 1. The commando sprite doesn't appear. :/
Now SPS France representative since the 19th of June 2014. Proud to be an SPS member !

ijor
Hardware Guru
Hardware Guru
Posts: 3629
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Warzone / Core Design / 1991

Postby ijor » Mon May 14, 2018 10:40 am

dlfrsilver wrote:It fails under Steem 3.9.3 even under STE/TOS 1.62. I upgrade to steem 3.9.4.
Under Steem 3.9.4. it loads, but i'm stuck on level 1. The commando sprite doesn't appear. :/


Does it work correctly with STF, TOS 1.0 or 1.02?


Social Media

     

Return to “Games - Requests”

Who is online

Users browsing this forum: No registered users and 1 guest