Auto folder causes sound to be distorted and too fast

Bug reports and support area for Steem

Moderators: Mug UK, Steem Authors, Moderator Team

Forum rules
All bug reports must include:
Steem version
Host operating system version
TOS ROM version
Copy of steem.ini
Reference to or copy of disk image being used
Brief description of steps performed
Description of desired outcome
Description of actual outcome
solrac42
Atarian
Atarian
Posts: 1
Joined: Sat Feb 03, 2018 6:48 pm

Auto folder causes sound to be distorted and too fast

Postby solrac42 » Sat Feb 03, 2018 7:25 pm

Steem version SSE 3.9.4 Win32 D3D
Windows 10 Enterprise Edition 64 bit
TOS Image 1.04
Xenon.stx

steem.ini below

Code: Select all

[Main]
DebugBuild=0
Left=849
Top=2
Width=340
Height=263
Maximized=0
AOT=0
LastSnapShot=E:\Games\Steem.SSE.3.9.4.Win32.D3D\memory snapshots\Carrier Command.sts
SnapShotHistory0=E:\Games\Steem.SSE.3.9.4.Win32.D3D\memory snapshots\Carrier Command.sts
SnapShotHistory1=E:\Games\Steem.SSE.3.9.4.Win32.D3D\memory snapshots\Archipelogos.sts
SnapShotHistory2=E:\Games\Steem.SSE.3.9.4.Win32.D3D\memory snapshots\Battlezone.sts
SnapShotHistory3=
SnapShotHistory4=
SnapShotHistory5=
SnapShotHistory6=
SnapShotHistory7=
SnapShotHistory8=
SnapShotHistory9=
LastCfgFile=E:\Games\Steem.SSE.3.9.4.Win32.D3D\config\
PasteSpeed=2
AdvancedSettings=1

[Update]
CurrentVersion=3.9.4
LatestVersion=3.9.4

[Options]
StartFullscreen=1
Visible=0
Left=717
Top=388
FSLeft=224
FSTop=154
CPUBoost=8021247
AllowTaskSwitch=1
PauseWhenInactive=0
MuteWhenInactive=0
DiskAccessFF=0
AutoLoadSnapShot=0
FrameSkip=8
ShowToolTips=1
SpecificHacks=1
CaptureMouse=0
Chipset1=0
EmuDetect=1
OsdDriveInfo=0
StatusBar=1
StatusBarGameName=0
Chipset2=1
VMMouse=0
OsdTime=0
Brightness=0
Contrast=0
GammaR=0
GammaG=0
GammaB=0
SlowMotionSpeed=100
Page=3
DoAsyncBlit=0
Volume=10000
SoundMode=3
LastSoundMode=3
SoundLowQuality=999
MaxFastForward=0
HighPriority=0
AutoSnapShotName=auto
RunSpeed=1000
ScreenShotFol=E:\Games\Steem.SSE.3.9.4.Win32.D3D\screenshots
ScreenShotFormat=0
ScreenShotExt=bmp
ScreenShotMinSize=0
FinetuneCPUclock=0
NewMemConf0=-1
NewMemConf1=1
NewMonitorSel=-1
NewROMFile=
TOSSortDescend=0
TOSSort=0
StartOnClick=0
MacroDir=E:\Games\Steem.SSE.3.9.4.Win32.D3D\macros
ProfileDir=E:\Games\Steem.SSE.3.9.4.Win32.D3D\profiles
MacroSel=E:\Games\Steem.SSE.3.9.4.Win32.D3D\macros
ProfileSel=E:\Games\Steem.SSE.3.9.4.Win32.D3D\profiles
FSQuitAskFirst=1
LastIconPath=E:\Games\Steem.SSE.3.9.4.Win32.D3D\
LastIconSchemePath=E:\Games\Steem.SSE.3.9.4.Win32.D3D\
OSDDiskLight=1
OSDPlasma=0
OSDSpeed=0
OSDIcons=0
OSDCPU=0
OSDScroller=0
OSDDisable=0
OSDOldPos=0
BlitHideMouse=0

[HardDrives]
Visible=0
Left=702
Top=533
FSLeft=62
FSTop=173
Drive_0_Letter=C
Drive_0_Path=E:\Games\Steem.SSE.3.9.4.Win32.D3D\Hard Drive 01
Drive_1_Letter=NOT ASSIGNED
Drive_1_Path=NOT ASSIGNED
Drive_2_Letter=NOT ASSIGNED
Drive_2_Path=NOT ASSIGNED
Drive_3_Letter=NOT ASSIGNED
Drive_3_Path=NOT ASSIGNED
Drive_4_Letter=NOT ASSIGNED
Drive_4_Path=NOT ASSIGNED
Drive_5_Letter=NOT ASSIGNED
Drive_5_Path=NOT ASSIGNED
Drive_6_Letter=NOT ASSIGNED
Drive_6_Path=NOT ASSIGNED
Drive_7_Letter=NOT ASSIGNED
Drive_7_Path=NOT ASSIGNED
Drive_8_Letter=NOT ASSIGNED
Drive_8_Path=NOT ASSIGNED
Drive_9_Letter=NOT ASSIGNED
Drive_9_Path=NOT ASSIGNED
BootDrive=2
DisableHardDrives=0
AcsiDrive_0_Letter=NOT ASSIGNED
AcsiDrive_0_Path=NOT ASSIGNED
AcsiDrive_1_Letter=NOT ASSIGNED
AcsiDrive_1_Path=NOT ASSIGNED
AcsiDrive_2_Letter=NOT ASSIGNED
AcsiDrive_2_Path=NOT ASSIGNED
AcsiDrive_3_Letter=NOT ASSIGNED
AcsiDrive_3_Path=NOT ASSIGNED
Acsi=0

[Disks]
Visible=1
Left=707
Top=423
FSLeft=97
FSTop=147
Width=506
Height=354
Maximized=0
FSWidth=1694
FSHeight=805
FSMaximized=0
CurrentFolder=E:\Games\Steem.SSE.3.9.4.Win32.D3D\Disk Images
HomeFolder=E:\Games\Steem.SSE.3.9.4.Win32.D3D\Disk Images
Disk_A_Path=
Disk_A_Name=
Disk_A_DiskInZip=
Disk_B_Path=
Disk_B_Name=
Disk_B_DiskInZip=
QuickFol0=
QuickFol1=
QuickFol2=
QuickFol3=
QuickFol4=
QuickFol5=
QuickFol6=
QuickFol7=
QuickFol8=
QuickFol9=
InsertHistoryName00=Xenon Melbourne House.stx
InsertHistoryPath00=E:\Games\Steem.SSE.3.9.4.Win32.D3D\Disk Images\Xenon Melbourne House.stx
InsertHistoryDiskInZip00=
InsertHistoryName01=Xenon Melbourne House - Copy.stx
InsertHistoryPath01=E:\Games\Steem.SSE.3.9.4.Win32.D3D\Disk Images\Xenon Melbourne House - Copy.stx
BytesPerSectorIdx=2
SecsPerTrackIdx=1
TracksIdx=5
SidesIdx=1
ExplorerFolders=0
MSAConvPath=E:\Games\Steem.SSE.3.9.4.Win32.D3D\msa.exe
SmallIcons=0
IconSpacing=1
PastiActive=0
HideBroken=0
HideExtension=0
EjectDisksWhenQuit=1
DoubleClickAction=2
CloseAfterIRR=0
NumFloppyDrives=2
QuickDiskAccess=1
FloppyArchiveIsReadWrite=0
AutoInsert2=0
GhostDisk=0
DriveSoundSeekSample=0
DriveSound=1
DriveSoundVolume=5000
PRG_support=0

[Joysticks]
Visible=0
Left=687
Top=374
FSLeft=47
FSTop=20
JoyReadMethod=1
Setup=0
BasePort=0
MouseSpeed=10

[GeneralInfo]
Visible=0
Left=544
Top=378
FSLeft=-96
FSTop=18
SearchText=
Page=3

[Shortcuts]
Visible=0
Left=667
Top=385
FSLeft=27
FSTop=25
ScrollPos0=0
CurrentCutSel=E:\Games\Steem.SSE.3.9.4.Win32.D3D\shortcuts
CurrentCutSelType=0
CutDir=E:\Games\Steem.SSE.3.9.4.Win32.D3D\shortcuts
SelectedCutFile0=

[Patches]
Visible=0
Left=732
Top=383
FSLeft=92
FSTop=23
SelPatch=3615 HMD DIST
PatchDir=E:\Games\Steem.SSE.3.9.4.Win32.D3D\patches
LastKnownVersion=

[Display]
ScreenShotUseFullName=99
ScreenShotAlwaysAddNum=99
FSDoVsync=0
FullScreenDefaultHz=1
FakeFullScreen=1
Scanlines=0
WinVSync=1
TripleBufferFS=0
Direct3D=1
STAspectRatio=0
BlockResize=0
LockAspectRatio=0
oldD3DMode=0
D3DMode=0
Direct3DCrisp=1
FullScreenGUI=1
ResChangeResize=1
WinSizeLowRes=0
WinSizeMedRes=0
WinSizeHighRes=0
DrawWinMode_LowRes=0
DrawWinMode_MedRes=0
BorderLastChosen=0
BppInFS=0

[Pasti]
version=2
logLevel=1
options=0
warnings=0
fastUnprotTracks=1
fastUnprotDisk=1
speedInfo.slowSectRead=1
speedInfo.slowTrackRead=1
speedInfo.slowRotation=1
speedInfo.slowSpinup=1
speedInfo.slowSettle=1
speedInfo.slowSeek=1
speedInfo.slowVerify=1
speedInfo.slowSnf=1
hardDisk0.enabled=0
hardDisk0.path=
hardDisk0.readOnly=0
PastiJustStx=1

[Joystick 1]
ToggleKey=0
AnyFireOnJoy=0
DeadZone=50
AutoFireSpeed=0
Type=0
DirID0=38
DirID1=40
DirID2=37
DirID3=39
DirID4=17
DirID5=13
DirID6=0
1_ToggleKey=0
1_AnyFireOnJoy=0
1_DeadZone=50
1_AutoFireSpeed=0
1_Type=0
1_DirID0=65535
1_DirID1=65535
1_DirID2=65535
1_DirID3=65535
1_DirID4=65535
1_DirID5=65535
1_DirID6=0
2_ToggleKey=0
2_AnyFireOnJoy=0
2_DeadZone=50
2_AutoFireSpeed=0
2_Type=0
2_DirID0=65535
2_DirID1=65535
2_DirID2=65535
2_DirID3=65535
2_DirID4=65535
2_DirID5=65535
2_DirID6=0

[Sound]
PsgMod=1
YmLowLevel=1
Microwire=1
KeyboardClick=1
Freq=44100
Bits=16
Channels=2
WritePrimary=0
TimeMethod=1
WriteAhead=3
WAVOutputFile=E:\Games\Steem.SSE.3.9.4.Win32.D3D\st.wav
RecordWarnOverwrite=1
WAVOutputDir=E:\Games\Steem.SSE.3.9.4.Win32.D3D
SoundRecordFormat=0
NoDsp=0

[MIDI]
Port_0_Type=0
Port_0_MIDIOutName=
Port_0_MIDIOutDevice=-2
Port_0_MIDIInName=
Port_0_MIDIInDevice=-1
Port_0_COMNum=0
Port_0_LPTNum=0
Port_0_File=E:\Games\Steem.SSE.3.9.4.Win32.D3D\midi.dmp
Port_1_Type=0
Port_1_MIDIOutName=
Port_1_MIDIOutDevice=-2
Port_1_MIDIInName=
Port_1_MIDIInDevice=-1
Port_1_COMNum=0
Port_1_LPTNum=0
Port_1_File=E:\Games\Steem.SSE.3.9.4.Win32.D3D\printer.dmp
Port_2_Type=0
Port_2_MIDIOutName=
Port_2_MIDIOutDevice=-2
Port_2_MIDIInName=
Port_2_MIDIInDevice=-1
Port_2_COMNum=0
Port_2_LPTNum=0
Port_2_File=E:\Games\Steem.SSE.3.9.4.Win32.D3D\serial.dmp
Port_3_Type=0
Port_3_MIDIOutName=
Port_3_MIDIOutDevice=-2
Port_3_MIDIInName=
Port_3_MIDIInDevice=-1
Port_3_COMNum=0
Port_3_LPTNum=0
Port_3_File=E:\Games\Steem.SSE.3.9.4.Win32.D3D
OutRunningStatus=1
InRunningStatus=1
InSysExBufs=2
OutSysExBufs=2
InSpeed=100
OutVolume=65535
InMaxSysEx=65536
OutMaxSysEx=65536

[Machine]
STType=1
Wakeup=0
CpuCustomHz=8021240
ROM_File=E:\Games\Atari ST Steem Engine Emulator\TOS_104.IMG
ROM_Add_Dir=E:\Games\Steem.SSE.3.9.4.Win32.D3D
Cart_File=
LastCartFile=E:\Games\Steem.SSE.3.9.4.Win32.D3D\
CartidgeOff=0
Colour_Monitor=1
Mem_Bank_1=1
Mem_Bank_2=1
ShiftSwitching=0
KeyboardLanguage=2057
ExMon=0
ExMonWidth=480
ExMonHeight=480
ExMonPlanes=4




In Steem ver 3.9.4 I have tested a game that runs from the Auto folder on floppy .stx image, the game I tested was Xenon by Melbourne House and it runs fine if I double click the Eric.prg file directly from a copied version without the Auto folder, but if I boot the Xenon.stx image which has the Eric.prg file in the Auto folder then the sound is slightly distorted and runs too fast.

Expected outcome is that it should be at the same clarity and speed if run by double clicking from the desktop.

Actual oucome is the sound is distorted and the music track plays too fast.

This problem was not present in version 3.6.4 which was the last version I had before upgrading to version 3.9.4

Return to “Support”

Who is online

Users browsing this forum: No registered users and 0 guests