ScummVM running on FrameBuffer

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Sorgelig, Moderator Team

BBond007
Captain Atari
Captain Atari
Posts: 384
Joined: Wed Feb 28, 2018 3:23 am

Re: ScummVM running on FrameBuffer

Postby BBond007 » Sat Jun 22, 2019 4:30 am

jpxdude wrote:Love that we have ScummVM as an option! Thank you so much!

I tried this today with MI 1 and 2 talkie versions and they work well. I did try using the MT32 emulator with MT32 ROMs on MI2 but it was awfully slow/stuttery/unplayable unfortunately. The dream would be to have MT32 or SC55/SC88 working in FPGA concurrently with ScummVM running. Wow that would be amazingly awesome...

I have a couple of hardware MT32 units and an SC55 mk2, just need to find my midi cables and power supply. Will try soon. Thanks for this!!


I never recommended using the MT-32 emulation (with ScummVM) as I always suspected it would require more CPU than is available. FluidSynth requires far less CPU, so I would suggest that.

For those MT-32 specific games (such as Sierra), I would encourage the use of ao486 or Minimig cores using the "UART: MIDI" option as it will free up a dedicated CPU for MUNT. Those games are typically older and as such run fine on ao486.

Yes, I would be very nice if "someone" would make an open source HDL MT-32/CM-32L implementation. Perhaps the already existing FM (Adlib/OPL3) could be integrated as a start. It would also be nice if there was a MPU-401 implementation for ao486...

I worked on ScummVM for the purpose of running the later 640x480x256/true-color CD games which can't be run on ao486. The vast majority of those don't support MT-32 as a sound option...

Also, if you do get new power adapters (which might be advisable) for your vintage Roland devices, please be aware that the center pin of the barrel jack is NEGATIVE 9V - which seems to be less typical.

BBond007
Captain Atari
Captain Atari
Posts: 384
Joined: Wed Feb 28, 2018 3:23 am

Re: ScummVM running on FrameBuffer

Postby BBond007 » Mon Aug 19, 2019 4:40 am

I have updated the ScummVM build to the latest...

https://github.com/bbond007/MiSTer_ScummVM/raw/master/Install_ScummVM.sh

"Install_ScummVM.sh" will now download the latest "ScummVM_Installer.sh"

I suggest using this script as opposed to "ScummVM_Installer.sh" directly.

Install options can be specified in "Install_ScummVM.ini",

See README for options --> https://github.com/bbond007/MiSTer_ScummVM/blob/master/README.md

Blade Runner game is very playable now, although the FMV still has some sync issues.

Thanks to NML32 for testing configuration options! --> https://youtu.be/pWEY7e-3pKw

Other games also show performance increases.

BBond007
Captain Atari
Captain Atari
Posts: 384
Joined: Wed Feb 28, 2018 3:23 am

Re: ScummVM running on FrameBuffer

Postby BBond007 » Fri Oct 18, 2019 4:59 am

Howdy,

ScummVM for MiSTer has now been updated to 2.2.0.

https://github.com/bbond007/MiSTer_Scum ... ScummVM.sh

Let me know if there are any problems...

Thanks :)

Jeruro
Atarian
Atarian
Posts: 1
Joined: Wed Sep 04, 2019 8:19 am

Re: ScummVM running on FrameBuffer

Postby Jeruro » Fri Oct 18, 2019 7:30 am

Thanks :cheers:

nico24
Atari maniac
Atari maniac
Posts: 84
Joined: Fri Aug 11, 2017 5:30 pm

Re: ScummVM running on FrameBuffer

Postby nico24 » Fri Oct 18, 2019 3:56 pm

I seem to have a very bad lag on the sound with ScummVM. Is there any way to changes settings to get rid of this lag?

Thanks.


Return to “MiSTer”

Who is online

Users browsing this forum: hyperterminal and 5 guests