A small request...Geneva

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

nagual
Captain Atari
Captain Atari
Posts: 313
Joined: Mon Sep 11, 2006 10:15 am

A small request...Geneva

Postby nagual » Sat Sep 30, 2017 8:58 am

Is there any Geneva user on forum ?

If is, can someone send me installed version of Geneva 6, without NeoDesk, just filse needed for work...
Somehow, I have a problem with installation disks of Geneva 6, so any help will be more than welcome:-)

So, just necessary files for AUTO folder, JAR, Geneva etc...

Thanx in advanced :-)

User avatar
Atarieterno
Atari Super Hero
Atari Super Hero
Posts: 783
Joined: Mon Jan 18, 2016 3:40 pm
Location: Spain

Re: A small request...Geneva

Postby Atarieterno » Sat Sep 30, 2017 12:24 pm

What problems do you have with the installation? Try a "clean" installation, with the folder AUTO empty. The installer works fine, the JAR10 program must be copied before GENEVA.

http://www.mediafire.com/file/eepq2sqyl ... eva_v6.rar
ST/fm/e, STacy, Mega ST/e, TT, Falcon, C-Lab MKX... and more music tools.

nagual
Captain Atari
Captain Atari
Posts: 313
Joined: Mon Sep 11, 2006 10:15 am

Re: A small request...Geneva

Postby nagual » Sat Sep 30, 2017 6:36 pm

Atarieterno wrote:What problems do you have with the installation? Try a "clean" installation, with the folder AUTO empty. The installer works fine, the JAR10 program must be copied before GENEVA.

http://www.mediafire.com/file/eepq2sqyl ... eva_v6.rar


Looks like ST image is not good, and just crash whole system.
I always made a clean installation, it's a safe and easier to debug in any case of problems.
Download now Geneva from your link and will see, hope the problem is in my installation :-)

Thank you Atarieterno for quick response and help :-)

Cheers! :cheers:

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1079
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: A small request...Geneva

Postby TheNameOfTheGame » Sun Oct 01, 2017 1:35 am

Here's a small Geneva text file if you don't have it already.

https://www.dropbox.com/s/9cgfk041zf4iowc/genevasecrets.zip?dl=1

nagual
Captain Atari
Captain Atari
Posts: 313
Joined: Mon Sep 11, 2006 10:15 am

Re: A small request...Geneva

Postby nagual » Sun Oct 01, 2017 6:42 am

Thanks:-)

User avatar
Dark Willow
Atari Super Hero
Atari Super Hero
Posts: 676
Joined: Fri Mar 12, 2004 10:59 am
Location: UK
Contact:

Re: A small request...Geneva

Postby Dark Willow » Sun Dec 17, 2017 3:32 pm

Trying to install Geneva+Neodesk 4 on Hatari using the images from the main Geneva thread. Geneva is running a treat but Neodesk has been pain - it seems the images aren't complete as the Neodesk installer just immediately errors out asking for an install script file that isn't present. Does anyone have a working copy?
TT030, 10mb/16mb, 3.5" SCSI multi-card reader (2gb CF/512mb SD), Matrix TC1006 gfx card, EtherNEC, Epson GT scanner, VanillaMint | 1040STe, 4mb, TOS 1.62, MegaFile 60, SM125 | Lynx II | 800XL, 64k, 1050 disk drive, XC12 tape deck, MicroLink parallel adapter

PuppySoft:Projects & More

User avatar
Atarieterno
Atari Super Hero
Atari Super Hero
Posts: 783
Joined: Mon Jan 18, 2016 3:40 pm
Location: Spain

Re: A small request...Geneva

Postby Atarieterno » Sun Dec 17, 2017 3:54 pm

ST/fm/e, STacy, Mega ST/e, TT, Falcon, C-Lab MKX... and more music tools.

User avatar
Dark Willow
Atari Super Hero
Atari Super Hero
Posts: 676
Joined: Fri Mar 12, 2004 10:59 am
Location: UK
Contact:

Re: A small request...Geneva

Postby Dark Willow » Sun Dec 17, 2017 4:05 pm

Thanks for that :) - but my Geneva install is fine, it's just Neodesk that won't play ball :(
TT030, 10mb/16mb, 3.5" SCSI multi-card reader (2gb CF/512mb SD), Matrix TC1006 gfx card, EtherNEC, Epson GT scanner, VanillaMint | 1040STe, 4mb, TOS 1.62, MegaFile 60, SM125 | Lynx II | 800XL, 64k, 1050 disk drive, XC12 tape deck, MicroLink parallel adapter

PuppySoft:Projects & More

User avatar
Atarieterno
Atari Super Hero
Atari Super Hero
Posts: 783
Joined: Mon Jan 18, 2016 3:40 pm
Location: Spain

Re: A small request...Geneva

Postby Atarieterno » Sun Dec 17, 2017 4:21 pm

Ok, Ok, see if this is the same as you have:
http://www.mediafire.com/file/88xf6q01w ... Desk_4.ZIP
ST/fm/e, STacy, Mega ST/e, TT, Falcon, C-Lab MKX... and more music tools.

dimfil
Atari maniac
Atari maniac
Posts: 82
Joined: Sat Feb 11, 2017 7:48 am
Location: Athens, Greece

Re: A small request...Geneva

Postby dimfil » Sun Dec 17, 2017 8:54 pm

This version of Neodesk works just fine for my Geneva + NeoDesk installation :
https://www.dropbox.com/s/mfab5uydbpcgd ... 4.LZH?dl=0

User avatar
Dark Willow
Atari Super Hero
Atari Super Hero
Posts: 676
Joined: Fri Mar 12, 2004 10:59 am
Location: UK
Contact:

Re: A small request...Geneva

Postby Dark Willow » Mon Dec 18, 2017 10:06 am

Thanks all :) Atarieterno's copy works a treat with Hatari. For the record - this is the setup:

Hatari emulating STe 68000 @ 32Mhz / 14mb RAM / TOS 2.06 / VDI extended video in mono / "real" HD image / Geneva 4 & Neodesk 4.

Notes:
Needs "real" HD image, won't work on shared folders as can't resort the AUTO folder due to native OS controlling file order.

EmuTOS causes crash at bootup. Original Atari TOS versions are fine, at least as far as the 1.x and 2.x versions are concerned. Others not tested yet.

VDI extension works fine in mono, but crashes Atari TOS 1.x and 2.x when run with colour. EmuTOS is fine, but as noted above does not seem to like Geneva.
TT030, 10mb/16mb, 3.5" SCSI multi-card reader (2gb CF/512mb SD), Matrix TC1006 gfx card, EtherNEC, Epson GT scanner, VanillaMint | 1040STe, 4mb, TOS 1.62, MegaFile 60, SM125 | Lynx II | 800XL, 64k, 1050 disk drive, XC12 tape deck, MicroLink parallel adapter

PuppySoft:Projects & More

joska
Hardware Guru
Hardware Guru
Posts: 4036
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: A small request...Geneva

Postby joska » Mon Dec 18, 2017 10:45 am

Dark Willow wrote:EmuTOS is fine, but as noted above does not seem to like Geneva.


Which version of EmuTOS is this?
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
Dark Willow
Atari Super Hero
Atari Super Hero
Posts: 676
Joined: Fri Mar 12, 2004 10:59 am
Location: UK
Contact:

Re: A small request...Geneva

Postby Dark Willow » Sat Dec 23, 2017 6:00 pm

Just checked as I couldn't recall of the top of my head. It's v0.9.6
TT030, 10mb/16mb, 3.5" SCSI multi-card reader (2gb CF/512mb SD), Matrix TC1006 gfx card, EtherNEC, Epson GT scanner, VanillaMint | 1040STe, 4mb, TOS 1.62, MegaFile 60, SM125 | Lynx II | 800XL, 64k, 1050 disk drive, XC12 tape deck, MicroLink parallel adapter

PuppySoft:Projects & More

User avatar
Dark Willow
Atari Super Hero
Atari Super Hero
Posts: 676
Joined: Fri Mar 12, 2004 10:59 am
Location: UK
Contact:

Re: A small request...Geneva

Postby Dark Willow » Sat Dec 23, 2017 6:53 pm

Tested in v0.9.9.1 - also getting errors. Screencap in the attachment for anyone interested.
You do not have the required permissions to view the files attached to this post.
TT030, 10mb/16mb, 3.5" SCSI multi-card reader (2gb CF/512mb SD), Matrix TC1006 gfx card, EtherNEC, Epson GT scanner, VanillaMint | 1040STe, 4mb, TOS 1.62, MegaFile 60, SM125 | Lynx II | 800XL, 64k, 1050 disk drive, XC12 tape deck, MicroLink parallel adapter

PuppySoft:Projects & More

joska
Hardware Guru
Hardware Guru
Posts: 4036
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: A small request...Geneva

Postby joska » Sun Dec 24, 2017 11:43 am

Maybe you should try a more recent version of Geneva? I seem to remember that I have been running Geneva with EmuTOS (in ROM) in my STE, but I'm using Geneva 006.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

czietz
Hardware Guru
Hardware Guru
Posts: 720
Joined: Tue May 24, 2016 6:47 pm

Re: A small request...Geneva

Postby czietz » Tue Dec 26, 2017 12:43 pm

Dark Willow wrote:Tested in v0.9.9.1 - also getting errors. Screencap in the attachment for anyone interested.


Thank you for testing and reporting the crash using EmuTOS. I can look at it if you want. Though, to make it easier for me, I'd appreciate it if you could provide me a fast way to reproduce the error, i.e. a zip file with the HD image and preferably also the Hatari config file.


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 2 guests