CTPCI and Realtek 8139D

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, lp, [ProToS], moondog/.tSCc., Moderator Team

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Wed Oct 04, 2017 11:41 pm

This falcon was using dhcp previously so these manually define _sh_it_ was not a concern for the scsilink and ethnec. I guess switching to manual configuration just does not mean adding ifconfig and route. :roll:
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Wed Oct 04, 2017 11:45 pm

Kroll wrote:Wow, super, :D :D
Finally, it was a problem with flash, not directly with the Realtek 8139 network card

Yes, it looks like.
and worst I cannot see which ABE/SDR version ( or rather version-revision C D E F etc ) it was programmed in.
Flashing was done in less than 10 minutes, but previous night I spend the whole night trying to setup Xilinx.
My old PC heat sink broke so I have to rebuild another PC to run old OS for Xilinx.
Luckily, yesterday at work I found out that Xilink was also able to work on Win10 with some hack, so I did not continue to setup the PC.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Thu Oct 05, 2017 7:36 am

Hi wongck,

great that it works for you now, too! So we have another qualified tester D:

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Thu Oct 05, 2017 11:32 am

Tester yes, qualified not sure.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
paul92706
Atari God
Atari God
Posts: 1401
Joined: Mon Apr 25, 2011 4:28 am
Location: Orange, CA

Re: CTPCI and Realtek 8139D

Postby paul92706 » Fri Oct 06, 2017 3:39 pm

wongck wrote:Tester yes, qualified not sure.

Sweet! You got it working wongck! Maybe writing a tutorial some time in future?!
Atari Falcon CT60/CTPCI 14MB+ 512mb ATI9250 + NetUSBee
Atari Falcon030 CF 4gb + NetUSBee+ 14MB Ram
Atari TT030 2meg STRAM/16meg TTRAM + Nova Adaptor +Maxtor SCSI HD + DaynaPort Pocket SCSI

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Sat Oct 07, 2017 1:09 am

paul92706 wrote:
wongck wrote:Tester yes, qualified not sure.

Sweet! You got it working wongck! Maybe writing a tutorial some time in future?!

I think all already done back in 2012 :wink:
Setting up TCP/IP in Mint is already written on my webpage.
Flashing the firmware on my CT63 is already written on the Wiki.... but that's down now. May be I should have placed it on my website rather than the wiki, but then I guess, I was trying to populate the wiki with all the good stuff in 2012.

Only step I did was to re-flash my CT63 with ABE_V7F and SDR_V7D, the very ones that Ektus been saying since 2012 as well I guess.
I see that I have a SDR_V7Z, I wonder if I had that one on my system. From what i remember, Czuba gave me that for the IDE specifically, and that the Radeon was always working.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Sun Oct 29, 2017 3:50 pm

Hi Mikro,

are there any news about this issue?
Means: Can we do something better than bothering you with silly questions? :mrgreen:
Please tell us if we can help with testing!

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

mikro
Atari God
Atari God
Posts: 1681
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: CTPCI and Realtek 8139D

Postby mikro » Sun Oct 29, 2017 10:15 pm

No real news, except my very limited time right now. However I haven't abandoned those PCI/USB issues, I just can't solve them at the same time. Right now I'm (more or less) trying to catch the bug with Milan PCI-USB (strange regression, having hard time even to pinpoint it down...) and Kroll's NetUSBee issue (I know what's wrong I just don't know why -- very interesting issue with different delay algorithms).

If/when one of those are solved/closed, I can move forward to this one.

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Tue Oct 31, 2017 9:11 am

Ah, good to hear that it´s not forgotten!
No need to hurry, please just keep us informed.

Thank you, Mikro! :)

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Sat Dec 09, 2017 11:18 am

Hi,

i found a problem with mikros modified rtl8139.xif driver and FreeMinT 1.18.0:
Downloads from my UbuntuLinux PC (vsftpd ftp server and nfs server) are very fast and stable,
about 2200 KB/sec (with Litchi, download of a 12 MB mp3 file). NFS "download" works good, too.
Upload of small files (~ 50-100 KB) works correct, too.

But when i try to upload a "bigger" file (~ 2-5 MB), file transfer stops after a few kilobytes.
I didn't find the exact filesize "barrier" between working or not working upload yet.
This happens with Litchi and nfs client, too. Litchi "hangs" and has to be terminated, nfs client
just stops file transfer and no file is copied to the nfs shared folder on PC at all.
Same problem with Litchi on CT60TOS+StinG/RTL8139.STX from TOSbeta10 archive.

I tested the other way around, too (MinT ftp server on Falcon and FileZilla on PC) with same result:
PC --> Falcon Transfer fast+correct.
Falcon --> PC Transfer stops after ~35 KB.

With the EtherNEC before everything worked correct.

Can anybody confirm this behaviour?

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

mikro
Atari God
Atari God
Posts: 1681
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: CTPCI and Realtek 8139D

Postby mikro » Sun Dec 10, 2017 11:38 am

Interesting, looks like an internal buffer issue (not properly allocating and/or resizing or whatever). I wish I had more proper 'environment' around me for this kind of stuff... one notebook and very little free time and another project in the works --> not good. But it's not forgotten.

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Sat Dec 16, 2017 10:52 am

Hi,
just tested with Troll EMail: Receiving works perfect. Sending email + 450 KB attachment "hangs" (same behaviour as reported above).

Again: Can anybody confirm this problem (perhaps with other clients/servers)? With TOS/STinG or MiNT.
wongck? ektus? Kroll?

Thanks in advance,
Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

jury
Captain Atari
Captain Atari
Posts: 289
Joined: Tue Sep 21, 2004 11:11 am
Location: Poland

Re: CTPCI and Realtek 8139D

Postby jury » Sun Dec 17, 2017 2:32 pm

Latz wrote:Downloads from my UbuntuLinux PC (vsftpd ftp server and nfs server) are very fast and stable,
about 2200 KB/sec (with Litchi, download of a 12 MB mp3 file).


Wow, nice speed 2200 KB/sec. I have to get some Realtek 8139D then and try it out, as the highest speed I achived so far was around 700 KB/sec with Svethlana. And as sometimes I transfer to Falcon files around 1GB this speed could make a huge difference ( 3 times faster )

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 217
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Ektus » Sun Dec 17, 2017 3:16 pm

Latz wrote:Hi,
just tested with Troll EMail: Receiving works perfect. Sending email + 450 KB attachment "hangs" (same behaviour as reported above).

Again: Can anybody confirm this problem (perhaps with other clients/servers)? With TOS/STinG or MiNT.
wongck? ektus? Kroll?


I won't have access to my Falcon until Christmas, but might do some testing afterwards. I'll have to update the MiNT installation first, though.


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Mon Dec 18, 2017 9:38 am

Hi,

jury wrote:Wow, nice speed 2200 KB/sec.


Yes, indeed amazing!! Thanks to mikro :cheers:

ektus wrote:I won't have access to my Falcon until Christmas, but might do some testing afterwards. I'll have to update the MiNT installation first, though.


This would be great, thank you!
Updating MiNT is easy (and you can keep your old installation), but a test with 1-17 would be interesting, too.

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Mon Dec 18, 2017 1:30 pm

Since I upgraded my Windoze 10, I have not installed an FTP server on it yet.

But I did a CURL to get a 100MB file from speedtest and I managed to get it on my hdd, at average speed of 465KB/s and in 3 mins 40 secs.
That's out on the Internet.

I need to set up my FTP before I can try sending.

This is on mint 1.19, CT63 at 90MHz. Realtek 8139C at half duplex. :roll:
I need to get my 8139D, if i can find it. :mrgreen:
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Mon Dec 18, 2017 3:51 pm

So I quickly setup MS FTP on my Win10 as I did not need to dl anything.
Created a 3MB ZIP file.
PC -> Atari was 400 KB/s in 7.9 sec ZIP test OK
Atari -> PC was 800 KB/s in 3.6 sec ZIP test OK

I used the Mint FTP command line tool.
I have aftp installed but it does not report speed after the transfer.
aftp also transferred without any issues.

I will try a bigger ZIP file tomorrrow
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Faucon2001
Atari Super Hero
Atari Super Hero
Posts: 704
Joined: Sat Oct 26, 2013 11:19 pm
Location: Brasil
Contact:

Re: CTPCI and Realtek 8139D

Postby Faucon2001 » Mon Dec 18, 2017 9:33 pm

Hi Wongck,
It reminds me some tests I did on the Firebee where the transfer speed was very variable depending on the software used and conditions. Mint ftp was 135% faster if you download to /ram instead of HDD, and litchi was the fastest of all thanks to his buffering.
viewtopic.php?t=26821&start=50

Hummm, If I had time I would switch on again my Falcon, flash the CTPCI and play with the Ethernet card... but it's not going to happen soon :-(
Philippe

Firebee, Falcon, STE, Aranym Box, Hatari Pi Box.
My music http://www.philippeworld.net/
My photography http://phil-67.deviantart.com/
EasyAraMint, BeeKey and BeePi https://sites.google.com/site/emaappsarch/home

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Mon Dec 18, 2017 11:48 pm

Thanks for pointing it out, Yeap I know, to ramdisk is surely faster. I did thought about it when I was in bed. :wink:
It was late and I needed sleep.... so I just tested whatever was ready on my Falcon.
Sure I will dl Litchi and test with it. I am sure it's blazing fast, as I used it on my FB.
Will do it tonight, in my free time.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Tue Dec 19, 2017 2:11 pm

Not sure what's with Gluestick but it crashes AESSYS on startup.
In any case, I continue with the test without Litchi, using the commandline ftp.

I created a 47 MB ZIP file.
PC -> Falcon in 144 secs -- STZIP checked file as no error.
Falcon -> PC in 29.9 secs -- 7-zip checked as no error.

Again, it is using my 8139C.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Rustynutt
Atari Super Hero
Atari Super Hero
Posts: 516
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: CTPCI and Realtek 8139D

Postby Rustynutt » Tue Dec 19, 2017 3:05 pm

The performance writing to RAM disk is vs Falcon IDE?

Sometime back, "someone" said they have USB working on the CT/SV S/U (sorry).
But that is USB 1 @ 400k, correct?

My CTPCI arrived just before holiday, so testing my NIC cards will have to wait until the CTPCI is installed, a job in itself it sounds :)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Tue Dec 19, 2017 3:09 pm

That's to ramdisk.

I found my RTL 8139D and remember now why I used the 8139C.
The 8139D seems to be a walking wounded.... it pings, get weather, updates my time via time server... but hangs when I start to do FTP.
Browsing starts off OK but then hangs half way as well especially downloading graphics..
I think it is busted, so i order another one from China. :lol: ,,,, never learn the busted one was also from China. :?
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12416
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Tue Dec 19, 2017 3:13 pm

Rustynutt wrote:Sometime back, "someone" said they have USB working on the CT/SV S/U (sorry).


That be Ektus
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Rustynutt
Atari Super Hero
Atari Super Hero
Posts: 516
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: CTPCI and Realtek 8139D

Postby Rustynutt » Tue Dec 19, 2017 4:42 pm

Have 4 ISA NIC cards for the Milan, but no PCI format (yet) :)

I found open source for Nokia suite. If MiNT can network via USB, it may be possible to use a Symbian Nokia tethered to the USB as a modem. More fun.

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 217
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Ektus » Tue Dec 19, 2017 4:51 pm

wongck wrote:
Rustynutt wrote:Sometime back, "someone" said they have USB working on the CT/SV S/U (sorry).


That be Ektus

Right, that's me. USB keyboard and mouse, but tested only briefly. The keyboard is having mapping issues, but I haven't been investigating further because I rarely use that Falcon and it already has an Eiffel installed. Some USB memory stick did work also, but I don't remember doing any speed tests.


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage


Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 3 guests