HxC inside 520ST (not 520STF!)

Everything related to using the HxC Floppy Emulator hardware on your Atari.

Moderators: mr.vince, DrCoolZic, Moderator Team

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

HxC inside 520ST (not 520STF!)

Postby zzarko » Mon Mar 17, 2014 10:51 am

I have bought a 520ST (model without an internal floppy) with internal 512K upgrade (total 1MB) and I would like to connect HxC internally. This machine doesn't have an internal floppy connector. Is it possible to connect HxC just by making a cable that is soldered to external floppy connector contacts, or should there be some additional electronics involved? Did anyone did this? Is there maybe a schematics for this?

Dal
Administrator
Administrator
Posts: 4034
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: HxC inside 520ST (not 520STF!)

Postby Dal » Mon Mar 17, 2014 1:12 pm

FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
tenox
Captain Atari
Captain Atari
Posts: 325
Joined: Thu Apr 05, 2012 11:52 pm
Location: Sunnyvale, California

Re: HxC inside 520ST (not 520STF!)

Postby tenox » Mon Mar 17, 2014 10:21 pm

Also check out SLIM SD: http://www.lotharek.pl/category.php?kid=25 it may fit inside better than the standard HxC.

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Re: HxC inside 520ST (not 520STF!)

Postby zzarko » Tue Mar 18, 2014 10:47 am


That is an very nice external solution! If I understood correctly, you have directly connected pins on HxC to pins on external floppy connector on Atari ST, no additional electronics required? If that is the case, I guess I could just use your scheme and solder a floppy cable directly to pins on 520st floppy connector for internal mount. I already have a HxC with a detachable LCD screen, so I will use that for my project. Thanks!

Dal
Administrator
Administrator
Posts: 4034
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: HxC inside 520ST (not 520STF!)

Postby Dal » Tue Mar 18, 2014 1:08 pm

Yes you got it. For the 520ST then there is no need to do the Floppy A/B switch mod as the external port is already mapped to Drive A (or DS0 to use its correct name).

So just wire up directly from the 34pin IDC header on the HxC to the 14pin DIN connector and you're good to go. If you want a completely internal solution (and you're able to desolder without destroying boards), you might consider removing the 14pin connector and wiring directly to the board or keep the connector in place but tap back to find a suitable place to take each line from.

It would be great to see your finished solution. Have fun and take it slowly!
FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Re: HxC inside 520ST (not 520STF!)

Postby zzarko » Wed Mar 19, 2014 4:17 pm

Dal wrote:It would be great to see your finished solution. Have fun and take it slowly!
I intend to take it very slowly, and to consult my friend who is much better with soldering than me. I will post pictures when I'm finished. Thanks again for advices! Atari-Forum is a great community :)

User avatar
troed
Atari God
Atari God
Posts: 1050
Joined: Mon Apr 30, 2012 6:20 pm
Location: Sweden

Re: HxC inside 520ST (not 520STF!)

Postby troed » Wed Mar 19, 2014 10:05 pm

Dal wrote:Yes you got it. For the 520ST then there is no need to do the Floppy A/B switch mod as the external port is already mapped to Drive A (or DS0 to use its correct name).

So just wire up directly from the 34pin IDC header on the HxC to the 14pin DIN connector and you're good to go. If you want a completely internal solution (and you're able to desolder without destroying boards), you might consider removing the 14pin connector and wiring directly to the board or keep the connector in place but tap back to find a suitable place to take each line from.


Jookie´s CosmosEx has me wondering whether I should change plans for this system - but currently the above is what I intend to do (on an STE). Removing the external floppy port altogether, wire it up to an internally mounted HxC SD and installing an A<->B switch.

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Re: HxC inside 520ST (not 520STF!)

Postby zzarko » Fri Mar 21, 2014 12:46 pm

After gathering all the info I needed, I have made connections diagram. And after soldering, everything worked the first time! Now, I need to decide how will I mount HxC inside Atari. Thanks again for advices!
You do not have the required permissions to view the files attached to this post.

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Re: HxC inside 520ST (not 520STF!)

Postby zzarko » Sun Apr 13, 2014 5:47 pm

Here it is, the finished machine:
ST3.jpg

A mobile telephone joystick is used for navigation, it is connected to HxC buttons internally.

On the back, there are added S-Video and Composite video outputs, SD card slot and two Audio outputs:
ST2.jpg

A friend of mine has made me a RGB-to-S-Video converter (with this circuit: http://www.cpcwiki.eu/index.php/RGB_SVideo).

Everything works fine :)
You do not have the required permissions to view the files attached to this post.

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Dots on screen

Postby zzarko » Wed Apr 16, 2014 7:08 am

The machine I have modified had a problem with displaying black dots on Atari desktop while moving the mouse (before I started to modify it). Here is how its desktop looks like after driving a mouse for a while:
IMG_20140415_165806.jpg

When i bought it, I found that it had a 1MB piggyback memory expansion:
520ST2.JPG

Could it be that maybe some of the memory chips are malfunctioned, or should I try to look elsewhere?

If you know something about this problem, please answer! Thanks!
You do not have the required permissions to view the files attached to this post.

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1026
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Re: HxC inside 520ST (not 520STF!)

Postby MasterOfGizmo » Wed Apr 16, 2014 12:16 pm

This is exactly how ram problems look like. Your problem occurs exactly every 16 pixels. So only a single ram seems to be affected. You should be able to disable the extra layer by tying one of the control signals to vcc. That way you can test that its really the ram update without soldering too much on the machine.

I'd check for bad solder conections on the update first.

Gesendet von meinem GT-I8190 mit Tapatalk
MIST board, FPGA based Atari STE and more: https://github.com/mist-devel/mist-board/wiki

zzarko
Atarian
Atarian
Posts: 7
Joined: Thu Dec 08, 2011 5:52 pm

Re: HxC inside 520ST (not 520STF!)

Postby zzarko » Wed Apr 16, 2014 8:29 pm

MasterOfGizmo, thank you very much for advice! I'll try to check what you suggested.


Social Media

     

Return to “HxC Floppy Emulator”

Who is online

Users browsing this forum: No registered users and 1 guest

cron