Page 1 of 1

[solved] HxC Problems

Posted: Sat Oct 05, 2013 1:40 pm
by musojon74
Hey guys. Hope you're well.

I just received my hxc floppy emulator this morning. Excitedly removed the floppy drive from my ste, fitted hxc. Stuck in an sd card with hxc floppy emulator manager autoboot.hfe, and the supplied config. stuck a load of hfe images on the card. all in root directory.

I turn the ste on, i get one click, then one slightly longer beep. The red led sort of flickers after initially shining bright, and the floppy led stays on. After a while the GEM desktop boots. THe menu doesn't load, and I can't access the floppy.

Jumpers are set default for A:, first on, all others off.

I've tried multiple different sd cards, and I have never successfully loaded anything.

Is there something ridiculously simple I've missed, or could my hxc not be working correctly do you think?
Thanks very much

Jon

Re: HxC Problems

Posted: Sat Oct 05, 2013 4:04 pm
by musojon74
Update - when using a whole atari st image downloaded from the Lothariek's lair, the led doesn't flicker, there's just one click. still nothing happens though.

Re: HxC Problems

Posted: Sat Oct 05, 2013 6:43 pm
by musojon74
Another update - after talking to another user and grabbing the files from his working hxc sd card, I am reaching the unfortunate conclusion that I am unlucky and have a faulty hxc. I'd still appreciate advice, but I think I'll see about sending it back :(

Re: HxC Problems

Posted: Sat Oct 05, 2013 7:55 pm
by exxos
putting the cable in upside down caught me out with loads of problems.

Re: HxC Problems

Posted: Sat Oct 05, 2013 8:09 pm
by musojon74
First - important update - hxc works perfectly with my a600. So it's not faulty.

Hmmm. Very interesting. I did see your thread earlier Exxos. However this is an internal drive I'm replacing in the ST. I can't put the cable the other way due to a physical feature on the cable - i'd have to grind that down to turn upside down...

Re: HxC Problems

Posted: Sat Oct 05, 2013 8:21 pm
by musojon74
Thanks Exxos. Works fine now :) Even though the cable physically needed filing down to work the other way!!! I'd best test it out, then...

Mods, please mark / rename this as fixed / floppy cable upside down. :-S

Thanks
Jon

Re: HxC Problems

Posted: Sat Oct 05, 2013 8:57 pm
by exxos
8)

I think the cable catches out a lot of people, I will be making some up hopefully next week as I have the same cable problem :)

Re: [solved] HxC Problems

Posted: Sun Oct 06, 2013 2:21 am
by wongck
Is there a red dots on line on FDD cable that specify pin 1 ?
On my Falcon, it's like that.