HAs anyone tried the HXC HD driver yet?

Everything related to using the HxC Floppy Emulator hardware on your Atari.

Moderators: DrCoolZic, mr.vince, Moderator Team

waSTE
Atariator
Atariator
Posts: 21
Joined: Sat Apr 23, 2011 8:03 pm

HAs anyone tried the HXC HD driver yet?

Postby waSTE » Fri Apr 29, 2011 7:30 pm

Still waiting for mine to be delivered but this looks pretty darn interesting :

http://hxcmount.atomas.com/

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sat Apr 30, 2011 3:35 am

Thanks for your URL.
I saw this HxC HD thingy in the firmware update file readme file and wondered what it was.
I normally dl the firmware updates as it has more features or faster access. :thumbs:

I have not tried it yet as I am using my TT now and the HxC SD is on my Falc.
Will probably change machine this weekend and have a go at it. :mrgreen:
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sun May 01, 2011 3:13 am

So I was downloading all the required files like the new v1.6 firmware, new HxC FloppyEmulator software v1.5.2.1 ready for flashing.
I read the webpage at http://hxcmount.atomas.com/ and it says it needs a hxcmount.tos program.
Amazingly, they do not have a direct download but gives a address to their source code. 8O

So I cannot test it because there is no binary for the hxcmount.tos program.
But I am sure it will work. :wink:

:lol: :lol: this the shortest and easiest hardware test report.
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
jokker
Atari freak
Atari freak
Posts: 71
Joined: Mon Nov 17, 2008 7:13 am
Location: Ontario, Canada

Re: HAs anyone tried the HXC HD driver yet?

Postby jokker » Sun May 01, 2011 4:36 am

Yeah I grabbed the source to have a look and it has some prebuilt binaries. I need to create a suitable image for it to work though before I can test anything out. The binary included isn't called by the same name referred to in the page. Hopefully with some puttering about I'll be able to get something basic up and running.

User avatar
jokker
Atari freak
Atari freak
Posts: 71
Joined: Mon Nov 17, 2008 7:13 am
Location: Ontario, Canada

Re: HAs anyone tried the HXC HD driver yet?

Postby jokker » Sun May 01, 2011 5:54 am

Well I got it up and running! It does work and considering how raw it is right now it runs pretty well!

I didn't do a whole lot with it but threw on CHKDSK and Trailblazer so I could basically check out the disk and write to all of it easily. The game was there for a simple load test and it passed wonderfully. I didn't have another hard drive hooked up to it and this was running on a Mega ST2 with TOS 1.02.

I used mkdosfs on linux to create the image and throw some files on the mounted fs image file.

mkdosfs -A -C IMG1.IMA 32765

then mounting it via

mount -o loop IMG1.IMA /atari

then followed the instructions from the website. The only important thing is that the util is called HD_HXC.PRG from the svn repo and that it actually wants an image file call IMG*.IMA not IMG*.IMG. I'll probably try some kind of benchmark tomorrow to get an idea of throughput. Any good ones that people would recommend?

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sun May 01, 2011 10:19 am

jokker wrote:Yeah I grabbed the source to have a look and it has some prebuilt binaries. I need to create a suitable image for it to work though before I can test anything out. The binary included isn't called by the same name referred to in the page. Hopefully with some puttering about I'll be able to get something basic up and running.


well... so it's in the source code area, eh?
Hah! Now I have to get SVN on my Windows to get it.
Looks like it's a ready for end-user, having to get a dev to to download the source.
I have never used SVN before, is there somewhere to pull this file without needing to install SVN??
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sun May 01, 2011 10:23 am

jokker wrote:then followed the instructions from the website. The only important thing is that the util is called HD_HXC.PRG from the svn repo and that it actually wants an image file call IMG*.IMA not IMG*.IMG. I'll probably try some kind of benchmark tomorrow to get an idea of throughput. Any good ones that people would recommend?


Great stuff.
Looks like I need a bunch of equivalent tools on Windoze to get it working :(

You can try the tool RateHD to test for the speed viewtopic.php?f=27&t=14403#p122984
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Jeff_HxC2001
Captain Atari
Captain Atari
Posts: 300
Joined: Fri Sep 21, 2007 7:35 pm
Location: Paris - France
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby Jeff_HxC2001 » Sun May 01, 2011 12:58 pm

wongck wrote:
jokker wrote:then followed the instructions from the website. The only important thing is that the util is called HD_HXC.PRG from the svn repo and that it actually wants an image file call IMG*.IMA not IMG*.IMG. I'll probably try some kind of benchmark tomorrow to get an idea of throughput. Any good ones that people would recommend?


Great stuff.
Looks like I need a bunch of equivalent tools on Windoze to get it working :(


http://www.winimage.com/

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sun May 01, 2011 1:38 pm

jokker wrote: I'll probably try some kind of benchmark tomorrow to get an idea of throughput.


I would not expect it to be fast as it still depends on the WD1772 chip which have a 500kbps limit.

Actually the ST already does a Monster floppy disk image, which GEM reported like it is 4MB large.
I reckon that's plenty enough to transfers files between the PC to ST.
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Sun May 01, 2011 1:38 pm

Jeff_HxC2001 wrote:http://www.winimage.com/


Thanks Jeff :thumbs:
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
jokker
Atari freak
Atari freak
Posts: 71
Joined: Mon Nov 17, 2008 7:13 am
Location: Ontario, Canada

Re: HAs anyone tried the HXC HD driver yet?

Postby jokker » Sun May 01, 2011 7:09 pm

Thank for the info!

I gave winimage a shot but it couldn't read my existing images so I just stuck with my linux methods.

I tried out RATE_HD however it looks for a driver like ICD/HDDRIVER which isn't present. So I tried out the HOW_FAST instead. It worked and here are my results...
Image

Not exactly blazing but hey it's a first draft. I'm sure things will only get better from here on out.

*note* I don't speak any german so I can't be sure I'm using HOW_FAST properly since I'm just clicking run. If there are better ways to use and someone can send some instructions then hey I'm more than willing to give it another go.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Mon May 02, 2011 1:04 am

It seems to peak at 18 KBps which works out to be around 140 Kbps. At least 3 factors less than the theoretical 500 kbps.
Hope the next revision will be better.
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Jeff_HxC2001
Captain Atari
Captain Atari
Posts: 300
Joined: Fri Sep 21, 2007 7:35 pm
Location: Paris - France
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby Jeff_HxC2001 » Mon May 02, 2011 7:31 pm

wongck wrote:It seems to peak at 18 KBps which works out to be around 140 Kbps. At least 3 factors less than the theoretical 500 kbps.
Hope the next revision will be better.


No. The theoretical max speed is 250 kbps - 25KB/s on ST.

So don't except to get a bitrate over 20KB/s ;-)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11853
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: HAs anyone tried the HXC HD driver yet?

Postby wongck » Tue May 03, 2011 12:58 am

Jeff_HxC2001 wrote:
wongck wrote:It seems to peak at 18 KBps which works out to be around 140 Kbps. At least 3 factors less than the theoretical 500 kbps.
Hope the next revision will be better.


No. The theoretical max speed is 250 kbps - 25KB/s on ST.

So don't except to get a bitrate over 20KB/s ;-)


WOW.... so even less than I though.
My Stuff: FB/Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list


Social Media

     

Return to “HxC Floppy Emulator”

Who is online

Users browsing this forum: No registered users and 1 guest