XEGS Rom test fault

All discussions about the Atari 8bit range of machines.

Moderators: Mug UK, Silver Surfer, Moderator Team

Stargazer
Atarian
Atarian
Posts: 3
Joined: Mon Jan 29, 2018 6:47 pm

XEGS Rom test fault

Postby Stargazer » Mon Jan 29, 2018 7:00 pm

Hello to all members ,

Yesterday i had a lucky find outside the trash, a XEGS always wanted an 8 bit computer and voila but,
When i power it up it goes to memory test which shows me two red squares for rom. Every ram square (40 of them) are passing the test ok.
Already i tried to reseat the only socketed chips Rom and GTIA also used contact cleaner but the same happens.
Also i've removed every capacitor and measure it with a capacitometer and every single one is ok.
I am asking you is there a way to bypass the self test maybe put 5Volts to pin 6 of mmu?
Is there anythink else i can do ? I have a full electronic lab except a logic probe.
Thank you for your time...

User avatar
krupkaj
Captain Atari
Captain Atari
Posts: 281
Joined: Wed Oct 22, 2003 11:00 pm
Location: Olomouc/Czech Republic
Contact:

Re: XEGS Rom test fault

Postby krupkaj » Mon Jan 29, 2018 7:53 pm

Usually there is a problem with RAM when 8bit goes to memory test after start.
Try to change the RAM chips. It is a common trouble. There are 41464 chips.

LuigiThirty
Atari maniac
Atari maniac
Posts: 75
Joined: Sat Sep 03, 2016 12:20 am

Re: XEGS Rom test fault

Postby LuigiThirty » Mon Jan 29, 2018 8:11 pm

Yeah, an XEGS should be booting to Missile Command if there's no cartridge inserted.

You could also check continuity of the four big buttons on the console, I think holding Option takes you to the self-test screen. Sometimes the switches get stuck closed and cause weird problems on startup.

Stargazer
Atarian
Atarian
Posts: 3
Joined: Mon Jan 29, 2018 6:47 pm

Re: XEGS Rom test fault

Postby Stargazer » Tue Jan 30, 2018 4:25 pm

When i press option squares that represent ram go from 40 to 48 so buttons must work also ram squares pass the test rom squares don't.
If you see at the picture it uses number 2 for letter R on ROM maybe it is a clue ?
I'll try to find ram chips but first i want to try everything that is for free
You do not have the required permissions to view the files attached to this post.

User avatar
krupkaj
Captain Atari
Captain Atari
Posts: 281
Joined: Wed Oct 22, 2003 11:00 pm
Location: Olomouc/Czech Republic
Contact:

Re: XEGS Rom test fault

Postby krupkaj » Thu Feb 01, 2018 10:28 pm

aha sorry I miss it. There is a trouble in ROM. You can download the XEGS ROM from here
http://ftp.pigwa.net/stuff/collections/ ... em%20ROMs/
and burn it to the chip

Stargazer
Atarian
Atarian
Posts: 3
Joined: Mon Jan 29, 2018 6:47 pm

Re: XEGS Rom test fault

Postby Stargazer » Fri Feb 02, 2018 2:53 pm

krupkaj wrote:aha sorry I miss it. There is a trouble in ROM. You can download the XEGS ROM from here
http://ftp.pigwa.net/stuff/collections/ ... em%20ROMs/
and burn it to the chip


Thank you for your kind answer, in the web page you sended me there are two xegs roms, one named xegs rom the other xegs (full) i assume i must burn the full version ?
Also what name do i declare the rom chip of the atari on the programmer software ?


Social Media

     

Return to “The Atari 8bit corner”

Who is online

Users browsing this forum: No registered users and 1 guest