Scart tech woes- please help!

All discussions about the Atari 8bit range of machines.

Moderators: Mug UK, Silver Surfer, Moderator Team

seastalker
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Sun May 15, 2016 3:44 pm

Scart tech woes- please help!

Postby seastalker » Wed Jun 08, 2016 10:27 pm

Am I hording the 8-bit corner? I'm on a consecutive roll...

I'll start with the most important question and then a backstory:
What does it mean if your power up an Atari 800XL with monitor out displaying a blank green-ish screen (like the hue of the memory tests, etc) with a few reddish vertical lines? Is it surely the XL or a video issue such as cable or connector?

BACKSTORY:
So my recent gear- An untested Atari800xl and a MiST (fantastic and loving it!). I got the MiST with a VGA to Scart cable as well as a power cable and XL monitor to Scart adapter for my 800xl. I also bought an HDMI/SCART input to HDMI out upscaler I was hoping to use with both. I want to troubleshoot to replace/repair the non working items.

Testing device screens: A Dell Monitor, Two Samsung LED tvs, a converted 15" laptop screen remade into a monitor with VGA and HDMI inputs. All work well on their own as well as the Mist. Atari 800XL POWERS up so far.

Pre-test: Mist works on Dell monitor and makeshift laptop monitor (as well as friend's flat panel tv), but NO signal on Samsungs.

Test: 1st Scart/HDMI box- total fail. No signal from HDMI input via dvd player, nor either Scart device (XL nor Mist) on ANY screen. Power light went out on Scart box and now won't power at all. It was not a Panlong as advertised.

Test 2: A new but similar SCART/HDMI box arrived and this one gets some bios messages on some screens. HDMI input works but with less quality as a pass-thru device than going direct HDMI without it. Neither SCART device work but with slight "progress"... Mist displays nothing but box reports Mist as a PAL input and XL as NTSC in. The XL does display some green background with slight vertical red lines.

Pressing the PAL/NTSC toggle button only toggles 50/60 hz but input stays the same (XL= NTSC and swapping to Mist reports PAL). 720p/1080p can be swapped, but again the results can only be seen when toggled to HDMI input and unimpressive on either resolution.

So, if you've made it this far, any way for me to troubleshoot further?

I don't get the purpose of HDMI to HDMI at all, and the Scart cable leans too far towards the power cable to fell like it will stay. Maybe it's Framemeister N XRGB-Mini or nothing (Panlong is untested waters for me in quality and if your order one you are likely to get a generic replacement).

Is the XL "green" a sign that the power works but otherwise broken? I may get a non scart video cable to test. I'm at a loss as to not knowing which devices are working or not. I don't have a Scart input TV to test either Mist/XL cable and it takes weeks to get these little Chinese Scart boxes.

mlynn1974
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Mon Mar 03, 2008 10:33 pm
Contact:

Re: Scart tech woes- please help!

Postby mlynn1974 » Sun Jun 12, 2016 10:57 am

A few years ago a friend of mine built some ST Scart cables that were higher quality than the ones that are advertised on eBay etc.
I would first check that the scart cable itself is working without considering the scart to hdmi adaptors. It should work easily with the Samsung monitors. I have a Samsung SyncMaster 711MP and it works with scart cables wired with RGB, Composite and Commodore DTV with composite only etc.

What you could test is if the scart cables are "fully wired". By that I mean it should work if the video source supplies RGB and Composite wiring. A well made cable should also support the Status & Aspect Ratio up ( Pin 8 ) +9.5-12V on 4:3. If it doesn't support this you will manually need to switch to the video source by pressing AV1\AV2 etc. For the ST on the RGB lines you need 150 Ohm resistors otherwise the colour saturation is too high.

I take it the 800XL uses only composite output so it should work on any half-wired scart cable (composite only). I assume you have tested the 800XL by RF to ensure that normal video output is working?
Still got, still working: Atari 4Mb STe, 520STFM, 2.5Mb STF.
Hardware: Cumana CSA 354, Ultimate Ripper, Blitz Turbo, Synchro Express II (US and UK Versions).

seastalker
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Sun May 15, 2016 3:44 pm

Re: Scart tech woes- please help!

Postby seastalker » Mon Jun 13, 2016 12:45 am

I am waiting on an Atari 800xl video monitor out to standard yellow, red, white video/stereo audio cable to test the basics vs buying an RF converter. If the Atari works, then I must test the SCART cables. Without a SCART tv, I'd need to send them to someone on the forum or meet up with a local... or look for a scart tv to test on.

seastalker
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Sun May 15, 2016 3:44 pm

Re: Scart tech woes- please help!

Postby seastalker » Tue Jun 21, 2016 3:10 pm

Update: I got my standard video cable and it too only outputs a green screen with no audio (the classic booting several second "raspberry" noise). Is my 800 motherboard hosed? I do have those two added wires on the board so maybe a previous owner was soldering a video upgrade and messed up or didn't finish? I don't want to trash the board unless I know it is dead/un-repairable. Anyone on the forum fix them?

seastalker
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Sun May 15, 2016 3:44 pm

Re: Scart tech woes- please help!

Postby seastalker » Tue Jun 28, 2016 2:07 pm

NEW UPDATE: "DOUBLE VISION" issue:

Got a second Scart-HDMI adapter and this one powers up. Tested via HDMI in from a Shield TV which works (but HDMI to HDMI still feels useless to me if not breaking copy protection on content in the pass-thru). SCART now at least gets a signal, but I'm getting a DOUBLE image (left and right), like I could stare at it if it were a steroscopic 3D picture.. but of course it is not. Also, the display rotates up and down, like I need an old tv's "vertical hold" knob adjusted.

Being new to this SCART thing, does this sound like a resolution thing, a 50/60hz issue (again, repeats issue on multiple monitors), or are these Scart/HDMI boxes just cheap junk?

seastalker
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 113
Joined: Sun May 15, 2016 3:44 pm

Re: Scart tech woes- please help!

Postby seastalker » Tue Jun 28, 2016 2:09 pm

P.s. I think I ruled out the MIST as being the issue. It's VGA out looks fine on a PC monitor, and the same issue happens when I plug the VGA to SCART cable in the Scart/HDMI box, and toggle the VGA input between the MIST and my laptop VGA out. So frustrating!

User avatar
exxos
Hardware Guru
Hardware Guru
Posts: 4933
Joined: Fri Mar 28, 2003 8:36 pm
Location: England
Contact:

Re: Scart tech woes- please help!

Postby exxos » Tue Jun 28, 2016 2:18 pm

From what I hear about those HDMI boxes are very mixed results. From what I see people do seem to have a lot of problems with them. I think there was a guy who did some mods to one to make it work better, I can't remember where I saw it. It might have been on the atari-age forum.
4MB STFM 1.44 FD- VELOCE+ 020 STE - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - various clutter

http://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
http://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.
http://ataristeven.exxoshost.co.uk/Steem.htm Latest Steem Emulator

emcclariion
Atari maniac
Atari maniac
Posts: 79
Joined: Wed Nov 28, 2012 6:37 pm

Re: Scart tech woes- please help!

Postby emcclariion » Tue Jun 28, 2016 2:29 pm

I must admit, I have not had any issues with the SCART to HDMI box.

I have used a RGB SCART though
Mega STE 4MB, AlberTT and Atari STE 4MB TOS 2.06 Netusb Ultrasatan 2


Social Media

     

Return to “The Atari 8bit corner”

Who is online

Users browsing this forum: No registered users and 1 guest