CTPCI & DLink DFE-538TX **works**

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12787
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

CTPCI & DLink DFE-538TX **works**

Postby wongck » Mon Oct 07, 2019 11:53 am

So this is a RTL8139 based card from DLINK that I had for may be 3-4 years now.
Even as this card was listed in the RTL8139 source code, It was not picked up by the driver due to wrong vendorid/deviceid.

So this weekend, I decided to just add in the vendorid & deviceid into the current RFTL8139 driver.
And it works. :D

I cannot claim any credits as I just added the correct vendor & device id.
But I am happy now that I have another network card.

output during driver init:

Code: Select all

Loading interfaces:
aRTL8139: Testing adapter...
aRTL8139: Testing adapter...done
aRTL8139: RealTek RTL8139CP Fast Ethernet at 0x60000000, 00:50:BA:AB:46:B5
aRTL8139: TX buffers at 0x20D80000, RX buffers at 0x20D81800, DMA offset 0x0
RTL8139: Setting 100mbps full-duplex based on auto-negotiated partner ability 41E1.
aRTL8139: ioaddr 0x60000000 handle 0x1 full-duplex.


output of lspci -vv: - note non-Realtek ID

Code: Select all

00:01.0 Ethernet controller [0200]: D-Link System Inc RTL8139 Ethernet [1186:1300] (rev 10)
        Subsystem: D-Link System Inc DFE-538TX 10/100 Ethernet Adapter [1186:1300]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0 (8000ns min, 16000ns max)
        Interrupt: pin A routed to IRQ 255
        Region 0: I/O ports at <unassigned> [size=256]
        Region 1: Memory at 60000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1+,D2+,D3hot+,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-


iperf testing:

Code: Select all

root@F18:/root>iperf -c 192.168.3.2
------------------------------------------------------------
Client connecting to 192.168.3.2, TCP port 5001
TCP window size: 62.7 KByte (default)
------------------------------------------------------------
[  6] local 192.168.3.8 port 1038 connected with 192.168.3.2 port 5001
[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-10.1 sec  27.9 MBytes  23.2 Mbits/sec

My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 2 guests