CT63/CTPCI and Magic 6.20

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

Kroll
Captain Atari
Captain Atari
Posts: 368
Joined: Fri Mar 09, 2012 10:07 am

CT63/CTPCI and Magic 6.20

Postby Kroll » Mon May 22, 2017 5:54 pm

HI
I've been using CTPCI and Radeon for a few weeks and I wanted to run Magic 6.20 under Radeon cards
I'm sure with patched Magic.RAM, because I run it and I use it under CT63 on Videl.
I run the first file in the Auto folder MAGXBOOT.PRG (3870 bytes) prg, after this I saw table with the connected PCI cards again, but then appears the standard error of the CT63, press the space key and again error CT63 and end, I have to turn off the computer.

Does anyone know how to solve this problem?

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 192
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CT63/CTPCI and Magic 6.20

Postby Ektus » Tue May 23, 2017 4:10 pm

I can't remember how I did it, but have it running on my CT63. I'll post the configuration, but don't have access prior to next Thursday.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

Kroll
Captain Atari
Captain Atari
Posts: 368
Joined: Fri Mar 09, 2012 10:07 am

Re: CT63/CTPCI and Magic 6.20

Postby Kroll » Tue May 23, 2017 7:30 pm

Yesterday I found my old drive for 3-4 years, the first configuration before CTPCI crash. When I remember correctly, older versions of Magic 6.1 have a MAGIC.RAM file of length (244,476 bytes), and if I just changed the one I use at the moment (MAGIC.RAM 246.232 byte) the system works perfectly.
The conclusion is that the larger Magic.ram that works on CT63 and Videl does not work on Radeon.
Is there a special patch for CTPCI?

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 192
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CT63/CTPCI and Magic 6.20

Postby Ektus » Thu May 25, 2017 5:19 am

My working AUTO folder consists of the following entries:
CHECK_B.PRG 408 Byte to remove the drive letter for the non-existant second floppy
CT60XBIO.PRG 3787 Byte
NVDI503.PRG
MAGXBOOT.PRG 3680 Byte (patched 2010)
DRVIN-PRG, SCC.PRG, MIDI.PRG (Hsmodem)
WM.PRG 9275 Byte (mouse accelerator)
TRAPPER.PRG, MWHEEL.PRG (Mouse wheel driver)
EXTENDOS.PRG (optical disc driver)

MAGX.RAM has 246232 Byte and was last patched in 2010

Inside the GEMSYS folder, there's a file RADEON.SYS 83724 Byte and the NVDIDRV*.SYS are disabled.


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

Kroll
Captain Atari
Captain Atari
Posts: 368
Joined: Fri Mar 09, 2012 10:07 am

Re: CT63/CTPCI and Magic 6.20

Postby Kroll » Thu May 25, 2017 9:13 am

Thanks a lot
I noticed only such differences in my Auto folder
My MAGXBOOT has (3870 bytes)
The qquestions is:
You do not use DSPXBIOS.PRG and EXCEP060.PRG at all and if they are needed.
Could you send me MAGAIC.RAM, MAGXBOOT.PRG and WM.PRG.
I also use eiffel and PC mouse on PS / 2 connector too. Please send me trapper and mwheel.prg?
Trapper must be run before Mwhell?

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 192
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CT63/CTPCI and Magic 6.20

Postby Ektus » Thu May 25, 2017 1:39 pm

MAGXBOOT.PRG with 3870 byte may come from the tos060_201.lzh archive. Mine likely is a version that has been patched using the the patch program that came with the CT63. I won't send MAGIC.RAM, it's still sold by ASH. AFAIK, MAGIC.RAM (and/or magxboot?) must have been installed on the partition it boots from.

WM.PRG: That's wrapmouse, should be that one: http://www.cheshuntcomputerclub.co.uk/i ... wrap-mouse

Trapper is to be started first, as it installs a hook that's needed by MWheel. MWheel is availble from http://www.ardisoft.de/Produkte/MWheel/mwheel.html


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

Kroll
Captain Atari
Captain Atari
Posts: 368
Joined: Fri Mar 09, 2012 10:07 am

Re: CT63/CTPCI and Magic 6.20

Postby Kroll » Thu May 25, 2017 4:32 pm

Thank you very much for information. Is wrapmouse for serial mouse connect to RS232 ?
I want ask about DSPXBIOS.PRG and EXCPE060.PRG, you do not use it. Are these programs not required?

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 192
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CT63/CTPCI and Magic 6.20

Postby Ektus » Thu May 25, 2017 6:35 pm

Kroll wrote:Thank you very much for information.

You're welcome.

Kroll wrote: Is wrapmouse for serial mouse connect to RS232 ?

Among other things, yes. It's also a mouse speeder for any kind of mouse, and has the special feature to move the mouse pointer to the opposite side of the screen if you move it with high speed to the side. I've got an eiffel interface and use only the speeder and warp (wrap) function. The latter comes in handy with bigger screens, like my 1920x1200 LCD :-)

Kroll wrote:I want ask about DSPXBIOS.PRG and EXCPE060.PRG, you do not use it. Are these programs not required?


The system works without, so at least for basic function they are not required. The function may have become integrated in TOS, but I don't know for sure.

Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage


Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 2 guests