CT60e + Time&Date problem

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

User avatar
Robson
Atari Super Hero
Atari Super Hero
Posts: 631
Joined: Sun Feb 19, 2006 7:03 am
Location: London

CT60e + Time&Date problem

Postby Robson » Fri May 12, 2017 10:04 am

It might be just something obvious but I can't get the time and date set to correct values when booting in 060 mode.
I can click on the Date field but there is no out of it. I can type the settings but simply can't accept the changes, the control stuck in that field and I have to reset the falcon.

What would be the solution?
Thanks.
DSC08946.JPG
You do not have the required permissions to view the files attached to this post.
------------------------------------------------
http://www.tercsirobi.byethost14.com
------------------------------------------------

joska
Hardware Guru
Hardware Guru
Posts: 3636
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: CT60e + Time&Date problem

Postby joska » Fri May 12, 2017 10:38 am

This is a bug in Didier's patched xcontrol.cpx. The solution is to not use it to change date/time :)
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
Robson
Atari Super Hero
Atari Super Hero
Posts: 631
Joined: Sun Feb 19, 2006 7:03 am
Location: London

Re: CT60e + Time&Date problem

Postby Robson » Fri May 12, 2017 10:45 am

joska wrote:This is a bug in Didier's patched xcontrol.cpx. The solution is to not use it to change date/time :)

Thanks for letting me now.
------------------------------------------------
http://www.tercsirobi.byethost14.com
------------------------------------------------

mzry
Captain Atari
Captain Atari
Posts: 274
Joined: Tue Jan 26, 2016 12:39 pm

Re: CT60e + Time&Date problem

Postby mzry » Fri May 12, 2017 11:59 am

Is there a basic program we can use to set date/time in NVram? I find it annoying to have to rely on xcontrol.

User avatar
Robson
Atari Super Hero
Atari Super Hero
Posts: 631
Joined: Sun Feb 19, 2006 7:03 am
Location: London

Re: CT60e + Time&Date problem

Postby Robson » Fri May 12, 2017 12:08 pm

I've switched to COPS and it's working fine.
------------------------------------------------
http://www.tercsirobi.byethost14.com
------------------------------------------------

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11976
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CT60e + Time&Date problem

Postby wongck » Fri May 12, 2017 12:17 pm

I do not set my time on my FB now as it is done automatically via network ( using synctime ).
But there is a clock_e.cpx that I used to use that allows entry of time/date.
You can set clock_e.cpx to ask you for time entry on boot up.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11976
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CT60e + Time&Date problem

Postby wongck » Fri May 12, 2017 12:22 pm

Sorry just found the URL for it: http://hoepfl.de/%2Bold.hoepfl.de/2005/comp/atari.html

Allows you to key in 2017 instead of 1917.... LOL
1917 means that your Atari does not exist yet, so that's the reason why nothing happens... wah ... wah .....wah....
Last edited by wongck on Fri May 12, 2017 12:27 pm, edited 1 time in total.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 192
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CT60e + Time&Date problem

Postby Ektus » Fri May 12, 2017 12:25 pm

mzry wrote:Is there a basic program we can use to set date/time in NVram? I find it annoying to have to rely on xcontrol.

You can always use "date" from a command line.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

mzry
Captain Atari
Captain Atari
Posts: 274
Joined: Tue Jan 26, 2016 12:39 pm

Re: CT60e + Time&Date problem

Postby mzry » Fri May 12, 2017 12:47 pm

Thx! :)

fidzen
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 146
Joined: Tue Mar 31, 2015 5:13 pm
Location: Sweden

Re: CT60e + Time&Date problem

Postby fidzen » Fri May 12, 2017 4:58 pm

joska wrote:This is a bug in Didier's patched xcontrol.cpx. The solution is to not use it to change date/time :)


Good news! I have changed my RTC chip twice due to this problem. :-)
Atari Falcon, 14Mb RAM, CT60e, Supervidel, Svetlana, 512Mb RAM, 8Gb CF.
Atari Falcon, 14Mb RAM, CT63, 256Mb RAM,4Gb CF.
Firebee Series 2, 16Gb CF, 2Gb SD, MEGA ST Keyboard and Atari Mice.
Atari 2600 4-switch Woody


Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 1 guest