CTPCI and Realtek 8139D

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, lp, [ProToS], moondog/.tSCc., Moderator Team

User avatar
viking272
Captain Atari
Captain Atari
Posts: 348
Joined: Mon Oct 13, 2008 12:50 pm
Location: west of London, UK

Re: CTPCI and Realtek 8139D

Postby viking272 » Thu Jan 25, 2018 1:15 pm

Hi Latz, try that shorter better quality cable. I've seen cables cause 'flapping' issues on network devices, so well worth testing another cable.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12411
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Sun Jan 28, 2018 12:15 am

The daily Mint snapshot does not include the RTL8139.XIF driver.
What is the chance for that to be included ?
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

mikro
Atari God
Atari God
Posts: 1679
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: CTPCI and Realtek 8139D

Postby mikro » Sun Jan 28, 2018 3:18 am

wongck wrote:The daily Mint snapshot does not include the RTL8139.XIF driver.
What is the chance for that to be included ?

The chance is directly proportional to the time when I finish working on it: https://github.com/mikrosk/freemint/tree/rtl8139 ... i.e. not zero but have other things to keep me busy.

The most visible obstacle to finish this is to agree how the driver should work -- it calls quite a few PCI BIOS calls, I proposed to include them into the 'kerinfo' structure but it wasn't exactly welcome with praise: https://mikro.naprvyraz.sk/mint/freemin ... 01206.html

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12411
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Sun Jan 28, 2018 5:25 am

Ah ok. Glad to know it will be one day.
Just that after installing the snapshot, I had to come to this thread to get the file again.

Thank you Mikro for supporting us. :cheers:
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Sun Jan 28, 2018 9:53 am

Hi,

first problem solved: I removed the USB card from my "main" Falcon...
...and now upload is working perfect!
Transferred zipfiles 2-13 MB to my LinuxPC with an average speed of 2700 MB/sec with Litchi,
a 100 MB mp3 file with ~1900 MB/sec. Great, i´m really happy!! :D

But this does not explain why my second Falcon (which don´t have an USB card) still shows exactly
the same problem. Tested a short network cable, no difference. I´ll have to investigate further.

Thank you all for your great help!

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
viking272
Captain Atari
Captain Atari
Posts: 348
Joined: Mon Oct 13, 2008 12:50 pm
Location: west of London, UK

Re: CTPCI and Realtek 8139D

Postby viking272 » Sun Jan 28, 2018 10:36 am

Latz wrote:to my LinuxPC with an average speed of 2700 MB/sec with Litchi,
a 100 MB mp3 file with ~1900 MB/sec. Great, i´m really happy!! :D


Impressive network performance! :D

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12411
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Sun Jan 28, 2018 11:29 am

Latz wrote:first problem solved: I removed the USB card from my "main" Falcon...
...and now upload is working perfect!
Transferred zipfiles 2-13 MB to my LinuxPC with an average speed of 2700 MB/sec with Litchi,
a 100 MB mp3 file with ~1900 MB/sec. Great, i´m really happy!! :D


Glad that it is working for you now.

Other than why your other Falcon exhibited the same behavior, I wonder how is it that USB card "lame" the network card.
Something that we never know I guess.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and Realtek 8139D

Postby Latz » Mon Jan 29, 2018 10:45 am

Hi,

wongck wrote:Other than why your other Falcon exhibited the same behavior, I wonder how is it that USB card "lame" the network card.
Something that we never know I guess.

Only Didier knows... :|

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
piku
Captain Atari
Captain Atari
Posts: 164
Joined: Wed Jan 30, 2008 5:17 am
Location: Philadelphia, PA USA
Contact:

Re: CTPCI and Realtek 8139D

Postby piku » Tue Jan 30, 2018 3:11 am

Interesing I only have boot 2.01 and tos drivers 1.01 from didier's page.
piku http://www.atari-source.org http://rpmint.com/
CT60 Falcon - Dead Firebee - Some others ;)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12411
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Tue Jan 30, 2018 3:40 am

piku wrote:Interesing I only have boot 2.01 and tos drivers 1.01 from didier's page.

It is difficult to go over all the posting.
But it is here viewtopic.php?f=97&t=31641&start=25#p328257
You can find the latest beta 10 that is working.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

NEMOx
Atarian
Atarian
Posts: 1
Joined: Thu Jun 15, 2017 2:04 pm

Re: CTPCI and Realtek 8139D

Postby NEMOx » Sun Apr 22, 2018 5:49 pm

Hi
I heve problem with latest build mint. rtl8012ct60.xif doesn't work.
here is a listing of boot.log:
My config is CT60 with CTPCI.

"p RTL8012 ethernet romport driver version 1.10 q
˝ 2000 by Vassilis Papathanassiou.
˝ 2000-2010 by Frank Naumann.

pThis driver work only on 68000!q

Sorry, driver NOT installed - initialization failed!
"


This driver is ct60 version, but it is for 68000??
i am don't understand.
NEMOx

sorry for my english

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and Realtek 8139D

Postby Galvez » Sun Apr 22, 2018 6:19 pm

NEMOx wrote:Hi
I heve problem with latest build mint. rtl8012ct60.xif doesn't work.
here is a listing of boot.log:
My config is CT60 with CTPCI.

"p RTL8012 ethernet romport driver version 1.10 q
˝ 2000 by Vassilis Papathanassiou.
˝ 2000-2010 by Frank Naumann.

pThis driver work only on 68000!q

Sorry, driver NOT installed - initialization failed!
"


This driver is ct60 version, but it is for 68000??
i am don't understand.
NEMOx

sorry for my english

Here we have 2 issues. The first one is that you hit a bug introduced by me in MiNT sources some days ago that I'm fixing now, where checks for some CPUs is not correctly done. The second is that the driver you are trying to use is not for PCI cards but for a network adapter which uses the cartridge and parallel ports. The driver's sources for the PCI card is not in the MiNT's repository yet.
Last edited by Galvez on Mon Apr 23, 2018 6:05 am, edited 1 time in total.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12411
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and Realtek 8139D

Postby wongck » Sun Apr 22, 2018 11:42 pm

Should start downloading from this post onward.
There are couple more following it, you need to find one that works well for you.
Try to following the messy thread as several people were reporting back.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list


Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 1 guest