CTPCI and USB card

Discuss CT60/CT63, CTPCI, SuperVidel and EtherNAT hardware here.

Moderators: Mug UK, moondog/.tSCc., lp, [ProToS], Moderator Team

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Fri Jan 26, 2018 12:47 pm

Hi,

Galvez wrote:Another kernel to test, let's see how it goes.

Again, only tested regarding network functions:
SUCCESS
mint060_pcibios2 works correct here (exept my upload problem), like trunk2101 with disabled pciwrapper.
Tested NFS, Litchi and some web apps.

Great work, David!! :cheers:

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Fri Jan 26, 2018 2:28 pm

Galvez wrote:Another kernel to test, let's see how it goes.


Great that Latz got it working.

I downloaded Mint-F51 distribution into my Falcon. copied the new David's binaries #2. Adjusted my MINT.CNF and XaAEX.CNF.
But I get a OS killed error...
I also restored the original f51 mint060.prg.
Same happened..... :shrug: :shrug:
You do not have the required permissions to view the files attached to this post.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Fri Jan 26, 2018 3:43 pm

Hi,

this is when loading the rtl8139.xif driver. Are you shure that you use the correct .xif?
Perhaps your C: is corrupted (run "dosfsck -a" or "-r" like suggested)?

I use this build for testing Davids new kernels, if that helps:
https://github.com/freemint/freemint.github.io/tree/master/builds/freemint/master/old

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

Galvez
Captain Atari
Captain Atari
Posts: 183
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and USB card

Postby Galvez » Fri Jan 26, 2018 4:11 pm

Perhaps Latz didn't trigger the error because his kernel was running without memory protection and Wongck with it. I'm going to check if there is something that can trigger a memory violation in the code.

Thanks for the feed back!

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Fri Jan 26, 2018 4:14 pm

Yes, correct. No memory protection here.

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

Galvez
Captain Atari
Captain Atari
Posts: 183
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and USB card

Postby Galvez » Fri Jan 26, 2018 5:55 pm

Latz wrote:Yes, correct. No memory protection here.

Latz

Could you please test with memory protection enable to see if crashes also for you?

Thanks

Kroll
Captain Atari
Captain Atari
Posts: 396
Joined: Fri Mar 09, 2012 10:07 am

Re: CTPCI and USB card

Postby Kroll » Fri Jan 26, 2018 9:34 pm

Hi all,
today I received a repaired falcon mainboard from my friend and installed CT63, CTPCI and all 3 cards. Falcon 060 is working again.
I am very happy that I will return to the tests, but I have been out of circulation for the last few weeks. Please brief instructions, what should I install the latest freemint, mint060_pcibios_2.zip, you test the USB card, what devices do you connect, keyboard, mouse and pendrive?

Thank you in advance

Galvez
Captain Atari
Captain Atari
Posts: 183
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and USB card

Postby Galvez » Fri Jan 26, 2018 10:48 pm

Hi Kroll, great to read about your Falcon working again.

Over the latest FreeMiNT official snapshot install the kernel in mint060_pcibios_2.zip. Then let's try first only the network card function, without and with memory protection so we can see if Wongck's crash can be replicated.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Fri Jan 26, 2018 11:59 pm

Hi guys,
Saw the issue with my setup when I got up this morning.
I hope that it was not because I transferred the Mint-F51 via the (new found) thumb drive.
Guess I go back to my network to do the transfer later after I restore from backup.
You do not have the required permissions to view the files attached to this post.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sat Jan 27, 2018 1:43 am

Latz wrote:Perhaps your C: is corrupted (run "dosfsck -a" or "-r" like suggested)?


I cannot run this dosfsck on C;
tells me "cannot lock" or something like that.

I place it inside my MInt.CNF.... also have this statement.
So I do not know how to run this command on C:.

it runs well on my E: which is fat32, just not C:.

Any ideas?

BTW, I wipe my entire c: and restored from backup. Good thing was it took 15 mins or so, bad news is my last backup was from Oct 2017. I need to put back a lot of stuff and I hope I remember how.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Sat Jan 27, 2018 10:00 am

Hi,

Galvez wrote:Could you please test with memory protection enable to see if crashes also for you?

Tested with memory protection enabled:
mint060_pcibios_2 works correct here regarding network functions. No crash, no problems (like always exept my upload issue...)
Like i said before: Great work!

wongck wrote:I cannot run this dosfsck on C;
tells me "cannot lock" or something like that.

Use "init=u:/bin/bash" in mint.cnf.
Perhaps another (auto folder-) program locks drive C:? Is dosfsck or bash located on drive C:?
"dosfsck c:" works good here on FAT16, too.

Regards,
Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Sat Jan 27, 2018 10:43 am

Hi Kroll,

Kroll wrote:Falcon 060 is working again.

Great to hear that!! What was wrong??

Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sat Jan 27, 2018 11:44 am

Yes, David's 2nd mint.prg is working with my system. :thumbs:
Tested networking ..... OK
Tested keyboard...... OK.

Cannot test mouse because XaAES not working for this Mint-F51.

Great job David.

Took me 2 hrs just to get Mint-F51 to load XaAES( this is a record time for me to install Mint, normally 10 minutes will do )
No wonder Mikro told me to just use init=/bin/bash..... it's a good hint but would save me more time if told me about the folders.
And after this 2 hrs, just to find out that XaAES crashes on loading.
Turn off memory protection.... same crash.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Galvez
Captain Atari
Captain Atari
Posts: 183
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and USB card

Postby Galvez » Sat Jan 27, 2018 12:23 pm

Great! thanks a lot guys. I'll push the fix to freemint's github repo.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sat Jan 27, 2018 1:56 pm

Galvez wrote:Great! thanks a lot guys. I'll push the fix to freemint's github repo.

Thanks.
So tomorrow's snapshot build will have this fix ?
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sat Jan 27, 2018 4:24 pm

Latz wrote:I use this build for testing Davids new kernels, if that helps:
https://github.com/freemint/freemint.github.io/tree/master/builds/freemint/master/old


So I followed Latz and went back to the old school installation, much better.
I get all the way to the the desktop on 1st configuration :D
Something mixing up the 1-19-cur and 1-19-f51 folders in the new school installation that leads to crashing.

Anyway, further testing done
1. mouse - OK but it is still moving erratically as per the Mikro built.
2. USB thumb drive - OK able to read write to it.

So CTPCI network and USB functions are back :cheers:
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Galvez
Captain Atari
Captain Atari
Posts: 183
Joined: Fri Oct 19, 2007 7:49 am

Re: CTPCI and USB card

Postby Galvez » Sat Jan 27, 2018 9:20 pm

wongck wrote:
Galvez wrote:Great! thanks a lot guys. I'll push the fix to freemint's github repo.

Thanks.
So tomorrow's snapshot build will have this fix ?

Already there, I've just pushed the commits and thanks to Miro's work snapshots now are made whenever commits are pushed.

mikro
Atari God
Atari God
Posts: 1481
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: CTPCI and USB card

Postby mikro » Sat Jan 27, 2018 11:12 pm

Kroll wrote:Please brief instructions, what should I install the latest freemint, mint060_pcibios_2.zip, you test the USB card, what devices do you connect, keyboard, mouse and pendrive?

Thanks to David and others, the instructions are now plain simple: just download the latest snapshot (https://github.com/freemint/freemint.gi ... 87-020.zip), rename mintxxx.prg in your AUTO folder, depack everything to C:, set desktop in xaaes.cnf and tell me whether everything works (your network & usb card).

That will confirm that https://github.com/freemint/freemint/issues/71 can be really closed as you have been my main tester. :-)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sun Jan 28, 2018 5:30 am

Galvez wrote:Already there, I've just pushed the commits and thanks to Miro's work snapshots now are made whenever commits are pushed.


Downloaded it the "old school" trunk version, noticed it was build 3 hrs ago when I d/l it. :megaphone:

Installed and tested, all working as expected [smilie=greencolorz4_pdt_01.gif] . Network, USB mouse, USB keyboard and USB thumb drive.

Thanks !! :cheers:
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Latz
Captain Atari
Captain Atari
Posts: 217
Joined: Tue Mar 08, 2011 6:02 pm
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Latz » Sun Jan 28, 2018 9:54 am

Hi,

thank you mikro and David for this great support!!

I removed my USB card. It´s a VIA Technologies with chip "VT6212L". So this card can be listed as
"not working".

@wongck, can you please tell me which card you use?

Regards,
Latz
Falcon/CT60 90MHz, 14+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, DVD-RW.
Falcon/CT63 95 MHz, 4+128 MB RAM, CTPCI/Radeon 9250/RTL8139, Carte Eiffel+LCD, 80GB IDE HD, CD-RW.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12283
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: CTPCI and USB card

Postby wongck » Sun Jan 28, 2018 11:32 am

As mentioned by David, only USB NEC board using an NEC D720101 is working.
https://www.ebay.com/p/5-Port-NEC-D7201 ... /688427528

I got mine may be 5 years ago :roll: two of them. One cannot be detected at all.
The other working but may be not working 100% I though all ports should work. There are 5 ports.
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Kroll
Captain Atari
Captain Atari
Posts: 396
Joined: Fri Mar 09, 2012 10:07 am

Re: CTPCI and USB card

Postby Kroll » Sun Jan 28, 2018 12:53 pm

Latz wrote:Hi Kroll,

Kroll wrote:Falcon 060 is working again.

Great to hear that!! What was wrong??

Latz

Hi Latz,
Nothing serious, As I was talking with a friend who repaired it, only some small things improved on the 030 board, it was a problem with the falcon main board, not with the CT63

Kroll
Captain Atari
Captain Atari
Posts: 396
Joined: Fri Mar 09, 2012 10:07 am

Re: CTPCI and USB card

Postby Kroll » Sun Jan 28, 2018 1:05 pm

mikro wrote:Thanks to David and others, the instructions are now plain simple: just download the latest snapshot (https://github.com/freemint/freemint.gi ... 87-020.zip), rename mintxxx.prg in your AUTO folder, depack everything to C:, set desktop in xaaes.cnf and tell me whether everything works (your network & usb card).


The above link does not work and I do not know where to download this version freemint-1-19-187-020.zip

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 211
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: CTPCI and USB card

Postby Ektus » Sun Jan 28, 2018 3:33 pm

Go to https://github.com/freemint/freemint.gi ... master/new and select the newest build from there. I guess the "187" is an abbreviated build identifier, 020 being the target architecture.


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

mikro
Atari God
Atari God
Posts: 1481
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: CTPCI and USB card

Postby mikro » Sun Jan 28, 2018 10:33 pm

Yep, there has been a newer commit making the current 'latest' obsolete. Sorry for the confusion.


Social Media

     

Return to “CT60 / CT63 Area”

Who is online

Users browsing this forum: No registered users and 1 guest