double fullstops in filenames - missing icons - problem ?

A place to discuss current and future developments for STeem

Moderators: Mug UK, Steem Authors, Moderator Team

User avatar
exxos
Hardware Guru
Hardware Guru
Posts: 4933
Joined: Fri Mar 28, 2003 8:36 pm
Location: England
Contact:

double fullstops in filenames - missing icons - problem ?

Postby exxos » Mon Jan 04, 2016 6:21 pm

I'm not really sure this is a bug exactly but..

Steem__00030.png


I've noticed "blank" icons when there are 2 fullstops in the file name. I know this isn't supposed to happen in GEM anyway, so I guess its not really a emulation bug, more of a GEM bug. Either way I was sat there for a while thinking WTF.. before I worked out it, so thought I would at least mention it in case it catches anyone else out :)
You do not have the required permissions to view the files attached to this post.
4MB STFM 1.44 FD- VELOCE+ 020 STE - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - various clutter

http://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
http://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.
http://ataristeven.exxoshost.co.uk/Steem.htm Latest Steem Emulator

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1547
Joined: Sun Jul 31, 2011 1:11 pm

Re: double fullstops in filenames - missing icons - problem ?

Postby Eero Tamminen » Tue Jan 05, 2016 9:18 pm

Actually, there should be no fullstops in file name. When you e.g. save "DESKTOP.INF" file to a disk, it's on the FAT directory entry as "DESKTOP INF" i.e. the first part is padded to 8 chars with space(s) and "INF" continues directly from that without any redundant '.' character in-between. :-)

You cannot create filename with '.' in them through TOS or DOS, only with direct disk editing (or corruption).

If this is about STeem host file system passthrough, invalid file name characters should be converted to something valid like Hatari already does (including conversion for unicode file names).

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11976
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: double fullstops in filenames - missing icons - problem ?

Postby wongck » Tue Jan 05, 2016 10:46 pm

Maybe Kobold can edit the filename.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list


Social Media

     

Return to “Development”

Who is online

Users browsing this forum: No registered users and 2 guests