Some patches for the Linux build

A place to discuss current and future developments for STeem

Moderators: Mug UK, Steem Authors, Moderator Team

dfaure
Atarian
Atarian
Posts: 1
Joined: Sun Dec 24, 2017 11:32 am

Some patches for the Linux build

Postby dfaure » Sun Dec 24, 2017 11:40 am

Hello,

I've been trying to compile Steem SSE for Linux (the old Steem 3.2 being incompatible with hi-dpi screens).
I discovered that a SVN trunk checkout of steemsse doesn't build on Linux, so here's my contribution, fixing as many issues as I could.

It still doesn't build though, I'm hitting the following error, which I don't see how to fix:
../steem/code/x/x_options_create.cpp:1375:39: error: ‘struct TOption’ has no member named ‘PSGFixedVolume’

Note also this error, which might indicate an error in the code itself?
../steem/code/ior.cpp:1151:64: error: cast from ‘BYTE* {aka unsigned char*}’ to ‘BYTE {aka unsigned char}’ loses precision [-fpermissive]
case 0xffc100: ior_byte=(BYTE)(stem_version_text[0]-'0'); break;

Anyhow, after checking that it doesn't break the Windows compilation, please consider applying the attached patch, at least, so this work isn't lost ;)
(and double check what should be the value of SCANLINES_OK)

Some explanations:
- gamma is a math function from /usr/include/bits/mathcalls.h, so I renamed the array to sse_vid_gamma.
- using namespace std; creates a conflict on the function name "exception" (which collides with std::exception), so better not do that in a header file, and use "using namespace std;" only locally
- mfp_reg_name requires SSE_DEBUG, otherwise it doesn't exist.
You do not have the required permissions to view the files attached to this post.

User avatar
Steven Seagal
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2018
Joined: Sun Dec 04, 2005 9:12 am
Location: Undisclosed
Contact:

Re: Some patches for the Linux build

Postby Steven Seagal » Thu Dec 28, 2017 9:11 pm

Hi,
Thx, unfortunately I've completely let down the Linux build.
Notice that I did nothing special for hi-dpi screens. Did you try the last released version (3.7.2)?
The last version I made Linux-compatible was 382 "pre release", meaning the 3.8.2 code isn't guaranteed.
In the CIA we learned that ST ruled
Steem SSE: http://sourceforge.net/projects/steemsse


Social Media

     

Return to “Development”

Who is online

Users browsing this forum: No registered users and 4 guests