hanging

All things related to the Atari Coldfire Project

Moderators: Mathias, Mug UK, [ProToS], moondog/.tSCc., Galvez, Moderator Team

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

hanging

Postby alienkidmj12 » Sun Mar 18, 2018 5:19 pm

i just got around to getting my firebee up and running, it seems a bit unstable, it just starts to hang after 10 mins of use, anyone encounter this ?

dave

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Sun Mar 18, 2018 5:29 pm

seems to boot fine, but at the desktop it freezes :(

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Sun Mar 18, 2018 5:35 pm

managed to hold shift at bootup and disable most, it gets to gem now.

windows are flashing like a key is held down but it is not :( seems more stable, not crashed yet

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Mon Mar 19, 2018 2:35 pm

alienkidmj12 wrote:managed to hold shift at bootup and disable most, it gets to gem now.

windows are flashing like a key is held down but it is not :( seems more stable, not crashed yet

What kind of keyboard are you using an ATARI one or USB?

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Mon Mar 19, 2018 9:42 pm

i have a ps2 to rj11 adapter, its called an eiffel.

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Tue Mar 20, 2018 8:09 am

alienkidmj12 wrote:i have a ps2 to rj11 adapter, its called an eiffel.

OK. I also have this key stuck problem, apparently people using USB keyboards don't have it. Only people using the real ATARI keyboards and now it seems that the Eiffel too "suffer" from this issue. In my opinion the problem is in the FPGA as I have seen the key stuck effect with different configurations, also with EmuTOS and Bas_gcc, but it seems that there are configurations that trigger it more easily than others. The worst is with latest official FireTOS, the system is almost unusable, with FireTOS beta 12 and previous versions is OK, the problem happens from time to time, the same with EmuTOS.

I've post about this in the FireBee development forum long time ago but nobody has investigated it and nothing has been done to try to fix this.

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Wed Mar 28, 2018 5:33 pm

oh dear, what makes it worse is that they know about it, ive had this thing a year and not been able to use yet :( do you think the problem could be causing the crashes, well...the mouse pointer just hangs :(

vido
Atari Super Hero
Atari Super Hero
Posts: 590
Joined: Mon Jan 31, 2011 7:39 pm

Re: hanging

Postby vido » Wed Mar 28, 2018 6:09 pm

Well, my experience is just the other way.
I use Atari keyboard with my FireBee and I never had any problem with it. With USB keyboard I had key stuck problem so stoped using it.
But as I know with latest firmware/FireTOS release also that problem is solved.

But I think there is a problem with Eiffel.

Anyway ... there should be no problem with Atari keyboards at all!

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Wed Mar 28, 2018 6:34 pm

alienkidmj12 wrote:oh dear, what makes it worse is that they know about it, ive had this thing a year and not been able to use yet :( do you think the problem could be causing the crashes, well...the mouse pointer just hangs :(

I don't remember if it crashed the system, I don't think so, if I have time I'll reflash the lastest FireTOS release and see if it crashes too.
Which version of FireTOS do you have?

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Wed Mar 28, 2018 6:41 pm

vido wrote:Well, my experience is just the other way.
I use Atari keyboard with my FireBee and I never had any problem with it. With USB keyboard I had key stuck problem so stoped using it.
But as I know with latest firmware/FireTOS release also that problem is solved.

But I think there is a problem with Eiffel.

Anyway ... there should be no problem with Atari keyboards at all!

This is interesting, which version of FireTOS do you have?
You said that you changed the keyboard by an Atari one, and the mouse? Did you change too or you're still using an USB mouse?
When I talk about this issue I mean Atari keyboard and mouse connected to the Atari keyboard.
I don't think it is a problem with Eiffel, I don't use it, and I saw the same behavior some years ago in another FireBee using a TT keyboard.

vido
Atari Super Hero
Atari Super Hero
Posts: 590
Joined: Mon Jan 31, 2011 7:39 pm

Re: hanging

Postby vido » Thu Mar 29, 2018 5:50 am

Galvez wrote:This is interesting, which version of FireTOS do you have?
You said that you changed the keyboard by an Atari one, and the mouse? Did you change too or you're still using an USB mouse?
When I talk about this issue I mean Atari keyboard and mouse connected to the Atari keyboard.
I don't think it is a problem with Eiffel, I don't use it, and I saw the same behavior some years ago in another FireBee using a TT keyboard.

I am using Atari MSTE/TT keyboard and USB wireless mouse.
It is true that I used Atari mouse connected to Atari keboard just to check if it works. It worked but never really used it.

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Thu Mar 29, 2018 7:22 am

how do i find out what versions im running ?

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Thu Mar 29, 2018 7:38 am

vido wrote:
Galvez wrote:This is interesting, which version of FireTOS do you have?
You said that you changed the keyboard by an Atari one, and the mouse? Did you change too or you're still using an USB mouse?
When I talk about this issue I mean Atari keyboard and mouse connected to the Atari keyboard.
I don't think it is a problem with Eiffel, I don't use it, and I saw the same behavior some years ago in another FireBee using a TT keyboard.

I am using Atari MSTE/TT keyboard and USB wireless mouse.
It is true that I used Atari mouse connected to Atari keboard just to check if it works. It worked but never really used it.

With which version of FireTOS did you test it? I works for FireTOS version previous to the beta 12, the problem is still there but it triggers less commonly.

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Thu Mar 29, 2018 7:47 am

alienkidmj12 wrote:how do i find out what versions im running ?

During boot time it is shown on the screen. It will say something like "BETA XX" and a date, the text scrolling can be fast so you have to be focused ;-)
In the meantime you could try to test the combination: keyboard through Eiffel plus USB mouse, maybe it's the workaround solution to get rid of your key stuck effect problem.

vido
Atari Super Hero
Atari Super Hero
Posts: 590
Joined: Mon Jan 31, 2011 7:39 pm

Re: hanging

Postby vido » Thu Mar 29, 2018 8:16 am

Galvez wrote:In the meantime you could try to test the combination: keyboard through Eiffel plus USB mouse, maybe it's the workaround solution to get rid of your key stuck effect problem.

I believe the only way to get rid of this problem is to upgrade firmware tothe latest available on the firebee.org web page.
But you have to be very careful when you flash the new firmware!!!
Read the instructions you got together with the official Free MiNT setup on your flash card. I guess they are in the "flasher" direectory?
If somethig goes wrong when you flash the firmware you will end with the nonworking FireBee and will require to reflash it using BDM cable and PC computer.

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Thu Mar 29, 2018 8:50 am

vido wrote:
Galvez wrote:In the meantime you could try to test the combination: keyboard through Eiffel plus USB mouse, maybe it's the workaround solution to get rid of your key stuck effect problem.

I believe the only way to get rid of this problem is to upgrade firmware tothe latest available on the firebee.org web page.

As I've already written many times it is the the latest official firmware that behaves the worst regarding this issue. I suppose if he has the FireBee since one year then it's a new batch FireBee (if it's not a used one), so the latest firmware is already there.

vido wrote:But you have to be very careful when you flash the new firmware!!!
Read the instructions you got together with the official Free MiNT setup on your flash card. I guess they are in the "flasher" direectory?
If somethig goes wrong when you flash the firmware you will end with the nonworking FireBee and will require to reflash it using BDM cable and PC computer.

I wouldn't try to flash by software in such unstable system without a BDM cable.

vido
Atari Super Hero
Atari Super Hero
Posts: 590
Joined: Mon Jan 31, 2011 7:39 pm

Re: hanging

Postby vido » Thu Mar 29, 2018 9:00 am

Galvez wrote:I wouldn't try to flash by software in such unstable system without a BDM cable.

If its generaly unstable system, I would also try to change power adapter with the one with more power. I guess the most such problems with the FireBees causes power adapters.

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Thu Mar 29, 2018 2:13 pm

im using a 24v fsp group psu, i changed the caps in it, i know it works :(

fidzen
Captain Atari
Captain Atari
Posts: 171
Joined: Tue Mar 31, 2015 5:13 pm
Location: Sweden

Re: hanging

Postby fidzen » Thu Mar 29, 2018 6:59 pm

alienkidmj12 wrote:im using a 24v fsp group psu, i changed the caps in it, i know it works :(


Did you change caps in a modern psu? What's the need for that?
And it should be a 12V PSU, not 24V.
Atari Falcon, 14Mb RAM, CT60e, Supervidel, Svetlana, 512Mb RAM, 8Gb CF.
Atari Falcon, 14Mb RAM, CT63, 256Mb RAM,4Gb CF.
Firebee Series 2, 16Gb CF, 2Gb SD, MEGA ST Keyboard and Atari Mice.
Atari Stacy 2 with 4Mb RAM and 20Mb HD.
Atari Lynx II with new LCD and VGA output.
Atari 2600 4-switch Woody

vido
Atari Super Hero
Atari Super Hero
Posts: 590
Joined: Mon Jan 31, 2011 7:39 pm

Re: hanging

Postby vido » Fri Mar 30, 2018 6:01 am

fidzen wrote:Did you change caps in a modern psu? What's the need for that?
And it should be a 12V PSU, not 24V.

I think it can be something from 12V to 24V. It just have to provide enough power! I guess it should be at least 2A or something aroung 50W.
It also depends what is attached to the FireBee. USB devices also needs some current.

User avatar
jfl
Atari Super Hero
Atari Super Hero
Posts: 858
Joined: Tue Jul 18, 2006 10:55 pm
Location: Liège, Belgium
Contact:

Re: hanging

Postby jfl » Fri Mar 30, 2018 6:10 am

My TT keyboard and PeST-connected mouse work fine. Boot v2.02. Sometimes I get that annoying key repeat but it can be cured by hitting any key so not a big issue, really.
Jean-François
GEMDict – GEMClip

Galvez
Captain Atari
Captain Atari
Posts: 225
Joined: Fri Oct 19, 2007 7:49 am

Re: hanging

Postby Galvez » Fri Mar 30, 2018 6:30 am

jfl wrote:My TT keyboard and PeST-connected mouse work fine. Boot v2.02. Sometimes I get that annoying key repeat but it can be cured by hitting any key so not a big issue, really.

Probably you must have a FireTOS BETA 12 from the 18th December 2012 or a previous version, for FireTOSes versions post this date the key repeat effect doesn't happen sometimes it's constantly, the system is unusable. Could you confirm which FireTOS beta version do you have?

User avatar
jfl
Atari Super Hero
Atari Super Hero
Posts: 858
Joined: Tue Jul 18, 2006 10:55 pm
Location: Liège, Belgium
Contact:

Re: hanging

Postby jfl » Wed Apr 04, 2018 9:28 pm

It looks like I have Beta 15. I say "it looks like" because it's not easy to spot.
Jean-François
GEMDict – GEMClip

alienkidmj12
Captain Atari
Captain Atari
Posts: 170
Joined: Sat Mar 10, 2012 6:45 pm

Re: hanging

Postby alienkidmj12 » Sat Aug 04, 2018 10:15 am

sorry, did not see response, i have other issues at moment, my fb wont boot, corrupted cf, im looking for image at moment.


Social Media

     

Return to “FireBee”

Who is online

Users browsing this forum: No registered users and 3 guests