ScummVM sound on Milan

A section to cover all the different problems encountered by running game x on system y! Whether it's as simple as a non-STE compatible game through to h/drive installable games. Discuss them all in here.

Moderator: Moderator Team

PeterS
Captain Atari
Captain Atari
Posts: 193
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

ScummVM sound on Milan

Postby PeterS » Sat Oct 20, 2018 7:01 pm

Has anyone got the sound worjing in ScummVM on tbe Milan ?

I don't think I ever got it working in any game and they are a bit dull without the music. The same with pmDoom.

User avatar
Neurotoxic
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 116
Joined: Thu Apr 20, 2017 9:29 pm
Location: Bremen (Germany)
Contact:

Re: ScummVM sound on Milan

Postby Neurotoxic » Sat Oct 20, 2018 11:18 pm

I've got the ScummVM 1.9.0 installed on my Milan040 but I never managed it to get it running. Perhaps the Milan040 is to slow for it?

PmDoom is just running fine on my Milan040 but I have to use it in the smallest resolution and the quality of the sound isn't very good. I think that also due to the 68040.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Card, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee, PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

mikro
Hardware Guru
Hardware Guru
Posts: 1779
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: ScummVM sound on Milan

Postby mikro » Sun Oct 21, 2018 8:11 am

Out of curiosity, about which build we are talking about? Where it comes from?

PmDoom should work fairly well, as it is based on SDL which supports a wide range of audio routines... What value do you set SDL_AUDIODRIVER to? According to my research (https://mikrosk.github.io/extended-xbios), you should be fine using either SDL_AUDIODRIVER=mint_xbios or, with GSXB, SDL_AUDIODRIVER=mint_gsxb.

PeterS
Captain Atari
Captain Atari
Posts: 193
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: ScummVM sound on Milan

Postby PeterS » Tue Oct 23, 2018 12:16 pm

ScummVM: I will have to check the version. It runs ok on the 060 with Monkey Island and Tentacle but the mouse click response seems a bit slower than I remember.

PmDoom: I think is version 0.59. I tried both mint_xbois and mint_gsxb (with and without gsxb running from AUTO) but it will not start, saying it cannot find the audio. It definately used to work. I seem to remember a long discussion about sound in PmDoom about 12 years ago when I may have been using NAES.

Interestingly, the gsxb mixer kills the normal mixer prog (same name ?) and when it opens the sliders will not work properly, they immediately jump back to zero.

I have an isa Soundblaster.

mikro
Hardware Guru
Hardware Guru
Posts: 1779
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: ScummVM sound on Milan

Postby mikro » Tue Oct 23, 2018 12:27 pm

Strange. Hopefully in near future I will release mxPlay with Hades/Milan support so then we can do further audio analysis in cases like this.

PeterS
Captain Atari
Captain Atari
Posts: 193
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: ScummVM sound on Milan

Postby PeterS » Thu Oct 25, 2018 12:11 pm

Thanks. Happy to test things.


Social Media

     

Return to “Games - Compatibility Issues etc.”

Who is online

Users browsing this forum: No registered users and 9 guests