TOS 2.06 and 1.62

A section to cover all the different problems encountered by running game x on system y! Whether it's as simple as a non-STE compatible game through to h/drive installable games. Discuss them all in here.

Moderator: Moderator Team

Jagman5994
Atariator
Atariator
Posts: 18
Joined: Wed Jul 23, 2014 7:57 am

TOS 2.06 and 1.62

Postby Jagman5994 » Fri Aug 01, 2014 10:09 pm

Greetings,
I am new here. I have just rejoined the world of Atari with a purchase of a 1040STE' after being without one for about 20ish years, and I have started to upgrade it. I have purchased an Ultrasatan and am waiting for its arrival. I was going to upgrade it to 4Mb, but did not have to as when I powered it up for the first time, I found it had already been upgraded :) (not sure the seller knew this!)
I am sure my question has been asked here, but I have been trawling through the forums and cannot find a definite answer.
I am thinking of upgrading its TOS to 2.06 from 1.62 and was wondering if I will have any compatibility problems with games. I know that low v1 TOS's are the most games compatible. I have seen messages stating that there are problems with 2.06 over 1.0x, but is there much of a difference between 1.62 and 2.06 with regard to games?
Thanks

User avatar
troed
Atari God
Atari God
Posts: 1197
Joined: Mon Apr 30, 2012 6:20 pm
Location: Sweden

Re: TOS 2.06 and 1.62

Postby troed » Fri Aug 01, 2014 10:54 pm

Jagman5994 wrote:I am thinking of upgrading its TOS to 2.06 from 1.62 and was wondering if I will have any compatibility problems with games. I know that low v1 TOS's are the most games compatible. I have seen messages stating that there are problems with 2.06 over 1.0x, but is there much of a difference between 1.62 and 2.06 with regard to games?


Adding a switch for a dual-TOS is a small amount of work and my memory claims it to be a good idea. However, the only problems I really know of are with earlier versions of TOS.

My own STE is 1.62-2.06 switchable, at least.

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2796
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: TOS 2.06 and 1.62

Postby AtariZoll » Sat Aug 02, 2014 6:35 am

Yes, TOS switch (or dual TOS) in machine is good idea, and costs not much.

TOS 2.06 has some differences what are not good for some games. The first problem is that it takes more low RAM than older TOS versions. And there are games which have code written to fixed RAM space - and if it is lower than TOS 2.06 workspace it will crash. Example is Millennium 2.2 .

Another problem is Timer-C . In TOS 2.06 more calls, mostly GEMDOS calls need that Timer-C work at default 200Hz. So, if game uses Timer-C at it's own, it may fail. Examples: Space Harrier, Flight of Intruder ...

Since you will have mass storage, I recommend to get adapted games for hard disks, where most of problematic ones is fixed for TOS 2.06 too .
http://atari.8bitchip.info/fromhd.php
Negative feedback has usually positive effect.

Jagman5994
Atariator
Atariator
Posts: 18
Joined: Wed Jul 23, 2014 7:57 am

Re: TOS 2.06 and 1.62

Postby Jagman5994 » Sun Aug 03, 2014 7:27 am

I was thinking about a TOS switcher, but the ones I have seen state that once installed, it cannot be undone without fitting new rom sockets as the switcher board has fat pins and makes the existing sockets loose.
I don't like the idea of doing an irreversible upgrade. I like to keep my machine as original as possible.

Thanks for the info about games from mass storage, didn't know about that site.


Social Media

     

Return to “Games - Compatibility Issues etc.”

Who is online

Users browsing this forum: No registered users and 1 guest