A few gbe questions...

GFA BASIC-related articles in here please

Moderators: exxos, simonsunnyboy, Mug UK, Zorro 2, Moderator Team

zelurker
Atarian
Atarian
Posts: 2
Joined: Fri Sep 29, 2017 1:03 pm

A few gbe questions...

Postby zelurker » Fri Sep 29, 2017 1:11 pm

Hi, I tried to find the mail of the author of gbe, but it's nowhere to be found, and he even disabled comments on his youtube videos !
So I post my questions here, maybe someone will have an idea...

1) why does the integrated help doesn't work ? All the help menu does nothing, no error message, nothing displayed. It's on aranym, the hyp file is there, st-guide is correctly installed with an association for hyp files in teradesk, all the other programms accept the shift+help shortcut to launch their help except gbe. I have absolutely no idea what's going on here, I am just calling st-guide from the accessory menu and looking manually for what I need but I would have liked to see this thing working...

2) why is the latest version, 1.71 I think, unlaunchable in aranym ? The app displays a message about "wrong cpu type, please use the correct binary", and the prg dispalys something about an overlay error. This is in aranym, so using freemint, xaaes, etc... I even tried in hatari and I get the same errors.

I got an interest on gfa lately to see if I could code a simple recursive problem in gfa (the 8 queens on a chess board). That's where I discovered that gfa basic doesn't support local arrays ! I could work around this and the code works, but I still have these questions...

User avatar
christos
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2291
Joined: Tue Apr 13, 2004 8:24 pm
Location: Greece
Contact:

Re: A few gbe questions...

Postby christos » Fri Sep 29, 2017 4:42 pm

Hi, and welcome.

Well, I can't speak for Lonny, but I am not sure that 1.71 is the latest version. I haven't had any problems running GBE on any of my systems so my first guess would be that you downloaded the coldfire executable. Try redownloading from the site.
http://96-32-243-246.static.oxfr.ma.cha ... sic/atari/
Felix qui potuit rerum cognoscere causas.
My Atari blog

STOT Email address: stot(NoSPAM)atari(DOT)org

User avatar
lp
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2227
Joined: Wed Nov 12, 2003 11:09 pm
Location: GFA Headquarters
Contact:

Re: A few gbe questions...

Postby lp » Fri Sep 29, 2017 5:10 pm

The domain name expired and the admin decided to change it instead of renewing the old one. I had to fix a bunch of broken links and might of missed some. Apologize ahead of time if so. http://gfa.atari-users.com/atari/

Unfortunately, so called social media sites are frequented by immature people who write negative comments just for the sake of being mean. I don't have the time to manage negative feedback so it's easier to just disable the comment feature. :wink:

You can also find me at https://www.facebook.com/groups/gfabasic/

It sounds like you had an older version, perhaps 1.5x and then installed 1.71. Find your HOME folder and locate all files with *.GBE extension. Either move them out of the HOME folder, delete them, or rename them *.GBX. Then restart GBE. There's two binaries, GBE.APP is only for the Firebee and GBR.PRG is for all other machines.

zelurker
Atarian
Atarian
Posts: 2
Joined: Fri Sep 29, 2017 1:03 pm

Re: A few gbe questions...

Postby zelurker » Sat Sep 30, 2017 2:26 pm

Hi ! Thanks for the quick reply. For some reason I have always used the .app in 1.51.x without any problem with aranym, it stopped working with this 1.71 version. The mysterious error message about overlay with the prg went away when I removed the *.gbe files, I didn't think it was the cause here, thanks ! And the 1.71 version finally correctly launches st-guide so everything seems fine.
Congratulations for your work by the way, quite impressive to see that someone did so much work to try to keep the gfabasic up to date !

Thanks again ! :)


Social Media

     

Return to “GFA BASIC”

Who is online

Users browsing this forum: No registered users and 1 guest