Hatari Alt+F4 not working

A forum about the Hatari ST/STE/Falcon emulator - the current version is v2.2.0

Moderators: simonsunnyboy, thothy, Moderator Team

Qumojo
Atarian
Atarian
Posts: 1
Joined: Sun Mar 10, 2019 3:42 pm

Hatari Alt+F4 not working

Postby Qumojo » Sun Mar 10, 2019 4:03 pm

Hi, I am enjoying this fantastic emulator but I am having some trouble with how this emulator seems to be coded.

What I mean is that I can't seem to be able to do an Alt+F4 to exit the emulator, even a simple alt+ctrl+sup sometimes to be off, and when working I get the mouse stuck in the middle. This is specially important to me as I run it using BigBox. Sometimes altgr+q just doesn't work. And I must have a way to force exit the emulator at any point.

As well as binding keys to my controller. Usually for some games in AtariST you will only need the Return and space key as basic keys to start playing that game. I can't manage to bind them to my controller, tried x360ce, Ahotkey and others. To me, it seems that Hatari has been coded as a modal window soft and there is no much else to do.

Any suggestion on how to deal with it? Is it just me and I am not seeing that tick option that allows the binding and alt+f4 functions?

Thanks and keep up the great work.

User avatar
Eero Tamminen
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2019
Joined: Sun Jul 31, 2011 1:11 pm

Re: Hatari Alt+F4 not working

Postby Eero Tamminen » Sun Mar 10, 2019 7:33 pm

You didn't say which OS and desktop you're using. Hatari is developed on Linux (that's what Hatari developers have).

If you have a desktop keyboard shortcut for Alt-F4, and it doesn't work, I don't think that's a Hatari problem, but likely a bug in your desktop. It might be a bug also in your libSDL version, depending on what even that key is supposed to provide.

(You didn't say which version of libSDL you're using, I have libSDL v2.0.5 and with that, Alt-F4 closes Hatari just fine in XFCE desktop.)

What's BigBox?

AltGr-Q works fine for me as long as Hatari doesn't have a dialog open, in that case you just have to close the dialog first (e.g. with Enter). There are some rare cases where Hatari's outputting errors about what's running inside emulation so fast that it's not very responsive. Do you see any such output when you run Hatari from console? (if you're using Windows, console requires giving Hatari -W option)

If you want your controller to output key codes, that's something you need to do outside of Hatari. I think there are some programs on Linux to do that.

darwinmac
Captain Atari
Captain Atari
Posts: 217
Joined: Sat Aug 06, 2011 2:49 pm
Location: San Jose, USA

Re: Hatari Alt+F4 not working

Postby darwinmac » Sun Mar 10, 2019 11:01 pm

It appears the OP is using Windows. Big Box (https://www.launchbox-app.com/big-box) appears to be a front end that can be used to run games from different emulators.

I haven’t run the Windows version of Hatari for awhile. I don’t know if there’s a problem with using Alt-F4 to close Hatari.

Bob C

User avatar
dhedberg
Atari God
Atari God
Posts: 1128
Joined: Mon Aug 30, 2010 8:36 am
Contact:

Re: Hatari Alt+F4 not working

Postby dhedberg » Sun Mar 10, 2019 11:30 pm

I can confirm that Hatari does not respond to the Alt+F4 shortcut in Windows. AltGr+Q works.
Daniel, New Beat - http://newbeat.atari.org. Like demos? Have a look at our new Falcon030 demo and feel the JOY.

ThorstenOtto
Atari Super Hero
Atari Super Hero
Posts: 900
Joined: Sun Aug 03, 2014 5:54 pm

Re: Hatari Alt+F4 not working

Postby ThorstenOtto » Mon Mar 11, 2019 4:35 am

Such Alt-combinations are handled differently on Windows. But that's not Hatari's fault, i guess that can't be easily fixed without changing SDL.


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 3 guests