Problems with GEMDOS drive and MiNT

A forum about the Hatari ST/STE emulator - the current version is v2.0.0

Moderators: simonsunnyboy, thothy, Moderator Team

User avatar
SweYC
Atariator
Atariator
Posts: 25
Joined: Sun Apr 27, 2014 2:32 pm

Problems with GEMDOS drive and MiNT

Postby SweYC » Thu Oct 20, 2016 4:55 pm

Hello,

Recently i got stuck with hatari 1.9.0 and gemdos drive access... I boot from ide disk image, and need to acces hostfs (linux), so i tried to use folder as gemdos drive, but it keep poping as C: drive, even if i select gemdos drive after real partitions... The other method, the single letter folder names works okay, i have set a P:/ drive, but no luck with that in MiNT. Works preety good in TOS, no way to get it working in MiNT. Drive P actually shows up in U: drive, but doubleclicking it, shows U: drive directory again.... any ideas?

Janez

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2759
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: Problems with GEMDOS drive and MiNT

Postby AtariZoll » Thu Oct 20, 2016 5:34 pm

MINT needs real hard disk emulation (ACSI or IDE), so can not work from GEMDOS emulated drive.
English language is like bad boss on workplace: it expecting from you to strictly follow all, numerous rules, but self bending rules as much likes :mrgreen:

User avatar
SweYC
Atariator
Atariator
Posts: 25
Joined: Sun Apr 27, 2014 2:32 pm

Re: Problems with GEMDOS drive and MiNT

Postby SweYC » Thu Oct 20, 2016 6:43 pm

AtariZoll wrote:MINT needs real hard disk emulation (ACSI or IDE), so can not work from GEMDOS emulated drive.


MiNT works okay... I do boot from real hard disk images. Into TOS or MiNT and works perfectly... however, i have pointed GEMDOS drive emulation to hosts ATARI folder, which contain P, R folders respectively and in TOS both R and P drive shows nicely, but not in MiNT.

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2759
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: Problems with GEMDOS drive and MiNT

Postby AtariZoll » Thu Oct 20, 2016 8:53 pm

OK, then I rephrase: GEMDOS drive is only for ROM TOS, not for MINT.
English language is like bad boss on workplace: it expecting from you to strictly follow all, numerous rules, but self bending rules as much likes :mrgreen:

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1512
Joined: Sun Jul 31, 2011 1:11 pm

Re: Problems with GEMDOS drive and MiNT

Postby Eero Tamminen » Fri Oct 21, 2016 10:46 pm

The reason is that MiNT replaces the GEMDOS vector with its own, overriding the mechanism installed by Hatari at start.

(ne could re-install Hatari GEMDOS HD emulation "vector" after MiNT has booted, through the Hatari debugger, but it's not very reliable.)

To get Hatari GEMDOS HD emulation working properly with MiNT, one needs to use TOSFS (which calls ROM TOS or whatever was installed on the system before MiNT started). It was removed from newer MiNT versions, but Helmut has a branch of latest MiNT which re-added / updated TOSFS support.

joska
Hardware Guru
Hardware Guru
Posts: 3574
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Problems with GEMDOS drive and MiNT

Postby joska » Sat Oct 22, 2016 10:21 am

ARAnyM might be a better choice for this. I lets you boot MiNT cleanly from the host filesystem. No TOSFS support necessary.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1512
Joined: Sun Jul 31, 2011 1:11 pm

Re: Problems with GEMDOS drive and MiNT

Postby Eero Tamminen » Sun Oct 23, 2016 6:15 pm

For MiNT stuff Aranym is surely better alternative, unless one wants real 68000 or 68030+MMU emulation and not 040 emulated by Aranym.

For host file system access with Aranym, one needs NatFeats VFAT MiNT driver instead of TOSFS MiNT driver.


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 1 guest