IDE disk image

A forum about the Hatari ST/STE/Falcon emulator - the current version is v2.1.0

Moderators: simonsunnyboy, thothy, Moderator Team

jury
Captain Atari
Captain Atari
Posts: 291
Joined: Tue Sep 21, 2004 11:11 am
Location: Poland

IDE disk image

Postby jury » Tue Sep 18, 2018 7:31 pm

Is it possible to attach a Falcon's IDE disc's image?
I of course read the documentation, but my English-foo is too weak to understand that ( for sure it is possible for ACSI images, but how about IDE's? ) so I decided to check it.
I have an image done through dd and when trying to attach it in Hatari it doesnt boot. It seems that it starts to read from the image as under Atari logo at boot I see:

Code: Select all

HDDRIVER V8.49
Uwe Seimet
Atari IDE 00.00: Hatari IDE master disk, Direct Access

But it stops there.
Hatari 2.1.0

mikro
Atari God
Atari God
Posts: 1733
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: IDE disk image

Postby mikro » Tue Sep 18, 2018 7:58 pm

Sure it is, I do it all the time, even directly with /dev/sdx. Are you sure it isn't just stopped on SCSI detection? That takes ages with old builds.

jury
Captain Atari
Captain Atari
Posts: 291
Joined: Tue Sep 21, 2004 11:11 am
Location: Poland

Re: IDE disk image

Postby jury » Wed Sep 19, 2018 8:42 am

mikro wrote:Are you sure it isn't just stopped on SCSI detection? That takes ages with old builds.


Thanks, I was just impatient and been quitting Hatari after few minutes hanging on that screen thinking that it hang for sure. When I give it more time it goes forward. But unfortunately doesnt load MiNT. At the end of loading I get the white screen with a lot of random pixel mess. TOS starts fine, but not many things work, I must play with it a lot and do some tweaks I guess.
Do you use MiNT fine in Hatari when you attach IDE image?

ThorstenOtto
Captain Atari
Captain Atari
Posts: 400
Joined: Sun Aug 03, 2014 5:54 pm

Re: IDE disk image

Postby ThorstenOtto » Wed Sep 19, 2018 10:23 am

jury wrote:
mikro wrote:Do you use MiNT fine in Hatari when you attach IDE image?


Memory protection should be turned off, but other than that, it works, yes. Only thing that is a bit difficult is to make it bootable when you are not using EmuTOS.

jury
Captain Atari
Captain Atari
Posts: 291
Joined: Tue Sep 21, 2004 11:11 am
Location: Poland

Re: IDE disk image

Postby jury » Wed Sep 19, 2018 5:29 pm

My fault, I have not fully disabled Super Videl configuration so it was half way SV configured and thats why the random pixel mess at the end of MiNT loading. I have disabled SV completely now and it load fine. Yaiks, I see ( and kind of work ) my Falcon MiNT setup on my Linux box :D
I have also tried the EmuTOS and it doesnt work at all for me. TOS bombs out when I choose not to load MiNT and MiNT doesnt load also, it hangs at XaAES splash screen ( and this time I waited like 6-7 minutes before closing it )

ThorstenOtto wrote:Only thing that is a bit difficult is to make it bootable when you are not using EmuTOS.


To be honest, I did not have to do anything special or difficult under TOS 4.04, I just attached an image for IDE master and that was all, it boots fine.
Last edited by jury on Wed Sep 19, 2018 5:46 pm, edited 3 times in total.

ThorstenOtto
Captain Atari
Captain Atari
Posts: 400
Joined: Sun Aug 03, 2014 5:54 pm

Re: IDE disk image

Postby ThorstenOtto » Wed Sep 19, 2018 10:08 pm

jury wrote:TOS bombs out when I choose not to load MiNT and MiNT doesnt load also, it hangs at XaAES splash screen


There was a bug in EmuTOS when trying to set hires modes. That mode isn't yet supported by EmuTOS, and could crash if you tried to activate it. It has been fixed recently, but of course that does not mean that hires is supported now, it just shouldn't crash anymore. You need to use some other mode with EmuTOS.

To be honest, I did not have to do anything special or difficult under TOS 4.04, I just attached an image for IDE master and that was all, it boots fine.


Then that image was maybe already bootable. Otherwise it's a chicken-and-egg problem.


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 2 guests