Steem debugger

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

slingshot
Atari God
Atari God
Posts: 1273
Joined: Mon Aug 06, 2018 3:05 pm

Steem debugger

Postby slingshot » Mon Sep 30, 2019 10:53 am

Hi!

I've encontered a strange debugging issue: a demo loader does a memory cleaning loop, and this loop interrupted somehow before the whole memory is zeroed out. But I cannot find out the interrupting device. Turned on all of the tracing options, but what I see the CPU tracing just switches off, and no indication why. The steem.log snippet:

The loop:

Code: Select all

00109E: dbra d0,-6 {$00109A}
00109A: movem.l D1-7/A0,-(a1)
00109E: dbra d0,-6 {$00109A}
00109A: movem.l D1-7/A0,-(a1)
00109E: dbra d0,-6 {$00109A}
00109A: movem.l D1-7/A0,-(a1)
00109E: dbra d0,-6 {$00109A}
00109A: movem.l D1-7/A0,-(a1)
00109E: dbra d0,-6 {$00109A}

What happens here? The CPU tracing is turned off automatically. Also no log of any interrupts. The cleaning doesn't reach the loop code. The next entry is only a breakpoint:

Code: Select all

Break: Hit breakpoint at address $001694


Upd: hmm, seems no interrupt, just Steem automatically turns off CPU logging after a while?

wietze
Captain Atari
Captain Atari
Posts: 272
Joined: Fri Mar 01, 2013 10:52 pm

Re: Steem debugger

Postby wietze » Mon Sep 30, 2019 5:55 pm

When d0 becomes less than 0.

slingshot
Atari God
Atari God
Posts: 1273
Joined: Mon Aug 06, 2018 3:05 pm

Re: Steem debugger

Postby slingshot » Tue Oct 01, 2019 5:21 am

Ok, the loop exits then, but why the logging?

ijor
Hardware Guru
Hardware Guru
Posts: 3821
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Steem debugger

Postby ijor » Mon Oct 07, 2019 8:59 pm

There are some long standing issues with Steem's debugger, especially with the logging system that was changed/replaced at some pont. Unfortunately the current developer is not active at the forum for quite some time. He has his own forum, or at least a blog, I believe.
Fx Cast: Atari St cycle accurate fpga core

User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1750
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Steem debugger

Postby Cyprian » Mon Oct 07, 2019 9:17 pm

slingshot,I would suggest you report that issue on Steem SSE forum:
https://sourceforge.net/p/steemsse/forum/bugs/
Lynx II / Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 7 guests