2.5 MB RAM setting not preserved across cold reset on Steem SSE 3.9.1

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

czietz
Hardware Guru
Hardware Guru
Posts: 593
Joined: Tue May 24, 2016 6:47 pm

2.5 MB RAM setting not preserved across cold reset on Steem SSE 3.9.1

Postby czietz » Sun Apr 23, 2017 1:19 pm

Hello,

while testing EmuTOS, Vincent found what turned out to be a bug in Steem: The 2.5 MB RAM setting is not retained across the second cold reset. You can easily see this in the video I made: https://www.youtube.com/watch?v=UiWXafyFxaY
I select 2.5 MB, after the first reset it Steem correctly shows 2560 kiB, after the second it changes to 2048 kiB.

BlankVector
Captain Atari
Captain Atari
Posts: 432
Joined: Wed Oct 24, 2007 7:52 pm
Location: France
Contact:

Re: 2.5 MB RAM setting not preserved across cold reset on Steem SSE 3.9.1

Postby BlankVector » Mon Apr 24, 2017 12:38 pm

Same happens with TOS 1.62. So this is not related to the ROM.
Subscribe to my new channel Vretrocomputing on YouTube and Facebook.

User avatar
Steven Seagal
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2018
Joined: Sun Dec 04, 2005 9:12 am
Location: Undisclosed
Contact:

Re: 2.5 MB RAM setting not preserved across cold reset on Steem SSE 3.9.1

Postby Steven Seagal » Mon Apr 24, 2017 5:49 pm

Yes, it's a pure Steem SSE bug, it's fixed in the dev builds.
Thx for the report.
In the CIA we learned that ST ruled
Steem SSE: http://sourceforge.net/projects/steemsse


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 3 guests