slowing down the emulation

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

kep
Atarian
Atarian
Posts: 3
Joined: Mon Jul 07, 2014 3:46 pm

slowing down the emulation

Postby kep » Mon Jul 07, 2014 3:54 pm

Hi,
In Steem SSE, when I try to slow the emulation down in "run speed", I get sound problems. What can I do?

Dio
Captain Atari
Captain Atari
Posts: 451
Joined: Thu Feb 28, 2008 3:51 pm

Re: slowing down the emulation

Postby Dio » Tue Jul 08, 2014 8:17 am

When you change emulation speed, some sort of 'sound problem' is inevitable. What sort of sound problem are you objecting to and what would you prefer?

kep
Atarian
Atarian
Posts: 3
Joined: Mon Jul 07, 2014 3:46 pm

Re: slowing down the emulation

Postby kep » Tue Jul 08, 2014 9:05 am

The sound stutters.

User avatar
nativ
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4106
Joined: Mon Jul 30, 2007 10:26 am
Location: South West, UK

Re: slowing down the emulation

Postby nativ » Tue Jul 08, 2014 7:49 pm

Any forced system speed change will result in issues like this? the YM/DMA is related to the Hardware timing for the best part. If you slow a tape deck down the sounds will be stretched if sped up they will be compressed.
Atari STFM 512 / STe 4MB / Mega ST+DSP / Falcon 4MB 16Mhz 68882 - DVD/CDRW/ZIP/DAT - FDI / Jaguar / Lynx 1&2 / 7800 / 2600 / XE 130+SD Card // Sega Dreamcast / Mega2+CD2 // Apple G4

http://soundcloud.com/nativ ~ http://soundcloud.com/nativ-1 ~ http://soundcloud.com/knot_music
http://soundcloud.com/push-sounds ~ http://soundcloud.com/push-records


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 1 guest