Steem 3.2 and paSTi

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

mamehead
Atarian
Atarian
Posts: 6
Joined: Sat Aug 06, 2011 5:07 pm

Steem 3.2 and paSTi

Postby mamehead » Tue Aug 23, 2011 7:52 pm

Hi guys. Firstly thankyou to the guys for having coded such a comprehensive emulator that does everything you could ask for! Secondly thanks to Ijor for his paSTi emulation. This brings ST emulation much closer to how i remember my experience with the computer and for that i can't be thankful enough!

I do however have an issue that i would like some advice on. I already posted this message but i'm guessing it was inthe wrong forum.

I cannot seem to get steem engine to boot up stx images using a frontend with pasti enabled . The emu just boots into the tos without reading the image that i have just accessed. Essentially it is behaving like the ST when you boot it with no disk in the floppy drive. Having researched the forums and other sites it seems that this was an emulator bug which had been addressed after someone commented, but may have been broken again since. Could anybody shed some light on this situation and if it is indeed possible to achieve this ? Maximus arcade is the frontend I use which loads all other st images fine and i would love to see this feature working.

Any suggestions would be greatly appreciated. Also is anyone compiling builds of new revs?

thanks for any help.

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Steem 3.2 and paSTi

Postby Dal » Wed Aug 24, 2011 12:00 pm

Hi, yes I remember having problems trying to call a STX with STeem using a command line (essentially how your front end would be working).

A little fish around and I saw this message thread.

What Russ is saying is relevant to the current release of STeem (3.2) - there has so far been no official release after this. Russ does mention that he had 'fixed' this issue ready for the next release, but this never made it to the community. However, there has been a recent development this year in that Russ and Ant have now release STeem as an open source project - it's possible that the code release may actually include the 'fix' that Russ talks about - which would be slightly confusing as the source was released as v3.2 so we end up with the source and the officially available compiled version being out of kilter :?

So, you're options are:
1. Look at Russ's suggestion of modifying the ini file up front with Disk_A_Path and Disk_A_Name pointing to your STX before calling "STeem -run"
2. Checkout the current source code from the svn repository, compile it and see if it includes Russ's pasti fix - you may be surprised?
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

mamehead
Atarian
Atarian
Posts: 6
Joined: Sat Aug 06, 2011 5:07 pm

Re: Steem 3.2 and paSTi

Postby mamehead » Wed Aug 24, 2011 4:33 pm

Thank you Dal. I did stumble across this post and you are quite correct. It does work this way but the trouble is you cannot access or create multiple .inis to use with the frontend. The only option is to create multiple steem directories with independant inis. This isnt really worth it and the frontend allows you to modify the command line parameter for each stx image but this does not seem to override the Steem.ini.

I also read that this fix had been addressed and may have well found its way into the source code. The problem is i have never done any compiling so i may have to be patient and wait for a release. This is obviously great news that the code has been picked up once more!!

thanks again


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 2 guests