steem working anymore?

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

cobra
Retro freak
Retro freak
Posts: 13
Joined: Sat Sep 18, 2004 10:50 am

steem working anymore?

Postby cobra » Thu Jun 10, 2010 4:43 am

Hi guys!
I have trouble using steem with linux for a long time now ( some years ).
Is anyone being successful in running steem with any recent linux flavor?
Currently using fedora 12 and when launching steem it's stuck .

strace steem gives me :

read(3, "\25\0J\0\5\0\300\5\5\0\300\5\340\227\374\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 32) = 32
gettimeofday({1276144786, 212201}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 1 (in [3], left {0, 11358})
gettimeofday({1276144786, 221084}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [32]) = 0
read(3, "\26\0J\0\5\0\300\5\5\0\300\5\0\0\0\0\4\0\26\0\220\1\214\0\0\0\0\0\0\0\0\0", 32) = 32
gettimeofday({1276144786, 221274}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 1 (in [3], left {0, 7993})
gettimeofday({1276144786, 233526}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [32]) = 0
read(3, "\226\0J\0\5\0\300\5\5\0\300\5\0\0\0\0\274\1\346\1\220\1\214\0\0\0\0\0\0\0\0\0", 32) = 32
gettimeofday({1276144786, 233757}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 1 (in [3], left {0, 15773})
gettimeofday({1276144786, 238242}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [32]) = 0
read(3, "\23\0J\0\5\0\300\5\5\0\300\5\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 32) = 32
gettimeofday({1276144786, 238442}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 0 (Timeout)
gettimeofday({1276144786, 259485}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 0 (Timeout)
gettimeofday({1276144786, 280652}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 0 (Timeout)
gettimeofday({1276144786, 300997}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0
select(4, [3], NULL, NULL, {0, 20000}) = 0 (Timeout)
gettimeofday({1276144786, 321335}, {4294967176, 0}) = 0
ioctl(3, FIONREAD, [0]) = 0

and the timeouts keep repeating forever ...

weirdly on some rare occasions it can work a bit then it's stuck again :/

User avatar
daeghnao
Captain Atari
Captain Atari
Posts: 479
Joined: Wed Oct 27, 2004 12:41 pm
Location: York, UK
Contact:

Re: steem working anymore?

Postby daeghnao » Thu Jun 10, 2010 8:32 am

I used steem yesterday on 64-bit Ubuntu 9.10 on my Samsung Q320, no problems. Is it all running on a simple partition on the local drive, or do you have something fancier going on? What happens if you run it from something completely different (network, USB etc)?

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: steem working anymore?

Postby rocket-dog » Thu Jun 10, 2010 11:22 am

You could try running STEEM under WIne. It does work.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12774
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: steem working anymore?

Postby wongck » Thu Jun 10, 2010 11:54 am

And at a fantastic speed as well????
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Hippy Dave
Atari Super Hero
Atari Super Hero
Posts: 515
Joined: Sat Jan 10, 2009 5:40 am

Re: steem working anymore?

Postby Hippy Dave » Thu Jun 10, 2010 5:43 pm

wongck wrote:And at a fantastic speed as well????

Probably Yes.
I have never had a problem with speed while using WINE on Linux. As a matter of fact, MDK2 (Max Doctor Kurt video game) has almost twice the frame rate with CentOS as compared to Win98 on the same computer.

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: steem working anymore?

Postby rocket-dog » Thu Jun 10, 2010 9:33 pm

wongck wrote:And at a fantastic speed as well????


Well I run WIn XP on VMware on CrunchBang on a 6 year old AMD box whose benchmarks suggests its performance is slightly better than an Atom. And XP runs quicker than it did when it was the AMD box's sole OS. Now I thought it was my imagination until I floated the idea over at a certain Linux forum and others had similar experiences with various flavours of Windoze. Go figure. The only theory we can offer is that VM is how we shall say perfectly tuned for Windows and Linux is just more efficient than WIndows. And I have found Wine behaves similarly with what bits of XP software I have. One failure I had with Wine was a collection of Atari games; that upset me greatly......

cobra
Retro freak
Retro freak
Posts: 13
Joined: Sat Sep 18, 2004 10:50 am

Re: steem working anymore?

Postby cobra » Thu Jun 10, 2010 11:13 pm

daeghnao> no nothing fancy!

yeah i can run steem in windows with virtualbox or with wine no problem, was wondering why on earth it was not working with fedora for years now :/

will try with another recent linux distro just to see later

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12774
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: steem working anymore?

Postby wongck » Fri Jun 11, 2010 11:20 am

rocket-dog wrote: and Linux is just more efficient than WIndows.


Nothing new about this statement.... was like that for several years ago and still is....
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: steem working anymore?

Postby rocket-dog » Fri Jun 11, 2010 2:54 pm

cobra wrote:daeghnao> no nothing fancy!

yeah i can run steem in windows with virtualbox or with wine no problem, was wondering why on earth it was not working with fedora for years now :/

will try with another recent linux distro just to see later


>cough< Linux Mint.......

........he says posting from a fresh Xubuntu install. :mrgreen:


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 5 guests