Mouse pointer on full screen.

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Mouse pointer on full screen.

Postby rocket-dog » Mon Jan 26, 2009 3:00 pm

Hello all!

If I use XSteem in its full window mode there is an image of the Ubuntu mouse pointer on the screen. This happens on both low and high res.

I removed XSteem and pulled down a fresh copy and it is still there.

I can live with it.

This is one of those "is it like this for everyone because I have no one else to ask?" threads.

Steem is a lot more pleasant on Ubuntu than on XP; it seems sharper. I can save file in FirstWord Plus and open it up in OpenOffice (as long as obviously there is no formatting). In fact FirstWordPlus I would go as far to say is a super text entry programming for a net book; nice black thick font on a steady white screen.

ppera

Re: Mouse pointer on full screen.

Postby ppera » Mon Jan 26, 2009 4:51 pm

I don't see 'image there' :D
For me XSteem worked fine on Mandrive in fullscreen mode. But surely much depends from used drivers, which are sometimes problematic in Linux.

I don't think that Steem is sharper in Linux than Windows. Of course, if you use scaling (window size setting) with mouse in Win, then will get unsharp pic. Use always screen sizes from settings - 2x, 3x, 4x. So will have very sharp pic.

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: Mouse pointer on full screen.

Postby rocket-dog » Mon Jan 26, 2009 6:50 pm

ppera wrote:I don't see 'image there' :D
For me XSteem worked fine on Mandrive in fullscreen mode. But surely much depends from used drivers, which are sometimes problematic in Linux.



I can live with it. I just wondered. I think STEEM is super. It really is super.

At least I have had one win this afternoon in that I have got a copy of Atari Logo in English.

User avatar
daeghnao
Captain Atari
Captain Atari
Posts: 479
Joined: Wed Oct 27, 2004 12:41 pm
Location: York, UK
Contact:

Re: Mouse pointer on full screen.

Postby daeghnao » Mon Jan 26, 2009 8:37 pm

I had the fullscreen/extra mouse pointer issue for a while when I was fiddling around with which Intel graphics drivers I was using on my laptop. One set did everything right, the other set got it all wrong. So I used the ones that got it right. You might be able to try some different drivers to see if that helps?

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: Mouse pointer on full screen.

Postby rocket-dog » Mon Jan 26, 2009 9:47 pm

Thanks!

The Samsung run Intel 950 graphics. It isn't a big problem. I will look at drivers. Samsung seem pretty hot on on keeping drivers up to date. As I said in the OP it was more a question of asking if this was normal.

STEEM is really nice on Linux.

At least now I have managed to switch off the keyboard bell thanks to another member's post.

User avatar
daeghnao
Captain Atari
Captain Atari
Posts: 479
Joined: Wed Oct 27, 2004 12:41 pm
Location: York, UK
Contact:

Re: Mouse pointer on full screen.

Postby daeghnao » Tue Jan 27, 2009 10:40 am

Some more info: I believe I found the older package xserver-xorg-video-i810 worked and the newer xserver-xorg-video-intel was giving me trouble. But the older driver might not work so well on an i950. It's advertised as working on i915 and i945 though. Good luck!

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: Mouse pointer on full screen.

Postby rocket-dog » Tue Jan 27, 2009 2:18 pm

Thanks! \i am headed into xorg territory tonight because of an external monitor issue.

User avatar
Desty
Atari God
Atari God
Posts: 1964
Joined: Thu Apr 01, 2004 2:36 pm
Location: 53 21N 6 18W
Contact:

Re: Mouse pointer on full screen.

Postby Desty » Tue Jan 27, 2009 6:11 pm

Do you have direct rendering working (i.e. reported by glxinfo)? xorg.conf and getting the drivers working can be a real pain. I struggled for a while with an i810 board as well - added an old ATi Rage GX (or something) PCI card, spent a few hours configuring it, and it turned out to be even slower than the integrated i810. Sob.
tá'n poc ar buile!

User avatar
rocket-dog
Atari Super Hero
Atari Super Hero
Posts: 779
Joined: Wed Mar 05, 2008 3:13 pm
Location: Great Britain - The Kingdom of Mercia

Re: Mouse pointer on full screen.

Postby rocket-dog » Tue Jan 27, 2009 6:58 pm

Gosh! I don't know about that. I am still playing a bit softly softly around this stuff. I don't know what I have got switched on or off in any of the config files.

What I can tell you is though I have just flashed the NC10's BIOS (for the second time in three months!) and autofolders in STEEM now produce an odd effect. Once a disk folder is open the mouse pointer flits between pointer(arrow) and the busy bee. I have got rid of the autofolder and everything is back to normal.


PS: On IBM Aix and Solaris servers there wasn't any of this modern super duper graphics stuff. (OK Solaris did a bit but we didn't need to play with that to get a payroll running.)


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 2 guests