GameBaseST archive download problems

Come and chat to the team working on the huge Atari ST emulator frontend projects

Moderators: Goldrunner, SkylineDave, Moderator Team

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

GameBaseST archive download problems

Postby unseenmenace » Sun Jan 15, 2006 9:56 pm

How many of you have had trouble downloading the multi-part zip of the archive from my website? It seems that somehow the .zip and .z02 files have got corrupted and they won't download properly. I have PM'd Silver Surfer who uploaded the multi-part zip for me in the first place but if he doen't have it any more then I'll re-zip and re-upload the whole thing from the working files on my hard drive. One way or another I'll get it sorted.
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Mon Jan 16, 2006 9:00 pm

Hi Unseen

Part 0 and Part 1 are downloading with exactly the same file name, which is GBST v1.2b Archive. zip. This means Part 0 is overwritten if the user saves to the same location for each file (which is probably everyone) making the archive useless. Part 1 should be downloaded as GBST v1.2b Archive. z01.

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Mon Jan 16, 2006 10:08 pm

Someone else reported this behaviour a while back but I have been unable to reproduce it. Have you tried refreshing the page in case its using an old one from the cache? I know some people had managed to download the multi-part archive from my site before. The problem I'm encountering now is simply that the part 0 (.zip) and part 2 (.z02) get approx half way through downloading and then get a file error. Part 1 (.z01) downloads perfectly ok for me and with the correct filename.

EDIT:-

Just tried downloading part 0 again and it worked fine. Which is odd since I haven't changed anything. I'll try parts 1 and 2 as well and let you kknow what happens.
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Mon Jan 16, 2006 10:15 pm

Refreshed it but the same happens :!: Oddly when you run the mouse pointer over Part 1 it correctly says GBST v1.2b Archive. z01 in the bottom status bar of IE, but when you try and download Part 1 it's back to GBST v1.2b Archive. zip

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Mon Jan 16, 2006 10:56 pm

Have you tried a different browser? I have successfully downloaded parts 0 to 6 so far this evening (using Firefox) and fingers crossed it'll extract correctly. I still don't get how come you can't get part 1. I'll keep you posted.
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Tue Jan 17, 2006 11:17 am

OK, I managed to download the whole archive and then tried to extract it and got an error. Then I looked at the parts and noticed one (.z09) was only 9MB instead of 48MB. I redownloaded it and this time I got all 48000KB. This time it extracted perfectly giving a single 1.1GB zip file which I then successfully tested in Winzip. I can only assume this is down to problems with my hosting causing downloads to stop prematurely. Make sure all parts of the multi-part zip are exactly 48000KB apart from part 0 (.zip) which should be 46492KB. As for the problem you've been having getting sent the wrong file for part 1, I still can't replicate this and I've got no idea whats going on :?
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Thu Jan 19, 2006 11:24 am

Hi Unseen

This is incredably strange, I have just tried downloading Part 1 from work and got the same GBST v1.2b Archive. zip instead of GBST v1.2b Archive. z01. I suspect that this may be down to Internet Explorer which are the latest versions of both my home and work computers. I am also running XP Pro on both machines, will try a different browser sometime tonight to see if it still happens!

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Thu Jan 19, 2006 4:03 pm

Solved it. Not my fault thank f&^%. Read the following link for an explanation of an annoying "feature" (read BUG!!!!) of Internet Explorer:-

http://www.ericsson.com/mobilityworld/sub/open/technologies/parlay/docs/parlay_cd

Rename the file with the extension .z01 and then re-download the first part (.zip) and it should all work fine :)
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Thu Jan 19, 2006 4:14 pm

Begining to think I'd lost the plot somewhere, don't you just love Microsoft :roll: Maybe it would be a good idea to add a note about this on your site :!:

User avatar
Mug UK
Administrator
Administrator
Posts: 11254
Joined: Thu Apr 29, 2004 7:16 pm
Location: Stockport (UK)
Contact:

Postby Mug UK » Thu Jan 19, 2006 4:16 pm

Or distribute it on DVD .. much easier :)
My main site: http://www.mug-uk.co.uk - slowly digging up the bits from my past (and re-working a few): Atari ST, Sega 8-bit (game hacks) and NDS (Music ripping guide).

I develop a free Word (for Windows) add-in that's available for Word 2007 upwards. It's a fix-it toolbox that will allow power Word users to fix document errors. You can find it at: http://www.mikestoolbox.co.uk

User avatar
nobogod
Captain Atari
Captain Atari
Posts: 194
Joined: Wed Aug 04, 2004 12:58 pm
Location: Athens, Greece
Contact:

...

Postby nobogod » Thu Jan 19, 2006 6:23 pm

I just can't believe that some people still use ie.
But, please, don't take it personally :)

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Thu Jan 19, 2006 7:50 pm

Me, take it personally :cry:

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Fri Jan 20, 2006 1:31 am

Goldrunner wrote:Maybe it would be a good idea to add a note about this on your site :!:

Done
http://www.unseenmenace.net/gamebasest
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
Goldrunner
Guardian of the PaST
Guardian of the PaST
Posts: 1578
Joined: Thu Mar 04, 2004 9:38 pm
Location: Formby, England, UK

Postby Goldrunner » Fri Jan 20, 2006 11:16 am

That should clear everything up for the poor people who still use IE, I may finally change my browser this coming weekend once and for all. BTW, well done tracking down the problem it could not have been easy!

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Fri Jan 20, 2006 12:49 pm

Actually it wasn't hard to figure out what it was doing as every file is exactly 48000KB apart from part 0 (.zip), so when I tried to download part 1 (.z01) it seemed to save part 0 but I noticed it was exactly 48000KB instead of 46492KB so I figured it must just be naming it wrong. A file comparison with the original part 1 (.z01) confirmed that they were the same file so I did a bit of googling and found out about this wonderful "feature". 8O
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
keili
Atari God
Atari God
Posts: 1287
Joined: Sun Mar 07, 2004 7:29 pm
Location: Germany, near Leer
Contact:

Postby keili » Fri Jan 20, 2006 1:24 pm

The right name was displayed, if you've moved the mouse over the link.
.zip appears after selecting 'Save as...'. I had no idea why, so i didn't post a comment. And i already have the complete archive, no download needed here.
TI 99/4A, C64, 800XL, 260ST, 520ST, 520ST+, 1040ST, 1040 STE, Mega ST1, Mega ST2, Mega STe, Apple IIsi


Social Media

     

Return to “GameBaseST & DemoBaseST”

Who is online

Users browsing this forum: No registered users and 2 guests