Longstanding dns fault resolved

News, updates, like or dislike

Moderators: Mug UK, Silver Surfer, Moderator Team

Dal
Administrator
Administrator
Posts: 4065
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Longstanding dns fault resolved

Postby Dal » Fri Feb 06, 2015 5:23 pm

Somebody (I thought it was WongCK) posted somewhere that whenever attempting to access the forum using one of the alias DNS names (Jackintosh-forum.com / ourtai-forum.com / fuji-forum.com) the site would always redirect to http://www.atari-forum.com. This can cause an issue if, for example, a company proxy server blocks atari-forum.com but allows access via an alias (Not the kind of behaviour I would personally condone of course - circumventing company proxies is often frowned upon in a big way!).

While working on the test site, I stumbled across the cause of this behaviour while debugging a similar issue. It was down to a nasty hack in one of the PHP files (probably my fault) that always hard coded the URL back to http://www.atari-forum.com. I can only guess I meant to do this as a temporary thing for some reason but lord only knows why I chose such a hideous approach to a forced redirect... :oops: :oops: :oops: :oops:

This has been removed and now DNS aliases are working properly.

Sorry it took a while, I honestly can't remember how (or even why) this code got in, but it's fixed now! :oops: :oops:
TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11916
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Longstanding dns fault resolved

Postby wongck » Sat Feb 07, 2015 4:00 am

Ha ha... yeah that was me. :wink:
Dal wrote: This can cause an issue if, for example, a company proxy server blocks atari-forum.com but allows access via an alias (Not the kind of behaviour I would personally condone of course - circumventing company proxies is often frowned upon in a big way!).

Content blocking ought to be the way to go for. Domain name blocking is not efficient at all.
My guess is that forums are actually Ok for the company i worked for as atariage and atari-home.de seems to have no issues for accessing.

Thanks Dal for fixing it. :mrgreen:
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list


Social Media

     

Return to “Website Discussions”

Who is online

Users browsing this forum: No registered users and 1 guest