Atari TT Black screen

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, [ProToS], lp, moondog/.tSCc., Moderator Team

User avatar
ST Graveyard
Obsessed with homicide
Obsessed with homicide
Posts: 2102
Joined: Fri Apr 26, 2002 11:53 pm
Location: Belgium
Contact:

Atari TT Black screen

Postby ST Graveyard » Sat May 05, 2018 12:22 pm

Hello all,

I have recently acquired an ATARI TT which I would like to restore to its former glory. The machine isn't working anymore, so I think. I have opened it up and this is what happens :

https://www.dropbox.com/s/8q722zs95xgbe ... 1.mp4?dl=0

I've been reading this forum and any bits of info I can find (not much) and I'm posting on the facebook group, but I haven't been able to get anything from the TT. I removed all peripherals, completely stripped the machine, took of the 2 meg ST ram board, put it back. I opened up the powersupply, looking for bulging caps (all look fine), pressed al the chips really good (the tos chips did make some cracking noises), removed the middel part and pressed the chips underneath the shield. Nothing.

Some things I like to point out :
- When the diskdrive is connected, the light stays on (green light) but there is no spinning. It seems the system is not looking for any startup disc or anything.
- I read it could be a broken reset switch, but as you can see in the movie, the monitor says 'signal not in range, check video cable' so there doesn't seem to be a video signal (This monitor works on my pc). I also tested on another monitor, nothing. Both monitors are SVGA PC monitors.
- my monitor cable has 3 rows of pins, and some missing pins (both monitors have this, I think it is standard, but is this a problem for the TT)

Worst case scenario (and this will probably be it), I'm not able to fix this machine. Are there any people who I can sent it to to have it checked?

Any suggestions what I can do next. The machine sounds ok, but nothing happens. Could it be the monitors don't work on the TT? (Guess not).

Thanks,
Maarten
Atari Legend IS back!

www.atarilegend.com

User avatar
ST Graveyard
Obsessed with homicide
Obsessed with homicide
Posts: 2102
Joined: Fri Apr 26, 2002 11:53 pm
Location: Belgium
Contact:

Re: Atari TT Black screen

Postby ST Graveyard » Sat May 05, 2018 12:25 pm

Atari Legend IS back!

www.atarilegend.com

czietz
Hardware Guru
Hardware Guru
Posts: 764
Joined: Tue May 24, 2016 6:47 pm

Re: Atari TT Black screen

Postby czietz » Sat May 05, 2018 2:21 pm

Troubleshooting as explained in the Service Manual:
https://archive.org/stream/Atari_TT030_ ... 5/mode/2up

Which steps you can perform of course depends on the equipment you have available. Multimeter? Oscilloscope? Diagnostic cartridge?

User avatar
ST Graveyard
Obsessed with homicide
Obsessed with homicide
Posts: 2102
Joined: Fri Apr 26, 2002 11:53 pm
Location: Belgium
Contact:

Re: Atari TT Black screen

Postby ST Graveyard » Sat May 05, 2018 8:58 pm

I sadly don't have any of these things.
I got a suggestion somewhere else saying the there is the possibility that the NVRAM is set to TTHIGH on boot. Because my monitor is saying 'Signal not in range - check cable' and not 'No signal'. I could test this with an ECL to VGA adapter...
Atari Legend IS back!

www.atarilegend.com

User avatar
qq1975b
Atari God
Atari God
Posts: 1076
Joined: Tue May 15, 2012 9:15 am
Location: Barcelona

Re: Atari TT Black screen

Postby qq1975b » Tue May 08, 2018 8:47 am

ST Graveyard wrote:I sadly don't have any of these things.
I got a suggestion somewhere else saying the there is the possibility that the NVRAM is set to TTHIGH on boot. Because my monitor is saying 'Signal not in range - check cable' and not 'No signal'. I could test this with an ECL to VGA adapter...


Maybe you can reset the nvram with a program. This is for the Falcon but maybe it works on the TT too:

Atari-Reset-NVRAM-RESETNVR.PRG.zip
You do not have the required permissions to view the files attached to this post.
Trying to learn...

User avatar
Bama
Captain Atari
Captain Atari
Posts: 196
Joined: Sat Feb 28, 2015 1:25 pm

Re: Atari TT Black screen

Postby Bama » Wed May 09, 2018 3:04 am

See page 62 from the Service Manual.

E984B78D-2CEF-4A74-99A9-8CC7C76EF141.png
You do not have the required permissions to view the files attached to this post.
:-)
BAMA

damanloox
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 101
Joined: Fri Jan 19, 2018 8:45 am

Re: Atari TT Black screen

Postby damanloox » Wed May 09, 2018 7:16 am

I'd remove/disconnect all non-essential stuff (ram board, disk drive, floppy etc), reset nvram (ctrl-alt-left shift-undo as far as I remember) and see what happens. Check/re-seat TOS chips. Check voltages (with some dummy load power resistors or do it with PSU connected to the TT but be careful not to short anything). That's the basics...


Social Media

     

Return to “Professionals”

Who is online

Users browsing this forum: No registered users and 3 guests