Eclipse PCI - fVDI v.959beta issues

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

User avatar
FujiMan
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 115
Joined: Wed May 03, 2006 3:34 pm
Location: Elburn, IL 60119 USA
Contact:

Eclipse PCI - fVDI v.959beta issues

Postby FujiMan » Mon Apr 08, 2013 2:40 pm

Hi,

Many years ago (2000? maybe), I bought a Eclipse PCI with fVDI software and just getting around to try it out again.

I was able to get it to work somewhat (desktop through the Eclipse PCI + Rage IIc 4mb + fVDI beta software), but locks up after launching some programs or trying to read a text file using desktop(it tries and fails to render properly on the Falcon's built in VGA port).

Is there a later version of the fVDI? I have found Rajah Lone's webpage and tried his setup, but no difference.
Is there other software that I can use (with/instead) of fVDI?

I'll try and post my fVDI.sys in a little while.

User avatar
[ProToS]
Moderator
Moderator
Posts: 2242
Joined: Fri Sep 20, 2002 2:09 am
Location: Lourdes / France
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby [ProToS] » Mon Apr 08, 2013 4:21 pm

www.klockars.net seems down

source code was on sourceforge if you want to compile it yourself
http://sourceforge.net/projects/fvdi/
SeeU
[ProToS]/Facebook

User avatar
Rajah Lone
Captain Atari
Captain Atari
Posts: 369
Joined: Wed Aug 07, 2002 12:27 pm
Location: Lyon / France
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby Rajah Lone » Mon Apr 08, 2013 5:26 pm

My fVDI configuration with Eclipse and ATI RageIIc worked very well (now my Falcon is discarded for the best).

But one have to be very cautious about what program is used on this system : pure and very clean GEM programs.
An application will crash or behave very badly if it access directly in video RAM, if Line-A is used (forbidden !), if the code is crappy, etc.

You have to select clean programs.

rpineau
Captain Atari
Captain Atari
Posts: 493
Joined: Wed Jun 29, 2011 6:39 am
Location: California / USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby rpineau » Tue May 21, 2013 7:21 pm

I have a version of fvdi v0.968beta4 that works with my Eclipse.
I also checked out the sourceforge repo and after adding some of the FT2 2.2.1 sources and headers I was abale to recompile the engine and some of the drivers. I haven't tested that version yet.
If you need any of these contact me.
Rodolphe

Edit : I tested my newly compiled version of fvdi on Aranym and it's a v0.968beta3 ... so the sourceforge tree is not up to date and a newer version exists somewhere.
Falcon + AB040 + Eclipse PCI + ATI Rage VGA card + NE2000 Ethernec + HxC Floppy Emulator
MegaSTE 4MB + CosmosEx / 1040 STF for hardware dev
http://www.rti-zone.org/atari.php

User avatar
[ProToS]
Moderator
Moderator
Posts: 2242
Joined: Fri Sep 20, 2002 2:09 am
Location: Lourdes / France
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby [ProToS] » Wed May 22, 2013 5:15 pm

SeeU
[ProToS]/Facebook

rpineau
Captain Atari
Captain Atari
Posts: 493
Joined: Wed Jun 29, 2011 6:39 am
Location: California / USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby rpineau » Wed May 22, 2013 5:59 pm

I know it's back but the version on his website are even older (0.95x) and the cvs from hi side doesn't work so for now the only source that work are the one on sourceforge. I'll be more than happy to have access to the lastest sources and recompile them.... but so far no chance.
Regards, Rodolphe
Falcon + AB040 + Eclipse PCI + ATI Rage VGA card + NE2000 Ethernec + HxC Floppy Emulator
MegaSTE 4MB + CosmosEx / 1040 STF for hardware dev
http://www.rti-zone.org/atari.php

rpineau
Captain Atari
Captain Atari
Posts: 493
Joined: Wed Jun 29, 2011 6:39 am
Location: California / USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby rpineau » Wed May 22, 2013 6:04 pm

I emailed Johan so we'll see if I get an answer.
Regards, Rodolphe
Falcon + AB040 + Eclipse PCI + ATI Rage VGA card + NE2000 Ethernec + HxC Floppy Emulator
MegaSTE 4MB + CosmosEx / 1040 STF for hardware dev
http://www.rti-zone.org/atari.php

jklockars
Atarian
Atarian
Posts: 1
Joined: Wed May 22, 2013 9:58 pm

Re: Eclipse PCI - fVDI v.959beta issues

Postby jklockars » Wed May 22, 2013 10:28 pm

I'm still around. Just a bit behind on my "home programming". ;-)

Anyway, I'll look into what might have happened with the 0.968beta4 sources. If I built it on one of my Atari machines, there would have been no network connection, and I might have forgotten to check in any changes. It might also be on my old server.
Or perhaps someone else built it?

My svn/cvs server is up and running, I just haven't gotten my new router configured properly yet. But at least the web site is accessible from the outside again, after I don't know how many weeks of being local-only (ISP trouble).

/Johan

User avatar
FujiMan
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 115
Joined: Wed May 03, 2006 3:34 pm
Location: Elburn, IL 60119 USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby FujiMan » Thu May 23, 2013 2:33 pm

rpineau wrote:I know it's back but the version on his website are even older (0.95x) and the cvs from hi side doesn't work so for now the only source that work are the one on sourceforge. I'll be more than happy to have access to the lastest sources and recompile them.... but so far no chance.
Regards, Rodolphe


That would be great. I would really like to use the Eclipse card and see what programs work well with it.

FujiMan

rpineau
Captain Atari
Captain Atari
Posts: 493
Joined: Wed Jun 29, 2011 6:39 am
Location: California / USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby rpineau » Thu May 23, 2013 4:59 pm

I talked to Johan Klockars yesterday and he thinks the sourceForge sources are the latest. He said he'll try to stop by and help us here. He's going to try to see what is the version of the sources he has and see if he can revive his cvs repo.
Regards, Rodolphe
Falcon + AB040 + Eclipse PCI + ATI Rage VGA card + NE2000 Ethernec + HxC Floppy Emulator
MegaSTE 4MB + CosmosEx / 1040 STF for hardware dev
http://www.rti-zone.org/atari.php

User avatar
Cyprian
Atari God
Atari God
Posts: 1368
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: Eclipse PCI - fVDI v.959beta issues

Postby Cyprian » Thu May 23, 2013 5:29 pm

rpineau wrote:I talked to Johan Klockars
He is here, look two posts above - jklockars
:)
Last edited by Cyprian on Thu May 23, 2013 6:23 pm, edited 1 time in total.
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Aranym / Steem / Saint
http://260ste.appspot.com/

rpineau
Captain Atari
Captain Atari
Posts: 493
Joined: Wed Jun 29, 2011 6:39 am
Location: California / USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby rpineau » Thu May 23, 2013 6:17 pm

oops .. I guess I need more coffee this morning :)

Johan : from the beta3 source I had to add a lot of the FT2 2.2.1 files back into the fVDI modules/ft2 directory (I can send you a diff of my local repo)... may be this is fixed in beta4. Also .. as a side note.. would you happen to have the source of the pci_bios.prg used for the Eclipse ?

Regards, Rodolphe
Falcon + AB040 + Eclipse PCI + ATI Rage VGA card + NE2000 Ethernec + HxC Floppy Emulator
MegaSTE 4MB + CosmosEx / 1040 STF for hardware dev
http://www.rti-zone.org/atari.php

joska
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 3431
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby joska » Mon Sep 12, 2016 9:56 am

[ProToS] wrote:http://www.klockars.net/fvdi.html is back online


Old thread, I know... Johan's site is down again, does anybody know how/where to reach him? I'm trying to locate the sources for the fVDI RageII driver.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
Rajah Lone
Captain Atari
Captain Atari
Posts: 369
Joined: Wed Aug 07, 2002 12:27 pm
Location: Lyon / France
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby Rajah Lone » Mon Sep 12, 2016 10:43 am

There were sources for fVDI itself, but not for the rage.sys driver, to respect the non-disclosure agreement. The sys file contains some ATI (x86 ?) code for the boot of the graphic card.

http://ptonthat.fr/files/ -> fvdipack.zip (executables only, lastest files I had installed on my Falcon configuration)

joska
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 3431
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby joska » Mon Sep 12, 2016 11:54 am

Rajah Lone wrote:There were sources for fVDI itself, but not for the rage.sys driver, to respect the non-disclosure agreement.


Yes, that's why I need to get hold of Johan :)
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

TXG/MNX
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 109
Joined: Fri Oct 24, 2003 10:05 am

Re: Eclipse PCI - fVDI v.959beta issues

Postby TXG/MNX » Wed Oct 12, 2016 12:40 pm

I got an Eclipse with an ATI Rage IIc card.
When I install the original drivers from the original disk it works only in 640x480x8 640x480x16 or 640x480x32

Other resolutions don't show a decent screen or double desktop and the system does crash after a minute.
In the 640x480 mode its stable, does not crash.

I did try the latest drivers from this thread only none of those seems to work, revert to original drivers and it works but only 640x480

Any help would be nice.

joska
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 3431
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby joska » Sat Oct 22, 2016 9:25 am

I'll zip up my working fVDI-setup from my Afterburner/Eclipse tonight. PM me your email-address.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
FujiMan
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 115
Joined: Wed May 03, 2006 3:34 pm
Location: Elburn, IL 60119 USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby FujiMan » Wed Jan 18, 2017 9:32 pm


joska
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 3431
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby joska » Thu Jan 19, 2017 8:12 pm

FujiMan wrote:rory.a.mcmahon@gmail.com


Do you have an Afterburner or stock Falcon? It looks like I only have 040-binaries.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

mikro
Atari God
Atari God
Posts: 1063
Joined: Sat Sep 10, 2005 11:11 am
Location: Brisbane, Queensland, Australia
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby mikro » Thu Jan 19, 2017 11:32 pm

joska wrote:
Rajah Lone wrote:There were sources for fVDI itself, but not for the rage.sys driver, to respect the non-disclosure agreement.


Yes, that's why I need to get hold of Johan :)

You can reach him at johan.klockars@gmail.com.

However, I discussed this matter (rage.sys) with him already and he said that he can actually imagine sharing it with someone else, he even did it at few occasions. So drop him a mail. :)

User avatar
FujiMan
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 115
Joined: Wed May 03, 2006 3:34 pm
Location: Elburn, IL 60119 USA
Contact:

Re: Eclipse PCI - fVDI v.959beta issues

Postby FujiMan » Thu Jan 19, 2017 11:42 pm

I have a stock and a 060 falcon.


Social Media

     

Return to “Professionals”

Who is online

Users browsing this forum: No registered users and 5 guests