Page 1 of 1

"We Were @" music

Posted: Fri May 12, 2017 8:37 pm
by leonard
Hi everyone!

"We Were @" music is made of several sample loops, chained in real time depending of loading time, effect sync etc. Anyway I did a standalone version very close to the demo. It's made from the original loops from Clawz so it's 44Khz, 16bits stereo ( Atari version is downsampled to 8bits, 12Khz )

Original full quality (16bits, 44Khz)
http://leonard.oxg.free.fr/download/WeWere.flac


And for real atari fans, I did an YM version too! (8bits, 12Khz)
http://leonard.oxg.free.fr/download/WeWere.ym

Enjoy!

If you don't know the demo, you can download or see it here : http://www.pouet.net/prod.php?which=66702

Re: "We Were @" music

Posted: Fri May 12, 2017 8:42 pm
by dhedberg
Cool! Thanks Leonard! I really enjoyed watching the demo at STNICCC!

Re: "We Were @" music

Posted: Fri May 12, 2017 9:26 pm
by Cyprian
great Leonard!

Re: "We Were @" music

Posted: Fri May 12, 2017 11:19 pm
by BenOVR
Hi Leonard

Would be great to have an sndh too.

Do you have a native player for .ym ?

Re: "We Were @" music

Posted: Sat May 13, 2017 9:54 am
by Cyprian
leonard wrote:Hi everyone!

And for real atari fans, I did an YM version too! (8bits, 12Khz)
http://leonard.oxg.free.fr/download/WeWere.ym


unfortunately ST-Sound doesn't play it

Re: "We Were @" music

Posted: Sat May 13, 2017 4:09 pm
by leonard
Cyprian wrote:unfortunately ST-Sound doesn't play it


Oh god you're right! I tested the YM file with my XMPlay STSound plugin only!

After investigation, StSound95 has a bug when dealing with signed "MIX1" music type! Instead of fixing StSound95 bug, I changed the YM file to unsigned sample data, so it's now compatible with the good old StSound95 player :)

Just download an updated version of WeWere.ym on my website and it will work with StSound95!

Re: "We Were @" music

Posted: Sat May 13, 2017 4:12 pm
by leonard
BenOVR wrote:Do you have a native player for .ym ?


Hi Ben! comment va?

No there is no native YM player on ATARI :( It reminds I started to code one long time ago but never finished. Maybe I can look at my code archive.

Re: "We Were @" music

Posted: Wed May 17, 2017 4:02 pm
by BenOVR
Ça va !

Zappy just asked the same question on facebook. It would be mice if you could find that in your archives. I thought of doing one a few time. I always stop at the lha part. I thought I had a lha depacker in asm written by M-coder but I lost it (or I'm remembering wrong).