Issues with Bigdos and Ide interface

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

talrek
Atari User
Atari User
Posts: 40
Joined: Mon Apr 06, 2015 8:13 am

Issues with Bigdos and Ide interface

Postby talrek » Thu May 02, 2019 6:50 pm

Hi,
I encounter a problem I don’t understand. I hope i’ll find someone to help me.

I have a 1040STE with 4GB and tos 2.06 and an ide interface (ppera schematics).
I formatted my CF on my PC with 1GB partitions.
I installed everything on it Imcluding the driver autoboot.

When I use a disk with the ide driver ided7 and Bigdos in autofolder everything works well. Partitions are available on tos2.06

When I boot with driver on partition C and with Bigdos in autofolder. The STE crashes with 3 bombs just after selecting drive C after driver download.

Strange thing : if I remove Bigdos from auto, the ste doesn’t crash anymore...


Last thing.
If I try this on a 1040 stf with ide interface and tos 2.06 it works with autoboot...


Thank you for your help !

czietz
Hardware Guru
Hardware Guru
Posts: 987
Joined: Tue May 24, 2016 6:47 pm

Re: Issues with Bigdos and Ide interface

Postby czietz » Thu May 02, 2019 7:09 pm

When you want to load BIGDOS from C:, you must make C: accessible without BIGDOS. Re-partition your CF card so that the first partition does not need BIGDOS.

talrek
Atari User
Atari User
Posts: 40
Joined: Mon Apr 06, 2015 8:13 am

Re: Issues with Bigdos and Ide interface

Postby talrek » Thu May 02, 2019 9:11 pm

Ok, But my first partition is 300MB. Does it need to be under ?

And in this case why does it works on a 1040STF and not STE ? (I tried on two STEs).

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1956
Joined: Sun Jul 31, 2011 1:11 pm

Re: Issues with Bigdos and Ide interface

Postby Eero Tamminen » Thu May 02, 2019 10:00 pm

TOS v4 supports up to 1GB partitions, TOS >=1.06 up to 512MB partitions, and earlier TOS versions up to 256MB partitions. I think EmuTOS supports larger partitions.

Did you make sure that PC didn't add any VFAT stuff to the formatted partitions? Older TOS versions don't like that.

czietz
Hardware Guru
Hardware Guru
Posts: 987
Joined: Tue May 24, 2016 6:47 pm

Re: Issues with Bigdos and Ide interface

Postby czietz » Fri May 03, 2019 5:56 am

It's not only the partition size that is limited. The FAT code in TOS also has other restrictions. For example, it only supports FAT file systems with exactly 2 clusters per (logical) sector. You can find the limitations summarized here: http://joo.kie.sk/wp-content/uploads/20 ... _Guide.pdf, section "9.3.2Big Partition (BGM) Limits". These limits are lifted by BigDOS, but your C: partition must adhere to them. You'll need a program such as mkfs.msdos (which allows you to specify number of clusters, logical sector size, etc.) to create such a file system on a PC.

talrek
Atari User
Atari User
Posts: 40
Joined: Mon Apr 06, 2015 8:13 am

Re: Issues with Bigdos and Ide interface

Postby talrek » Fri May 03, 2019 9:50 am

Thank you for your answers both of you.
I'll try it this Week-end.


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 3 guests