DIY Monitor cable problems

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

distantminds
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 104
Joined: Thu Sep 29, 2005 5:03 pm

DIY Monitor cable problems

Postby distantminds » Sun Oct 07, 2018 7:33 pm

Hello one and all :)

I finally got round to trying to make a cable to connect my STE to my Sony PVM monitor. After a bit of googling I saw that people had had good results by presenting RGB and composite sync. I made my cable which was pretty fiddly, but I think it's ok with no shorts..

however..

The STE won't even boot with the lead plugged in - black screen only, and the disk drive doesn't even spin up :lol:

Can anyone offer clues as to what i'm missing? Perhaps I need to take some other pins to ground on the ST end?

I wired:

7 - Red
6 - Green
10 - Blue
2 - Sync
13 - Ground

many thanks!

Damo

User avatar
xc8
Captain Atari
Captain Atari
Posts: 213
Joined: Mon Aug 11, 2008 5:23 pm
Location: B'ham, UK

Re: DIY Monitor cable problems

Postby xc8 » Sun Oct 07, 2018 8:05 pm

IIRC there is a 12v pin there (at least on the ST video output), surely no shortcuts?

distantminds
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 104
Joined: Thu Sep 29, 2005 5:03 pm

Re: DIY Monitor cable problems

Postby distantminds » Sun Oct 07, 2018 8:16 pm

hmm yes I see that pin now on some Scart schematics...

tomorrow i'll bell out each pin to be sure but I think you're probably on to something - i'm probably missing something essential!

thanks,
D

User avatar
xc8
Captain Atari
Captain Atari
Posts: 213
Joined: Mon Aug 11, 2008 5:23 pm
Location: B'ham, UK

Re: DIY Monitor cable problems

Postby xc8 » Sun Oct 07, 2018 10:30 pm

make 100% sure you don't have any shortcuts , esp between the 12v and other pins, I bet there are polyfuses around the video circuit but as they say....better safe that sorry.

siriushardware
Captain Atari
Captain Atari
Posts: 403
Joined: Thu Aug 21, 2014 7:55 pm
Location: UK

Re: DIY Monitor cable problems

Postby siriushardware » Sun Oct 07, 2018 11:05 pm

And another thing which comes up from time to time, make sure you have not accidentally plugged the 13-way monitor plug into the ST monitor socket upside down. It is easier to do than you might think, and goes in the wrong way up with very little difficulty.

The usual symptom is a black screen and a loud buzz from the monitor / display speakers.


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 7 guests