Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

Dwarfen
Atarian
Atarian
Posts: 3
Joined: Thu Aug 02, 2018 3:28 pm

Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby Dwarfen » Thu Aug 02, 2018 3:39 pm

Hi all,

I bought myself an early version of an Atari 520ST with Tos 1.00 with only external floppy SF354 from a childhood friend.
I played with this baby like 25 years ago. The external floppy SF354 did not work anymore but the power supply and the Atari itself works like a charm.

I have now for 3 month trying to get this bad boy to work with an Gotek attatched inside of the SF354.
But i have tried everything i can think of and read forums and googled like 50 hours and no solution.

Im sure i attached the floppy cable right and that the jumpers are in the right place.
I started out with flash floppy but the furtherest i came was to get [Loading HXC Manager ...... on the screen. So i would guess i have the connection right. After trying out like 20 different HFE and CFG files for the Gotek i gave up and bought the HXC Firmweare from https://hxc2001.com/
And upgraded to the latest firmware and not i get [Loading HXC Manager ..... and after like 10 seconds i get 2 classic atari bombs on the screen.

So my question is should i give up this and buy a Atari STFM or STE since with an internal drive they seam to work great?
Or is it possible i have to upgrade my TOS to newer than 1.00?

Would be glad for any tips or suggestions, would love to give this one new life since im bond to it from my childhood :)

Very best regards.
Erik

kolli
Atari User
Atari User
Posts: 42
Joined: Sat Jul 23, 2016 7:37 pm

Re: Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby kolli » Thu Aug 02, 2018 6:43 pm

The Gotek has pin 1 on the connector on the opposite side than a 'normal' floppy drive. And the Jumper for drive select should be set the same as on the original drive. Don't know if it is ds0 or ds1 in the external Atari drives.

Dwarfen
Atarian
Atarian
Posts: 3
Joined: Thu Aug 02, 2018 3:28 pm

Re: Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby Dwarfen » Thu Aug 02, 2018 7:23 pm

Hi,
Yes thats true, and i have mounted the Gotek upside down for this to be in the right direction.
According to a number of forums i have read the jumper on the gotek should be DS0 for the main drive.
What makes me uncertain of the external drive is that the old floppy didnt work, the Atari dont recognice it at all so might be the cable between the floppy case and the atari to i guess ;)
Would make a new cable for the gotek and skip the SF354 if i could get ahold of a 14 Pin Atari connector for a decent price somwhere but havent found one yet =)

Thanks for the reply much appreciated =)

Best regards

ijor
Hardware Guru
Hardware Guru
Posts: 3469
Joined: Sat May 29, 2004 7:52 pm
Contact:

Re: Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby ijor » Thu Aug 02, 2018 8:07 pm

Hard to tell what exactly is the problem.

You obviously has the cable and jumpers mostly right, or otherwise the computer wouldn't boot the HxC Manager. May be there is a problem with the computer, may be with the Gotek.

The small board on some SF354 drives can't be used with double sided drives. Not sure this is your problem, but just in case try to boot a single sided image.

There is no much difference with computers with internal drives. It is mostly an issue of personal preferences. External drive should work fine. Several people reported using a Gotek installed on an external drive case.

TOS version is not the problem here. It might be useful to upgrade for other purposes, but Gotek should work just fine with any TOS.

Jeff_HxC2001
Captain Atari
Captain Atari
Posts: 345
Joined: Fri Sep 21, 2007 7:35 pm
Location: Paris - France
Contact:

Re: Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby Jeff_HxC2001 » Thu Aug 02, 2018 9:25 pm

Dwarfen wrote:Hi all,

I bought myself an early version of an Atari 520ST with Tos 1.00 with only external floppy SF354 from a childhood friend.
I played with this baby like 25 years ago. The external floppy SF354 did not work anymore but the power supply and the Atari itself works like a charm.

I have now for 3 month trying to get this bad boy to work with an Gotek attatched inside of the SF354.
But i have tried everything i can think of and read forums and googled like 50 hours and no solution.

Im sure i attached the floppy cable right and that the jumpers are in the right place.
I started out with flash floppy but the furtherest i came was to get [Loading HXC Manager ...... on the screen. So i would guess i have the connection right. After trying out like 20 different HFE and CFG files for the Gotek i gave up and bought the HXC Firmweare from https://hxc2001.com/
And upgraded to the latest firmware and not i get [Loading HXC Manager ..... and after like 10 seconds i get 2 classic atari bombs on the screen.

So my question is should i give up this and buy a Atari STFM or STE since with an internal drive they seam to work great?
Or is it possible i have to upgrade my TOS to newer than 1.00?

Would be glad for any tips or suggestions, would love to give this one new life since im bond to it from my childhood :)

Very best regards.
Erik


Try this :

-Launch the hxc tool:
https://hxc2001.com/download/floppy_dri ... t_beta.zip

-With the Disk Browser create an empty 360KB dos image. Drag & Drop some files (txt files, prg files...)

-Export the image to AUTOBOOT.HFE (overwrite the normal autoboot.hfe)

- On the ST, check that you can read the files you have pushed to the image.

Dwarfen
Atarian
Atarian
Posts: 3
Joined: Thu Aug 02, 2018 3:28 pm

Re: Early Atari 520 ST Tos 1.00 Upgrade with external Gotek.

Postby Dwarfen » Sun Aug 05, 2018 4:13 pm

Hi,

I have tried out a couple of times now to create a 360kb image and it cant read it either.
It just sais that the disk in A: cant be read.

I also researched abit about my 2 bombs issue and that should indicate som bus problem.
So i guess my SF354 is to broken to use with a gotek, maby i should split the external cable and make an own cable and directly connect to the gotek instead of passing all electronics on the SF354, its the version with some extra IC circuit anyways and i guess that might be an issue to :)

Thanks for the repies.

Best regards


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 8 guests