MEGA ST 2 - what could this strange add on be?

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

fiveofive
Atariator
Atariator
Posts: 19
Joined: Sun Oct 10, 2004 12:07 pm
Contact:

MEGA ST 2 - what could this strange add on be?

Postby fiveofive » Thu Dec 21, 2017 10:43 pm

Hi everyone,

currently, I am checking a long stored Mega 2 machine. It has a button on the back and inside I found this little add on glued on one of the chips (well the glue is gone, so I lay it on the side for the photo). It is this white "board" with the black box attached and some "transistor"-whatever sticking out. It is connected to the button on the right (back of case) and has a little round battery it seems. The white cable leads to the modem port and the PSU, green and blue cables lead to the PSU as well and the black and red cable lead to the fan. The fan appears much more noisy to me than on another Mega ST I tried (Mega ST 1 in that case). So it might be just to turn the fan on and off? Any ideas?

I could not detect any changes of the fan or TOS version or any other reactions when switching and well, if this is a battery it would be empty anyway. It would be good to know if I should remove it or the battery or try to exchange it.

Image

Also, this machine has issues running software from disk, e.g. TOS errors or just stopping after a bit of loading demos and things like that. Maybe some chips are loose, I will try to press them gently and hope this helps. This action definitive fixed another Mega ST 1 machine earlier this year.

Anyway, would be nice what this little button is supposed to do and if I should care about this device, maybe its the source of errors. Any hints are appreciated!

Thanks and Greetings!
505 - Atari, Chiptune & Demoscene - website

fiveofive
Atariator
Atariator
Posts: 19
Joined: Sun Oct 10, 2004 12:07 pm
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby fiveofive » Thu Dec 21, 2017 10:57 pm

The disk errors are now gone and loading software works again. Pressing chips helped. However, that fan now turned off completely. Maybe one of the cables is not sitting properly or so. I wonder if the fan in Mega ST can stay switched off completely or if it will overheat? I read its a problem for Mega STE, but on Mega ST maybe its not necessary?
505 - Atari, Chiptune & Demoscene - website

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2375
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby spiny » Fri Dec 22, 2017 8:10 am

I recall there being a mod that would turn the fan on only when needed, presumably temp related, could be something like that. Instructions are on the vezz site but I'm on my phone so can't look at the archive, will post a link when I'm on a pc

joska
Hardware Guru
Hardware Guru
Posts: 3735
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby joska » Fri Dec 22, 2017 8:52 am

fiveofive wrote:The fan appears much more noisy to me than on another Mega ST I tried (Mega ST 1 in that case). So it might be just to turn the fan on and off?


Ues, it does look like some sort of "Noise Killer". My advice is to remove it and don't bother with the fan. Under normal circumstances the PSU does not get hot. The fan is there for the power user who adds a graphics card and an internal harddrive.
Last edited by joska on Fri Dec 22, 2017 9:08 am, edited 1 time in total.
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2375
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby spiny » Fri Dec 22, 2017 9:00 am

Link:
http://atari4ever.free.fr/hardware/others.html

my german is a bit rusty but the kit listed -is- for controlling the fan, but for the megafile hard drive. which doesn't have a modem port, so probably not what you have in yours :/

fiveofive
Atariator
Atariator
Posts: 19
Joined: Sun Oct 10, 2004 12:07 pm
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby fiveofive » Fri Dec 22, 2017 6:47 pm

Thanks for the replies and information, this makes sense and explains why the fan was turned on or off at times. The button functionality is still a bit of a mystery but I will make more tests tonight.
505 - Atari, Chiptune & Demoscene - website

User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4191
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby DarkLord » Sun Dec 24, 2017 5:48 am

joska wrote:
fiveofive wrote:The fan appears much more noisy to me than on another Mega ST I tried (Mega ST 1 in that case). So it might be just to turn the fan on and off?


Ues, it does look like some sort of "Noise Killer". My advice is to remove it and don't bother with the fan. Under normal circumstances the PSU does not get hot. The fan is there for the power user who adds a graphics card and an internal harddrive.


Well...it might be useful for someone who runs a BBS and keeps their Mega ST4 on 24/7, decades at a time... :roll:
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520

joska
Hardware Guru
Hardware Guru
Posts: 3735
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby joska » Sun Dec 24, 2017 11:41 am

Yes, if you consider stuffing your Mega full of dust "useful" ;)
Jo Even

Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4191
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby DarkLord » Mon Dec 25, 2017 11:12 am

I usually take the cover off and clean it once a year. Oddly
enough, there's not that much dust at all... maybe I've got
a great housekeeper. :)
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520

fiveofive
Atariator
Atariator
Posts: 19
Joined: Sun Oct 10, 2004 12:07 pm
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby fiveofive » Wed Dec 27, 2017 5:23 pm

You guys were right. Later on I found there is a poti on the device to adjust the fan speed (off to "megafile kind of level"). Maybe the button is to switch on/off temperature detection, but I could not really get this working in my tests. However, setting the fan speed is pretty useful as allowed me to reduce noise from the machine quite a lot. Very nice :)
505 - Atari, Chiptune & Demoscene - website

User avatar
1024MAK
Atari Super Hero
Atari Super Hero
Posts: 580
Joined: Sat Aug 01, 2009 2:58 am
Location: Looking forward to summer time in Somerset, UK...

Re: MEGA ST 2 - what could this strange add on be?

Postby 1024MAK » Thu Dec 28, 2017 4:38 am

If the fan control circuit is a simple analogue design (which often uses a variable resistor/preset/pot), the button may just be a test facility, try holding it in and see if the fan speeds up.

Mark
Falcon, Atari 520STFM, Atari 1040STE, more PC's than I care to count and an assortment of 8 bit micros (nearly forgot the Psion's)

fiveofive
Atariator
Atariator
Posts: 19
Joined: Sun Oct 10, 2004 12:07 pm
Contact:

Re: MEGA ST 2 - what could this strange add on be?

Postby fiveofive » Fri Dec 29, 2017 6:35 pm

Thanks Mark. Switching / holding the button did not affect anything like speedup. But the temperature detection seems to work in a way that the fan starts after a while when the machine is in use and not instantly when the machine is switched on.
505 - Atari, Chiptune & Demoscene - website


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 5 guests