520STE weird floppy disk drive problem

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

User avatar
Quickie
Retro freak
Retro freak
Posts: 12
Joined: Thu Nov 30, 2017 7:55 am

Re: 520STE weird floppy disk drive problem

Postby Quickie » Thu Sep 20, 2018 4:02 pm

ijor wrote:
Quickie wrote:Finally the DMA chip arrived and I had time to perform the replacement.
I removed the old DMA chip, soldered a 40 pin socket and placed the new DMA chip, which is a C025913-38 PH23-030 like the previous one.

Actions performed:

- Re-tested the floppy cable pin by pin. All continuity measurements are OK.
- Replaced the CPU for a MC68HC000FN8 just in case
- Inserted the new DMA IC...and suprise, it isn't working but a new error message is displayed:


As I said, replacing the DMA for the same version wasn't probably the best idea. As we have seen in different cases, the DMA issue is not simple and not always requires the same solution.

It is possible that the problem is something else, even at the board. But now that you soldered a socket, trying a different DMA chip version is probably the first thing that you should try.


Hi ijor,

I agree, but unfortunately the DMA was already ordered once I was advised to try another version.
As I said, the interesting thing is that the behavior with those 2 DMA ICs is different with the low power consumption MC68HC CPU, altough they are the same model, but I don't discard further issues on the motherboard.

F.ex.: yesterday I noticed that Y100 oscillator (this is a PAL machine) had one leg corroded (hence a strange sound I barely heard on that area).
But having checked the diagrams it seems that this oscillator has to do with PAL modulated signal, so must be something else.


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: DeepSpace5D and 5 guests