Mega STe black screen moving lines (again)

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

cerror
Retro freak
Retro freak
Posts: 12
Joined: Sun Jun 14, 2015 5:39 pm

Mega STe black screen moving lines (again)

Postby cerror » Wed Apr 13, 2016 7:04 pm

Hello! Me again.

My last thread was almost the same problem, but then with a regular STe.
See: viewtopic.php?t=28155

This time, I got a "cheap" mega ste and it shows practically the same symptoms:
Note: the diagonal lines move horizontally (different speeds)
Image

Tiny difference: When i hit keys on the keyboard: no sound.(also tried with a mega st 4 keyboard) and the floppy drive doesn't initiate.
I tried different (tested working) ram, TOS roms (2.06, also tested working) and a replacement shifter chip (model B instead of D) but no cigar.

I wanted to do the same fix (wich was replacing the
74s257 74hct257 OR 74als257
) but I can't for the life of me find it on the board.
Could be they are using a different but similar chip, but I don't know the location or the corresponding U/R/C + number.....

Does anybody know where the chip is and if it needs to be replaced, or is it another problem?

Please help me restore this mega ste! :cheers:

cerror
Retro freak
Retro freak
Posts: 12
Joined: Sun Jun 14, 2015 5:39 pm

Re: Mega STe black screen moving lines (again)

Postby cerror » Sat Apr 16, 2016 7:34 pm

So I tried Simbo's fix. (other thread I found was him talking about the same problem I had in my earlier thread, but this time about a mega ste)
I removed U504, gave it a socket and placed a new 74LS257 ic.

But, didn't work. Still have the same screen.
Maybe, just maybe, it could be the GST MCU. I saw in a mega ste manual that if you encounter a black screen, it could be the Shifter or GST MCU quote:
Black screen No power (check power supply), bad GSTMCU chip
(U501), bad Video Shifter (U502). See TESTING section,
"Troubleshooting a Dead Unit".


I've tried the shifter, not the gst mcu. Should I start looking for one or could it be something else?

cerror
Retro freak
Retro freak
Posts: 12
Joined: Sun Jun 14, 2015 5:39 pm

Re: Mega STe black screen moving lines (again)

Postby cerror » Fri May 19, 2017 3:41 pm

Long time no see :D
I got another mega ste, but I recently started looking at the broken one.
What I know so far:

- Power supply 12v line is putting out around 4-9v so that's not right.
Swapped psu's with the working mega ste and still no luck.
- No beeps, no floppy drive & no HD initiation.
- Tried a multitude of cpu's, shifter's, ram modules,MFP's, SCC's and rom's (swapping) also no luck.
- The GSTMCU is a surface mounted chip (soldered) and I am not that good at soldering I am affraid. So it can still be that bugger.

I have a GSTMCU replacement here. So I'll try to solder that in the near future. I'll keep you all updated (if you're at all interested at all :P )

User avatar
exxos
Hardware Guru
Hardware Guru
Posts: 4933
Joined: Fri Mar 28, 2003 8:36 pm
Location: England
Contact:

Re: Mega STe black screen moving lines (again)

Postby exxos » Fri May 19, 2017 3:48 pm

If the PSU is known working and its only outputting 4-9V then likely something is shorting out the PSU dragging down the voltages. Something would be getting very hot to short out the PSU like that. Likely the PSU is "ticking" into protection mode which is likely why the voltage is low.

Normally things like that are when some dumbass has put the ROM chips in backwards or something equally imaginative :)

You should probably take the PSU out of the duff machine measure the GND to 5V and 12V with a meter on resistance and see what you get. Compare to a working machine. Might give some clues.
4MB STFM 1.44 FD- VELOCE+ 020 STE - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - various clutter

http://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
http://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.
http://ataristeven.exxoshost.co.uk/Steem.htm Latest Steem Emulator


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 9 guests