NEW IDE Controller & TOS 2.06 board (with extras)

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

User avatar
tjlazer
Atari Super Hero
Atari Super Hero
Posts: 635
Joined: Mon Feb 02, 2004 4:00 am
Location: Tacoma, WA USA
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby tjlazer » Tue May 21, 2013 10:26 pm

Thanks for the info! Any idea on when this next batch will be ready?
Atari Computer Collector since 1984

From the 8-bit Atari 400 to the 32-bit Atari TT030!

alanh
Hardware Guru
Hardware Guru
Posts: 1384
Joined: Mon Jul 24, 2006 9:01 pm
Location: North Wales, UK

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby alanh » Tue May 21, 2013 10:51 pm

I'd guess about 3 weeks.
Falcon CT60, Falcon CT63 x2, TT x3, MegaST x2, MegaSTE x2, STFM x2, STE x2, STacy, STBook, (Dead) Hades 060, Milan 060, T40.

RA_pdx
Captain Atari
Captain Atari
Posts: 215
Joined: Sun Feb 02, 2003 12:01 pm
Location: Nuernberg/GERMANY

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby RA_pdx » Wed May 22, 2013 8:19 am

Hi. Just want to say that i got my two boards last week.
I have tested the standard STE board with HDDRIVER 8.46 and a 1,8" 8GB SLC SSD from KingSpec and it works fine. :) It´s plugged in a 1040STE with 4MB, MC68010 and TOS 2.06.
I will post benchmarks the next days.

Thanks Alanh for your great work!!!
>> > raZen/Paradox < <<

Atari 1040STE, TOS 2.06, 4MB, MC68010, IDE 8GB SSD, Gigafile

alanh
Hardware Guru
Hardware Guru
Posts: 1384
Joined: Mon Jul 24, 2006 9:01 pm
Location: North Wales, UK

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby alanh » Wed May 22, 2013 8:43 am

Wonderful. Thanks for the report. Great to see another one up and running !
Falcon CT60, Falcon CT63 x2, TT x3, MegaST x2, MegaSTE x2, STFM x2, STE x2, STacy, STBook, (Dead) Hades 060, Milan 060, T40.

User avatar
Decky
Captain Atari
Captain Atari
Posts: 175
Joined: Wed Apr 15, 2009 9:22 pm
Location: Belfast, N. Ireland

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Decky » Wed May 22, 2013 2:04 pm

Just a quick question. Is HDDriver the only driver that can be used with the IDE Controller board? It's just a bit pricey at 44 euro!
Atari STe 4Mb with TOS 1.62 / 2.06 Switchable, thanks to Techie Alison. UltraSatan, CosmosEx, Gotek

alanh
Hardware Guru
Hardware Guru
Posts: 1384
Joined: Mon Jul 24, 2006 9:01 pm
Location: North Wales, UK

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby alanh » Wed May 22, 2013 2:26 pm

It should work fine with AHDI, CBHD etc as it operates the same way for the primary port.

But only HDDriver can operate the secondary port.
Falcon CT60, Falcon CT63 x2, TT x3, MegaST x2, MegaSTE x2, STFM x2, STE x2, STacy, STBook, (Dead) Hades 060, Milan 060, T40.

lschafroth
Captain Atari
Captain Atari
Posts: 176
Joined: Thu Feb 17, 2011 3:01 pm

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby lschafroth » Wed May 22, 2013 2:34 pm

Decky wrote:Just a quick question. Is HDDriver the only driver that can be used with the IDE Controller board? It's just a bit pricey at 44 euro!


They would probably sell a lot more if the price was reasonable like $20. Some people didnt even pay 44 euro for their system. :) lol
I know its still supported so they need to be rewarded for their work, but I think the price could be adjusted.

RA_pdx
Captain Atari
Captain Atari
Posts: 215
Joined: Sun Feb 02, 2003 12:01 pm
Location: Nuernberg/GERMANY

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby RA_pdx » Wed May 22, 2013 7:03 pm

And here are the promised benchmark results using AHPT94:

Logical drives:
Transfare rate: 1105 KB/s
Access time: 2.7 mS

Combined Read/Write tests
Short files: 53/21 KB/s
Medium files: 606/333 KB/s
Long files: 966/787 KB/s
Access time: 19.5 mS

I tested an almost empty 120 MB partition on my SLC SSD.

Direct hardware access (PIO):
Transfer rate: 1146 KB/s
Access time: 0.5 mS

Direct hardware access (Blit):
Transfer rate: 1238 KB/s
Access time: 0.5 mS

Direct hardware access (HOG):
Transfer rate: 1374 KB/s
Access time: 0.5 mS
Last edited by RA_pdx on Wed May 22, 2013 7:39 pm, edited 2 times in total.
>> > raZen/Paradox < <<

Atari 1040STE, TOS 2.06, 4MB, MC68010, IDE 8GB SSD, Gigafile

alanh
Hardware Guru
Hardware Guru
Posts: 1384
Joined: Mon Jul 24, 2006 9:01 pm
Location: North Wales, UK

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby alanh » Wed May 22, 2013 7:23 pm

Did you test that using the partition tests or the master/slave window ?

The master/slave window has HOG mode which uses the blitter, so might want to try seeing if they have a boost to your numbers.
Falcon CT60, Falcon CT63 x2, TT x3, MegaST x2, MegaSTE x2, STFM x2, STE x2, STacy, STBook, (Dead) Hades 060, Milan 060, T40.

RA_pdx
Captain Atari
Captain Atari
Posts: 215
Joined: Sun Feb 02, 2003 12:01 pm
Location: Nuernberg/GERMANY

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby RA_pdx » Wed May 22, 2013 7:36 pm

alanh wrote:Did you test that using the partition tests or the master/slave window ?
The master/slave window has HOG mode which uses the blitter, so might want to try seeing if they have a boost to your numbers.

I have updated my previous post.
>> > raZen/Paradox < <<

Atari 1040STE, TOS 2.06, 4MB, MC68010, IDE 8GB SSD, Gigafile

Sasatari
Atarian
Atarian
Posts: 6
Joined: Mon Feb 04, 2013 12:37 pm
Location: Northern Germany
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Sasatari » Thu May 23, 2013 8:56 am

alanh wrote:PM'd you.


Thank you so much. It seems that I even can´t answer to PMs yet, so I write here again. Money is sent, think you´ll recognize it´s me.

Sascha

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Dal » Thu May 23, 2013 12:08 pm

Now you have more than 3 posts, you should have full user access. Let me know if this isn't the case.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
Decky
Captain Atari
Captain Atari
Posts: 175
Joined: Wed Apr 15, 2009 9:22 pm
Location: Belfast, N. Ireland

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Decky » Fri May 24, 2013 12:04 am

Has anyone done a tutorial on using HDDriver with both IDE connections?
Atari STe 4Mb with TOS 1.62 / 2.06 Switchable, thanks to Techie Alison. UltraSatan, CosmosEx, Gotek

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Dal » Fri May 24, 2013 6:27 am

Nothing to it:
Use HDDRIVER >=8.46
Run the "Auto-Configuring" menu command.
Both IDE channels are now recognised and accessible.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2978
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby AtariZoll » Fri May 24, 2013 7:41 am

alanh wrote:It should work fine with AHDI, CBHD etc as it operates the same way for the primary port.
But only HDDriver can operate the secondary port.


It is not problem to add support for secondary IDE port - if there is interested people. Price still 10 Euros.
http://atari.8bitchip.info/pphdr.php
Famous Schrodinger's cat hypothetical experiment says that cat is dead or alive until we open box and see condition of poor animal, which deserved better logic. Cat is always in some certain state - regardless from is observer able or not to see what the state is.

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2978
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby AtariZoll » Fri May 24, 2013 7:46 am

RA_pdx wrote:And here are the promised benchmark results using AHPT94:

Logical drives:
Transfare rate: 1105 KB/s
Access time: 2.7 mS

Combined Read/Write tests
Short files: 53/21 KB/s
Medium files: 606/333 KB/s
Long files: 966/787 KB/s
Access time: 19.5 mS

I tested an almost empty 120 MB partition on my SLC SSD.

Direct hardware access (PIO):
Transfer rate: 1146 KB/s
Access time: 0.5 mS

Direct hardware access (Blit):
Transfer rate: 1238 KB/s
Access time: 0.5 mS

Direct hardware access (HOG):
Transfer rate: 1374 KB/s
Access time: 0.5 mS


Just a note: Direct HW tests work regardless from partitions, so it is irrelevant is part. empty or full.
Interesting is that SSD is slower here in transfer than most of classic hard disks, or CF cards. Likely because not designed for slow oldies :D
Famous Schrodinger's cat hypothetical experiment says that cat is dead or alive until we open box and see condition of poor animal, which deserved better logic. Cat is always in some certain state - regardless from is observer able or not to see what the state is.

alanh
Hardware Guru
Hardware Guru
Posts: 1384
Joined: Mon Jul 24, 2006 9:01 pm
Location: North Wales, UK

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby alanh » Fri May 24, 2013 7:49 am

Thought that myself. I typically get 1200-1300KB/s on the partition test, and with HOG mode I've seen 1700+KB/s.
Falcon CT60, Falcon CT63 x2, TT x3, MegaST x2, MegaSTE x2, STFM x2, STE x2, STacy, STBook, (Dead) Hades 060, Milan 060, T40.

RA_pdx
Captain Atari
Captain Atari
Posts: 215
Joined: Sun Feb 02, 2003 12:01 pm
Location: Nuernberg/GERMANY

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby RA_pdx » Fri May 24, 2013 9:00 am

I think the problem is that modern SSD´s and HD´s uses 4096 byte sectors and TOS uses 512 byte sectors. That results in a slow down for these devices because the drive has to emulate the 512 byte sectors.
>> > raZen/Paradox < <<

Atari 1040STE, TOS 2.06, 4MB, MC68010, IDE 8GB SSD, Gigafile

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2978
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby AtariZoll » Sat May 25, 2013 6:36 am

Of course no 4KB sectors . And even, if would, it matters not - test SW works with 128KB blocks, and reads 10MB in row.
Famous Schrodinger's cat hypothetical experiment says that cat is dead or alive until we open box and see condition of poor animal, which deserved better logic. Cat is always in some certain state - regardless from is observer able or not to see what the state is.

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2617
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby spiny » Sat May 25, 2013 9:32 am

Finally got the small IDE cables in the post this morning (a bit of an oversight there, should have ordered them before the board turned up :D ) and I now have a working 256meg card in my STe :)

possible stupid question: can these be set to boot from the card ? I've had a quick play and can't seem to get it to work. If they can, then I'll keep at it :)

User avatar
simonsunnyboy
Moderator
Moderator
Posts: 5116
Joined: Wed Oct 23, 2002 4:36 pm
Location: Friedrichshafen, Germany
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby simonsunnyboy » Sat May 25, 2013 9:50 am

spiny wrote:Finally got the small IDE cables in the post this morning (a bit of an oversight there, should have ordered them before the board turned up :D ) and I now have a working 256meg card in my STe :)

possible stupid question: can these be set to boot from the card ? I've had a quick play and can't seem to get it to work. If they can, then I'll keep at it :)


To have autoboot from IDE you normally need TOS 2.06 or a special patchd version. Or you have an ACSI device which autoboots and provides a driver for the IDE too. I think HDDriver would do the job if booted from a Megafile or so and configured to detect and use IDE too.
Simon Sunnyboy/Paradize - http://paradize.atari.org/

Stay cool, stay Atari!

1x2600jr, 1x1040STFm, 1x1040STE 4MB+TOS2.06+SatanDisk, 1xF030 14MB+FPU+NetUS-Bee

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2617
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby spiny » Sat May 25, 2013 9:56 am

cool, the STe I used is still on 1.62, so that makes sense.
I've been meaning to upgrade this one anyway, so this is a perfect reason to start :)

zonky900
Atari User
Atari User
Posts: 34
Joined: Mon Jan 21, 2013 4:24 am

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby zonky900 » Mon May 27, 2013 2:45 am

Last time I posted in this thread I expressed interest in something for my STfm, but I sold my STfm off since it was very messed up!

I now am the proud owner of a 1040STe loaded up with 4MB RAM, however I already flashed some chips with TOS 2.06, could I still do some fun stuff with alternate OSes though? Maybe a chip loaded up with an old Mac System 6 or 7, instead of having to boot if off floppy always? :coffe:

Either way I would really love to have a IDE interface in my STe so let me know, i might really grab one in the next batch!

athensnet
Atari nerd
Atari nerd
Posts: 49
Joined: Sat May 11, 2013 8:27 pm

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby athensnet » Mon May 27, 2013 10:48 am

Dear Alanh,

I have just received this morning the board. At the best possible packaging.
Now I am a little bit furstrated. According to the details sent I thought that the pins would be only the ones spotted with red, but I see that the pins are at the full extension of the CPU rectangle. Could you please guide me about the orientation of the Board positioning it on the CPU? I suppose the board is providing also power to the Hard disk 2.5? Also on the CPU there is something like a crossed shield (sorry for the description but I cannot find the exact word, but you understand what I mean). How can I take this off?
Thank you

User avatar
Decky
Captain Atari
Captain Atari
Posts: 175
Joined: Wed Apr 15, 2009 9:22 pm
Location: Belfast, N. Ireland

Re: NEW IDE Controller & TOS 2.06 board (with extras)

Postby Decky » Mon May 27, 2013 3:30 pm

Here's a photo of my board set on top of the processor and the second one is it fully in place. fitted to my 1040STe

Image

Image
Atari STe 4Mb with TOS 1.62 / 2.06 Switchable, thanks to Techie Alison. UltraSatan, CosmosEx, Gotek


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 5 guests