Ive taken this apart... & my hands are still clean...?

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

snulty1
Atarian
Atarian
Posts: 2
Joined: Fri May 28, 2010 5:01 pm

Ive taken this apart... & my hands are still clean...?

Postby snulty1 » Fri May 28, 2010 6:12 pm

Hello guys.... Im Lost! Usually my living room is filled with car parts... not today...

Image

A friend gave a me an atari 520st the other day with a heap of games, when i finally remembered that a had to tune my tv in to find it!!! :lol: When i did i got as far as this ...

Image
:(

If i click on B...

Image

And when i click OK the first message appears again.

I done quite a bit of reading and searching on the forum and came to the conclusion that i needed a new floppy drive... but i think it has one?

Image
Image

Im not sure if the previous owner has tried to install the new drive and failed or its not been installed properly...
So im guessing next on the list is to, clean & demagnetize the drive?

Im sure this has been discussed a million times :oops: But i did have a search but it seems it could be caused by numerous things? Im not too good and working with things that involve me keeping clean :lol:

Thanks in advance, Sean.

User avatar
Mug UK
Administrator
Administrator
Posts: 11422
Joined: Thu Apr 29, 2004 7:16 pm
Location: Stockport (UK)
Contact:

Re: Ive taken this apart... & my hands are still clean...?

Postby Mug UK » Fri May 28, 2010 7:10 pm

Welcome aboard - hopefully someone will be able to lend you a hand (virtually) and help fix your drive.

Your next two posts will have to be moderated but that's just a spam prevention measure. Once you reach 4 posts, you're free of the moderators/admin's clutches :)
My main site: http://www.mug-uk.co.uk - slowly digging up the bits from my past (and re-working a few): Atari ST, Sega 8-bit (game hacks) and NDS (Music ripping guide).

I develop a free Word (for Windows) add-in that's available for Word 2007 upwards. It's a fix-it toolbox that will allow power Word users to fix document errors. You can find it at: http://www.mikestoolbox.co.uk

MRAtari
Captain Atari
Captain Atari
Posts: 494
Joined: Thu Apr 05, 2007 5:03 pm

Re: Ive taken this apart... & my hands are still clean...?

Postby MRAtari » Fri May 28, 2010 7:15 pm

well there's no way the drive in your picture is a new one, it's an old Sony as used in a lot of atari st's and has like you say probably died

either that or the disks you are using are corrupt

if you have some new or good decent disks try formatting a disk

if it is the drive then you need another one

someone on ebay is selling one already modded to make it easy

http://cgi.ebay.co.uk/Atari-ST-STE-Mega ... 2307022a69

good luck

User avatar
techie_alison
Administrator
Administrator
Posts: 1547
Joined: Tue Aug 23, 2005 10:06 am
Location: Cambridge, UK
Contact:

Re: Ive taken this apart... & my hands are still clean...?

Postby techie_alison » Fri May 28, 2010 8:25 pm

Oooooh, I like!! Pictures are ALWAYS good. OK I'll admit it, I'm just nosey!!

:)
If I don't answer or appear to have forgotton then email again, I'm scatty! :)

http://www.logicsays.com/ = Updated Site
http://www.logicsays.com/index1 = Older Site (with more Atari)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12781
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Ive taken this apart... & my hands are still clean...?

Postby wongck » Sat May 29, 2010 4:10 am

The problems are usually:
1. Bad floppy drive
2. Bad floppy diskettes
3. Rare electronics issues with the floppy controller.

Most likely 1 or 2 or both.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

snulty1
Atarian
Atarian
Posts: 2
Joined: Fri May 28, 2010 5:01 pm

Re: Ive taken this apart... & my hands are still clean...?

Postby snulty1 » Sat May 29, 2010 6:56 am

Thanks for the reply's guy's & Girls! ( Even if you are just nosey Yellow_Colorz_PDT_42 )

I like pictures too ... Not ALWAYS a good idea tho!

Riteo, I tried quite a lot of diskettes so I'm just gonna buy one of those and plug it in see how goes! :thumbs: Anything else I should do while I'm at it?

I had no idea until i found this forum that people were this big into modding these old things! I read the mission statement &I think its really cool, Keep it up Yellow_Colorz_PDT_15

Sean.


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 7 guests