Atari mouse scroll problem!

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

8bitbubsy
Atariator
Atariator
Posts: 22
Joined: Sun Nov 22, 2009 9:15 am
Location: Norway
Contact:

Atari mouse scroll problem!

Postby 8bitbubsy » Fri Nov 27, 2009 5:55 pm

I have this "good" old original Atari ST mouse... Today, I opened it up and cleaned the 'scroll pins' with alcohol, now they're shiny. Anyways, when I connect the mouse to my ST, it does only scroll up or left. If I move the mouse to the right, or down, it goes .. to the left or up!!

What is this?! Common problem? Resistor problem? Etc.. Help appriciated! :D

User avatar
nativ
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4106
Joined: Mon Jul 30, 2007 10:26 am
Location: South West, UK

Re: Atari mouse scroll problem!

Postby nativ » Sat Nov 28, 2009 10:58 am

Hi,

Not sure about the mouse, hopefully someone else will help!

Are you booting with from cold with no disks? Some behaviour similar to what you describe might be the 'GHOST' virus.

Download Ultimate Virus Killer! Check your disks!

Regards,

Ashley
Atari STFM 512 / STe 4MB / Mega ST+DSP / Falcon 4MB 16Mhz 68882 - DVD/CDRW/ZIP/DAT - FDI / Jaguar / Lynx 1&2 / 7800 / 2600 / XE 130+SD Card // Sega Dreamcast / Mega2+CD2 // Apple G4

http://soundcloud.com/nativ ~ http://soundcloud.com/nativ-1 ~ http://soundcloud.com/knot_music
http://soundcloud.com/push-sounds ~ http://soundcloud.com/push-records

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12789
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Atari mouse scroll problem!

Postby wongck » Sat Nov 28, 2009 1:24 pm

Not sure if this tread is any help - Problem: Erratic Mouse Movement :roll:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

8bitbubsy
Atariator
Atariator
Posts: 22
Joined: Sun Nov 22, 2009 9:15 am
Location: Norway
Contact:

Re: Atari mouse scroll problem!

Postby 8bitbubsy » Sat Nov 28, 2009 3:03 pm

No, I don't boot with any disk... I don't have any Atari ST floppies either. :roll:
Well, I've read that thread before... I've cleaned the "scroll pins" in my mouse with alcohol, and I've resoldered the mouse/joystick ports.
Still exactly the same issue... :x

User avatar
Jake/Depression
Captain Atari
Captain Atari
Posts: 484
Joined: Fri Dec 24, 2004 1:40 am
Location: Finland

Re: Atari mouse scroll problem!

Postby Jake/Depression » Sat Nov 28, 2009 6:47 pm

Mayby broblem is in port where mouse coming in machine. (Test it keeping mouse cabel down or up near place where it goming in machine.)
-soimaamme toinen toista ja unohdamme tulta kohentaa-

User avatar
nativ
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4106
Joined: Mon Jul 30, 2007 10:26 am
Location: South West, UK

Re: Atari mouse scroll problem!

Postby nativ » Sat Nov 28, 2009 8:17 pm

Hi,

Other problem can be breaks in the mouse cable.

Try gently pinching the lead and running from one end to the other, then do this in the opposite direction, Strech then compact! This has worked on some ropey old mice before!

Regards
Atari STFM 512 / STe 4MB / Mega ST+DSP / Falcon 4MB 16Mhz 68882 - DVD/CDRW/ZIP/DAT - FDI / Jaguar / Lynx 1&2 / 7800 / 2600 / XE 130+SD Card // Sega Dreamcast / Mega2+CD2 // Apple G4

http://soundcloud.com/nativ ~ http://soundcloud.com/nativ-1 ~ http://soundcloud.com/knot_music
http://soundcloud.com/push-sounds ~ http://soundcloud.com/push-records

User avatar
1024MAK
Atari Super Hero
Atari Super Hero
Posts: 632
Joined: Sat Aug 01, 2009 2:58 am
Location: Looking forward to summer time in Somerset, UK...

Re: Atari mouse scroll problem!

Postby 1024MAK » Sun Nov 29, 2009 1:48 am

Is this problem mouse an Atari made mouse?
If it was made my another company it could be that there is a switch that selects Atari ST mode or Amiga mode - if so check this switch, if it is in the correct position switch it back and forth a few times, then try again :)
Falcon, Atari 520ST, 520STFM, 1040STE, Mega, TT and more PC's than I care to count and an assortment of 8 bit micros (nearly forgot the Psion's).
Visit the Atari-Forum Wiki. Lots of technical info at DrCoolZic Atari ST Site :D

8bitbubsy
Atariator
Atariator
Posts: 22
Joined: Sun Nov 22, 2009 9:15 am
Location: Norway
Contact:

Re: Atari mouse scroll problem!

Postby 8bitbubsy » Sun Nov 29, 2009 3:10 am

nativ wrote:Hi,

Other problem can be breaks in the mouse cable.

Try gently pinching the lead and running from one end to the other, then do this in the opposite direction, Strech then compact! This has worked on some ropey old mice before!

Regards

Wow! I tried to pinch the mouse at the very end (where the plug is), and now I can move to the left too... But not down...
Defintely a bad wire... I want to change it, but it's not easy when it's in the very end! Gah, maybe I should steal one from an Amiga Mouse :D And reroute it, if needed.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12789
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Atari mouse scroll problem!

Postby wongck » Sun Nov 29, 2009 3:26 am

My experience with this type of behaviour is usually a bad connections on the wires particularly at the point where it connects up to the sockets beneath the keybroad. Normaly I whould give a good push into the socket and move the wires around that area, this maneuver seems to work for me. :mrgreen:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
atarimusic[dot]net
Atari freak
Atari freak
Posts: 57
Joined: Tue Aug 18, 2009 5:59 pm

Re: Atari mouse scroll problem!

Postby atarimusic[dot]net » Mon Dec 07, 2009 4:27 am

deleted/irrelevant post
Last edited by atarimusic[dot]net on Tue Dec 08, 2009 3:54 am, edited 1 time in total.

8bitbubsy
Atariator
Atariator
Posts: 22
Joined: Sun Nov 22, 2009 9:15 am
Location: Norway
Contact:

Re: Atari mouse scroll problem!

Postby 8bitbubsy » Mon Dec 07, 2009 9:52 am

8bitbubsy wrote:[...] and I've resoldered the mouse/joystick ports.


8bitbubsy wrote:Wow! I tried to pinch the mouse at the very end (where the plug is), and now I can move to the left too... But not down...
Defintely a bad wire... [...]

No offense, but reading is not dangerous. :)


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 5 guests